summaryrefslogtreecommitdiff
path: root/app-emacs/protbuf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/protbuf
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/protbuf')
-rw-r--r--app-emacs/protbuf/Manifest4
-rw-r--r--app-emacs/protbuf/files/50protbuf-gentoo.el12
-rw-r--r--app-emacs/protbuf/metadata.xml9
-rw-r--r--app-emacs/protbuf/protbuf-1.7-r1.ebuild17
4 files changed, 42 insertions, 0 deletions
diff --git a/app-emacs/protbuf/Manifest b/app-emacs/protbuf/Manifest
new file mode 100644
index 000000000000..527c89db6faa
--- /dev/null
+++ b/app-emacs/protbuf/Manifest
@@ -0,0 +1,4 @@
+AUX 50protbuf-gentoo.el 529 BLAKE2B 49ab3c50c3093fa9895f3adfd9084143eb395e700f0b30c4fe36e73436e368475142d4f0a0e458f54d36a468f60cfebe56491c2618aeec8c68ecfd6cf3289020 SHA512 f1cd37bdeb9568cbff9ffb989334237213b8c1bc50704195708fcac4848cc3c128c8121422a0ea42af8c2ee94647e325cd293e4b29c513ad8cdeb37d33fd3f4c
+DIST protbuf-1.7.tar.bz2 2270 BLAKE2B fa840549e785dcccbca53e4ddad7b6572f6da0191d3b82544ed562a4e1d6e6a28e1cc44aaf81498a0f6c8f9ef6d37451104b6552bb0c8469029d0589489d03e5 SHA512 9dad81784b71234812ac35be695895c3063e5337dddbed73b28fde800d12110cec6bb9faa42b6ed74d9a2d4f12da96b8e692d193edfc775fd33a7922a019b8b2
+EBUILD protbuf-1.7-r1.ebuild 428 BLAKE2B 54a1b73625827ac00432da8c06462e4521ae13efc8e46fa6d8c3d6d4d12af38de88c9af7d9e04b19c5431abcf717eefb703ded174440357454cb71db825aa84f SHA512 d7f3a6edbf92e455f4cee976b53b202c50e77801e9aa3c5494286417d7f9fe3908ab40c4db0365b99d429d46c51677781e04aa1354357b24fd21f45a6cba269b
+MISC metadata.xml 282 BLAKE2B 432e60a3b04def9f566fde3852011e006c0d578c72c42115734d1af5c128440fcee68134c8f891baad437e64a8d61fbbac49e70a35ed4f6f85641e888d3a2547 SHA512 1838e22e1f5b849b816a05d1b25bd81333c8cf67ceb996177e05ba7a555b8e0e307e62cb53e6f1217f4216823e2fecf050e85437678503d60e10c6b2d5303072
diff --git a/app-emacs/protbuf/files/50protbuf-gentoo.el b/app-emacs/protbuf/files/50protbuf-gentoo.el
new file mode 100644
index 000000000000..f64466f67ed8
--- /dev/null
+++ b/app-emacs/protbuf/files/50protbuf-gentoo.el
@@ -0,0 +1,12 @@
+(add-to-list 'load-path "@SITELISP@")
+
+(autoload 'protect-buffer-from-kill-mode "protbuf"
+ "Protect buffer from being killed.
+To remove this protection, call this command with a negative prefix argument."
+ t)
+(autoload 'protect-process-buffer-from-kill-mode "protbuf"
+ "Protect buffer from being killed as long as it has an active process.
+To remove this protection, call this command with a negative prefix argument."
+ t)
+(autoload 'protect-buffer-from-kill "protbuf")
+(autoload 'protect-process-buffer-from-kill "protbuf")
diff --git a/app-emacs/protbuf/metadata.xml b/app-emacs/protbuf/metadata.xml
new file mode 100644
index 000000000000..c918cdef9591
--- /dev/null
+++ b/app-emacs/protbuf/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<stabilize-allarches/>
+</pkgmetadata>
diff --git a/app-emacs/protbuf/protbuf-1.7-r1.ebuild b/app-emacs/protbuf/protbuf-1.7-r1.ebuild
new file mode 100644
index 000000000000..f175a542b6b0
--- /dev/null
+++ b/app-emacs/protbuf/protbuf-1.7-r1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Protect Emacs buffers from accidental killing"
+HOMEPAGE="http://www.splode.com/~friedman/software/emacs-lisp/
+ https://www.emacswiki.org/emacs/ProtectingBuffers"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+
+SITEFILE="50${PN}-gentoo.el"