summaryrefslogtreecommitdiff
path: root/app-emacs/powershell
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /app-emacs/powershell
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'app-emacs/powershell')
-rw-r--r--app-emacs/powershell/Manifest4
-rw-r--r--app-emacs/powershell/files/50powershell-gentoo.el6
-rw-r--r--app-emacs/powershell/metadata.xml14
-rw-r--r--app-emacs/powershell/powershell-0.3_pre20220402.ebuild21
4 files changed, 45 insertions, 0 deletions
diff --git a/app-emacs/powershell/Manifest b/app-emacs/powershell/Manifest
new file mode 100644
index 000000000000..b1cb88f9697e
--- /dev/null
+++ b/app-emacs/powershell/Manifest
@@ -0,0 +1,4 @@
+AUX 50powershell-gentoo.el 267 BLAKE2B ca2712812fe037fc498193a1d88476da61765af5308183cfa7537fe3dda797f480d89cb282276d517efad27bc53f520e95d0b9bb507961a84ebc772e01091603 SHA512 99214edd95150f4f366778f0db472bad7869a579e6b0635a6e37e74f7d389a293a226fff4b8eed9009ae388885a2305423530b3eb9306e4f3f6847e606af095b
+DIST powershell-0.3_pre20220402.tar.gz 17009 BLAKE2B c369993bc4ac0e681dde514c4303f6c131198e77f6aa3b293ecedefa552e8f2b94e8ab77978ff2f8d999a4b620fa4e013023a283e0a2c30f6578428bc54fe52d SHA512 2d38f1a968119a2022e1f3eceb8150947559e5e7943d184fec3b8075cc2dc8d97b5a897bc1ac97b14d69d9424b72ca20f01d24589403936b1ca2bc7becc2ea0f
+EBUILD powershell-0.3_pre20220402.ebuild 515 BLAKE2B 638ff0c7898290a2987e7866d2c0048d9ccc611dc101db01d50fefc915b5fa1bc440934391a740212df593c0b8f1003d785d2afab05557171d6740876753a0cb SHA512 705aca3322e1f7b3ca965518139a3effc9049b23658503d05f05bfc7f7989e0920d5104e72b521c7de5b3bcc2c95c2892be20732afadff4ad8c175c3dd9df360
+MISC metadata.xml 454 BLAKE2B 84931c284b0bc9dc20204737b54377498fef87eeb0a7d7d6cf956280f41b25fdd577306a39f5da937d4f4d84f80cffa8e8a11211ead5a98603ff7674214924f2 SHA512 4d3c39a70fefa9b07afb59cc46f438e2f64ceed173dad3e5bcaec342931c40b31b9f4474a851df3d554dbfece7fa5448d147da7d451290d02c640f1b9955b34d
diff --git a/app-emacs/powershell/files/50powershell-gentoo.el b/app-emacs/powershell/files/50powershell-gentoo.el
new file mode 100644
index 000000000000..e97cc3554edc
--- /dev/null
+++ b/app-emacs/powershell/files/50powershell-gentoo.el
@@ -0,0 +1,6 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'powershell "powershell"
+ "Run an inferior PowerShell." t)
+(autoload 'powershell-mode "powershell"
+ "Major mode for editing PowerShell scripts." t)
+(add-to-list 'auto-mode-alist '("\\.ps[dm]?1\\'" . powershell-mode))
diff --git a/app-emacs/powershell/metadata.xml b/app-emacs/powershell/metadata.xml
new file mode 100644
index 000000000000..ed7371a06f5f
--- /dev/null
+++ b/app-emacs/powershell/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <bugs-to>https://github.com/jschaf/powershell.el/issues/</bugs-to>
+ <remote-id type="github">jschaf/powershell.el</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/powershell/powershell-0.3_pre20220402.ebuild b/app-emacs/powershell/powershell-0.3_pre20220402.ebuild
new file mode 100644
index 000000000000..6d53582ddb59
--- /dev/null
+++ b/app-emacs/powershell/powershell-0.3_pre20220402.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=77b27faf8a292f1dc9f54c872241dc53b6791bf1
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="GNU Emacs mode for editing and running PowerShell code"
+HOMEPAGE="https://github.com/jschaf/powershell.el/"
+SRC_URI="https://github.com/jschaf/${PN}.el/archive/${H}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}.el-${H}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"