summaryrefslogtreecommitdiff
path: root/app-emacs/popwin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/popwin
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/popwin')
-rw-r--r--app-emacs/popwin/Manifest4
-rw-r--r--app-emacs/popwin/files/50popwin-gentoo.el6
-rw-r--r--app-emacs/popwin/metadata.xml15
-rw-r--r--app-emacs/popwin/popwin-0.6.2.ebuild22
4 files changed, 47 insertions, 0 deletions
diff --git a/app-emacs/popwin/Manifest b/app-emacs/popwin/Manifest
new file mode 100644
index 000000000000..b3cca907614a
--- /dev/null
+++ b/app-emacs/popwin/Manifest
@@ -0,0 +1,4 @@
+AUX 50popwin-gentoo.el 336 BLAKE2B 5f76341b524d373ed3aa8d15e99123f5be33a45eed4e865f647e8c40353bceefb8775dabadce9f0cbb630742893de1354dd09062ccc2cc4c4c68484ee380a02d SHA512 a9b72edf953d67a16aad44186d3f0f3deead224ce57342d73ba43abe15c0c2b170311380926d1195d98884b6e64fbeca23b74c3dd9a67b13015ec0b491861905
+DIST popwin-0.6.2.tar.gz 16821 BLAKE2B 6fcf2e711c28db3465fd4e267195f8526eff26aedeb04f07d66f5adac83f2447beef1ee988f692b9062a0e0eabbbe0760d3df6f1f7679fb4ab76317237aa8fdf SHA512 3c086361d6b79d7c68583cdbfb76cfd95b6ed56883382e42a863137d93e2a64fa8dce7b7873a4c46ce04a742942dd5f16367c691be608438079555578709b108
+EBUILD popwin-0.6.2.ebuild 471 BLAKE2B d76ac412dbdefe4a1449bd95b0552d5605e5fa5f27e4f4c4d2400b8f4bccaf3954d994e729927fb1537949aa4fdc52ba0af14ae234520b9bb88ca8000c2225b7 SHA512 a4dbeca3a4bd29b666fc533e01315fe02dae86ffad5653559ca3c4443189faf2b987d3b7960d04afa0a01425cc28f3a4f663d02b4bd56fd237bda367dcfedd23
+MISC metadata.xml 434 BLAKE2B 7a3d9e391906d94c7325bb2b3037ac72a17592c7000ea7952d1a24307972ac5e76197ab65757111c67b9e08714b5e8af3e96afa6b01ec6ebaba522bb07edcdcb SHA512 aecd01bc0b93d462be5de0f33709bde26740f9d5c86b926201a215c6eeedf79f8216d9906260f61b65f81f5850b958d1ac94a767775ddacee6df4547ec01efe9
diff --git a/app-emacs/popwin/files/50popwin-gentoo.el b/app-emacs/popwin/files/50popwin-gentoo.el
new file mode 100644
index 000000000000..bd00744ede00
--- /dev/null
+++ b/app-emacs/popwin/files/50popwin-gentoo.el
@@ -0,0 +1,6 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'popwin:display-buffer "popwin"
+ "Display BUFFER-OR-NAME, if possible, in a popup window, or as usual.
+This function can be used as a value of `display-buffer-function'." t)
+(autoload 'popwin:special-display-popup-window "popwin"
+ "The `special-display-function' with a popup window.")
diff --git a/app-emacs/popwin/metadata.xml b/app-emacs/popwin/metadata.xml
new file mode 100644
index 000000000000..ab2dca535eae
--- /dev/null
+++ b/app-emacs/popwin/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>naota@gentoo.org</email>
+</maintainer>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<stabilize-allarches/>
+<upstream>
+ <remote-id type="github">m2ym/popwin-el</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/app-emacs/popwin/popwin-0.6.2.ebuild b/app-emacs/popwin/popwin-0.6.2.ebuild
new file mode 100644
index 000000000000..f353fe5a47a0
--- /dev/null
+++ b/app-emacs/popwin/popwin-0.6.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit elisp eutils
+
+DESCRIPTION="Popup window manager for Emacs"
+HOMEPAGE="https://github.com/m2ym/popwin-el/"
+SRC_URI="https://github.com/m2ym/${PN}-el/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+SITEFILE="50${PN}-gentoo.el"
+DOCS="README.md NEWS.md"
+
+src_unpack() {
+ unpack ${A}
+ mv m2ym-popwin-el-* ${P} || die
+}