summaryrefslogtreecommitdiff
path: root/app-emacs/polymode
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /app-emacs/polymode
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'app-emacs/polymode')
-rw-r--r--app-emacs/polymode/Manifest4
-rw-r--r--app-emacs/polymode/files/50polymode-gentoo.el1
-rw-r--r--app-emacs/polymode/metadata.xml18
-rw-r--r--app-emacs/polymode/polymode-0.2.2_p20220322.ebuild33
4 files changed, 56 insertions, 0 deletions
diff --git a/app-emacs/polymode/Manifest b/app-emacs/polymode/Manifest
new file mode 100644
index 000000000000..ca481d1f834e
--- /dev/null
+++ b/app-emacs/polymode/Manifest
@@ -0,0 +1,4 @@
+AUX 50polymode-gentoo.el 38 BLAKE2B e96c6cf48d1522d89450e11d339c76210c672377208b56951791b83c6ef22b2c872d313084e199dd5d7b533a99106a87dbc7f15b5ee6126f71bf5f2e84165ffa SHA512 5c00bcabe2d7cc03013dc7a54b2c653940c08098ca5646d7c73624cb1ca04376ae9dcf88a7166b1925c69f0c5d192d90f6bd790fdef8ed8c3b0f9d163c987da5
+DIST polymode-0.2.2_p20220322.tar.gz 417218 BLAKE2B 7f2846a6fed751f7fb0e7d6b50ca2bb40232007e7f8cef801b22b252ca39a65658d0059ddb8ba384ed2f6b1bdbddaf39fcaa09d91787b8523f9872162156f25a SHA512 2e1d49cd3086cb7a8551a4c48cd6655e1c41155f1e518b1cfae5493ac382d566bc7a8969a167063c0384978b70d79f2d2557fc9a6d12e54a985fdbf24315bf0b
+EBUILD polymode-0.2.2_p20220322.ebuild 760 BLAKE2B e4741519a5db558ebe532616ebe6ba639b0e2432deb613eb7c73eb5f2af27bb3e17e18a90256518aacab255bbdfbc7baf935f2e11e61faf619a56b6b1d6cdb48 SHA512 60809cfc2316eaae9fa9d8051091558990dd633d17f3f2345048f709ffd103b00c7956c957f088c3a16f61ee0d5512da3e302b3cec2ba0c8d3f8d331d1c64cee
+MISC metadata.xml 685 BLAKE2B afe87d00ea99966b4b235b95061d46f267aeeb588f369e9a22b87921cc01b74684f5dc33db94a7ee7b6e6c7a029c57f69d72871ec45da92857aa2e27e3911303 SHA512 d42d29fb851d7fd2b0e3b675b6ee56acca5bc1c48ea6f47a9b2249d9c48909d446f450660e9481c271e3d4ab0e4183de7970c765e6fa0a61ba750d674435cbcf
diff --git a/app-emacs/polymode/files/50polymode-gentoo.el b/app-emacs/polymode/files/50polymode-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/polymode/files/50polymode-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/polymode/metadata.xml b/app-emacs/polymode/metadata.xml
new file mode 100644
index 000000000000..f362d712f750
--- /dev/null
+++ b/app-emacs/polymode/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/polymode/polymode/issues/</bugs-to>
+ <remote-id type="github">polymode/polymode</remote-id>
+ </upstream>
+ <longdescription>
+ Polymode is a framework for multiple major modes (MMM) inside a single
+ Emacs buffer. It is fast and has a simple but flexible object oriented
+ design. Creating new polymodes normally takes a few lines of code.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-emacs/polymode/polymode-0.2.2_p20220322.ebuild b/app-emacs/polymode/polymode-0.2.2_p20220322.ebuild
new file mode 100644
index 000000000000..c41d8cbfa476
--- /dev/null
+++ b/app-emacs/polymode/polymode-0.2.2_p20220322.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=2094c92403fe395dfb2b8b2521da1012a966e9ab
+NEED_EMACS=25
+
+inherit elisp
+
+DESCRIPTION="Framework for Multiple Major Modes in Emacs"
+HOMEPAGE="https://github.com/polymode/polymode/"
+SRC_URI="https://github.com/polymode/${PN}/archive/${H}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${H}
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+DOCS=( readme.md )
+# The "compat-tests" downloads resources from network and "define-tests" fails
+ELISP_REMOVE="tests/compat-tests.el tests/define-tests.el"
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . --load targets/test.el
+}
+
+src_install() {
+ elisp_src_install
+
+ dodoc -r samples
+}