summaryrefslogtreecommitdiff
path: root/app-emacs/pkg-info
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
commitc719fdcee603a5a706a45d10cb598762d56a727d (patch)
tree620cbf137661399a3fb1eff92914204f9a970713 /app-emacs/pkg-info
parentcc4618c9ba3d974948ebf340b542d8cb01db2f55 (diff)
gentoo resync : 25.09.2021
Diffstat (limited to 'app-emacs/pkg-info')
-rw-r--r--app-emacs/pkg-info/Manifest4
-rw-r--r--app-emacs/pkg-info/files/50pkg-info-gentoo.el8
-rw-r--r--app-emacs/pkg-info/metadata.xml16
-rw-r--r--app-emacs/pkg-info/pkg-info-0.6.ebuild22
4 files changed, 50 insertions, 0 deletions
diff --git a/app-emacs/pkg-info/Manifest b/app-emacs/pkg-info/Manifest
new file mode 100644
index 000000000000..5f8b8419938b
--- /dev/null
+++ b/app-emacs/pkg-info/Manifest
@@ -0,0 +1,4 @@
+AUX 50pkg-info-gentoo.el 432 BLAKE2B e422b694035b319ac40367cedeee146f1bcf6b5b69ab734d751fc670f647264b0bd2e0dab96f032cdfe7dd3c24bef9b84691578fdb55dac1abbc10e7e09b3099 SHA512 ca3e6390dd9e3eb12f1db203e4456c786a500566beef8647f204c5ce6218a6f44224ad6c3b6dc6afb02d5269168210231ae842de4fb4ff46d333135faa1a87a5
+DIST pkg-info-0.6.tar.gz 18896 BLAKE2B 464f172ef9e0e6e89f472032b1be0506c49a51fc8e2120ac561be23187fbd0ca64abf021e2ef717267623efe8ff0a49c14ad1af098f9ff20e167b334c49081d2 SHA512 73531a0a7ab54cf3e365a627d2905cc820f1328ad8ca8f985d1954c877f4a1ad7dc5129f52c4e2accd305661a9b952da9adf0a802c8ab6f35e1c16b55966ef54
+EBUILD pkg-info-0.6.ebuild 560 BLAKE2B fe801524ea429fd59a4a43010ba5a6278f6069e6f0e1ab881f680bfd65707b01c0e950cdb75d3a3ed5a6874d57bfa1fafe87f2dfd2ee96ebec6a041a18486c7f SHA512 359faccca9f0634fa3259e1004696452b3a2fcf18e824c1b82e2a269c648c84beb38ec57b1f665cc92a017658f1269a7895c7fe7b517000a89dece2252aaf300
+MISC metadata.xml 587 BLAKE2B ae1fa12c08fc93bce6c9a311852865b40412613f78225cf006e587ee10571fbb00c12ad1394c612d867c33022acc2e7ff13149be026664562b536d85a350cc39 SHA512 e42dd471a9dd10bf26d7138374e702e945c9f0a23fb36e2f6c9e69df308b9933b0709b8ca1c20fc1f44612971fd99e3ca3cf6d63bbec7708927f31026b11684a
diff --git a/app-emacs/pkg-info/files/50pkg-info-gentoo.el b/app-emacs/pkg-info/files/50pkg-info-gentoo.el
new file mode 100644
index 000000000000..352457a2380c
--- /dev/null
+++ b/app-emacs/pkg-info/files/50pkg-info-gentoo.el
@@ -0,0 +1,8 @@
+;;; pkg-info site-lisp configuration
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'pkg-info-library-original-version "pkg-info" nil t)
+(autoload 'pkg-info-library-version "pkg-info" nil t)
+(autoload 'pkg-info-defining-library-original-version "pkg-info" nil t)
+(autoload 'pkg-info-defining-library-version "pkg-info" nil t)
+(autoload 'pkg-info-package-version "pkg-info" nil t)
+(autoload 'pkg-info-version-info "pkg-info" nil t)
diff --git a/app-emacs/pkg-info/metadata.xml b/app-emacs/pkg-info/metadata.xml
new file mode 100644
index 000000000000..8ff3d9d5f463
--- /dev/null
+++ b/app-emacs/pkg-info/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>jturner.usa+gentoo@gmail.com</email>
+ <name>John Turner</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">emacsorphanage/pkg-info</remote-id>
+ <doc>https://github.com/emacsorphanage/pkg-info/blob/master/README.md</doc>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/pkg-info/pkg-info-0.6.ebuild b/app-emacs/pkg-info/pkg-info-0.6.ebuild
new file mode 100644
index 000000000000..a9a870f2370a
--- /dev/null
+++ b/app-emacs/pkg-info/pkg-info-0.6.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+NEED_EMACS="24.1"
+
+inherit elisp
+
+DESCRIPTION="Provide information about Emacs packages"
+HOMEPAGE="https://github.com/emacsorphanage/pkg-info"
+SRC_URI="https://github.com/emacsorphanage/pkg-info/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test" # test requires cask and ert-runner which are not packaged
+
+RDEPEND=">=app-emacs/epl-0.8"
+
+SITEFILE="50${PN}-gentoo.el"
+DOCS=( README.md CHANGES.md )