summaryrefslogtreecommitdiff
path: root/app-emacs/pariemacs/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/pariemacs/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/pariemacs/files')
-rw-r--r--app-emacs/pariemacs/files/64pariemacs-gentoo.el7
-rw-r--r--app-emacs/pariemacs/files/pariemacs-3.14-makefile.patch51
2 files changed, 58 insertions, 0 deletions
diff --git a/app-emacs/pariemacs/files/64pariemacs-gentoo.el b/app-emacs/pariemacs/files/64pariemacs-gentoo.el
new file mode 100644
index 000000000000..2dc1967ac762
--- /dev/null
+++ b/app-emacs/pariemacs/files/64pariemacs-gentoo.el
@@ -0,0 +1,7 @@
+;; site-init for pariemacs
+
+(add-to-list 'load-path "/usr/share/emacs/site-lisp/pariemacs")
+(autoload 'gp-mode "pari" nil t)
+(autoload 'gp-script-mode "pari" nil t)
+(autoload 'gp "pari" nil t)
+(autoload 'gpman "pari" nil t)
diff --git a/app-emacs/pariemacs/files/pariemacs-3.14-makefile.patch b/app-emacs/pariemacs/files/pariemacs-3.14-makefile.patch
new file mode 100644
index 000000000000..bbcd8b77c585
--- /dev/null
+++ b/app-emacs/pariemacs/files/pariemacs-3.14-makefile.patch
@@ -0,0 +1,51 @@
+diff -r -U2 pariemacs.orig/Makefile pariemacs/Makefile
+--- pariemacs.orig/Makefile 2017-12-05 18:54:54.000000000 +0700
++++ pariemacs/Makefile 2018-01-13 19:15:31.095946659 +0700
+@@ -5,19 +5,8 @@
+
+ # Path to pari.cfg file.
+-# Several possibilites:
+-PARI_CFG=/usr/local/lib/pari/pari.cfg
+-# For Debian (package "libpari-dev") install:
+-#PARI_CFG=/usr/lib/pari/pari.cfg
+-# For some other install, the architecture is mentioned
+-# (see https://wiki.ubuntu.com/MultiarchSpec):
+-#PARI_CFG=/usr/lib/i386-linux-gnu/pari/pari.cfg
+-#PARI_CFG=/usr/lib/x86_64-linux-gnu/pari/pari.cfg
+-
+-# In case, you cannot find it, you can use the following default file
+-# (but edit this file first):
+-#PARI_CFG=./pari.cfg-default
++PARI_CFG=./pari.cfg
+
+ # Where to install ourselves ?
+-INSTALL=/usr/local/share/emacs/site-lisp/pari
++INSTALL=/usr/share/emacs/site-lisp/pari
+
+ # Path to 'emacs' binary
+@@ -34,8 +23,4 @@
+ TARFILE=$(DIR).tar
+
+-install: pari-conf.el elc
+- mkdir -p $(INSTALL)
+- cp *.elc *.el README CHANGES COPYING $(INSTALL)
+-
+ pari-conf.el:
+ @if test ! -f $(PARI_CFG); then \
+@@ -52,16 +37,4 @@
+ -f batch-byte-compile *.el
+
+-distrib:
+- @if test -d $(DIR); then \
+- echo "Remove $(DIR) before building a new release"; exit 1; \
+- fi
+- @tar cf $(TARFILE) $(FILES)
+- @mkdir $(DIR) && mv $(TARFILE) $(DIR)
+- @cd $(DIR) && tar xf $(TARFILE) && rm -f $(TARFILE)
+- @tar cf $(TARFILE) $(DIR)
+- @rm -rf $(DIR)
+- @rm -f $(TARFILE).gz
+- @gzip $(TARFILE)
+-
+ clean:
+ rm -f *.elc pari-conf.el