summaryrefslogtreecommitdiff
path: root/app-emacs/osm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-14 17:52:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-14 17:52:12 +0000
commita90c84e720803f3d26c0ade8f1f1e405ca97502a (patch)
treef788ea0972d51c66823825021dd83427e1d466c4 /app-emacs/osm
parent07c1e2fbaa2f7d2cad4c16a747cebcf7ae7a6724 (diff)
gentoo auto-resync : 14:01:2023 - 17:52:11
Diffstat (limited to 'app-emacs/osm')
-rw-r--r--app-emacs/osm/Manifest4
-rw-r--r--app-emacs/osm/files/50osm-gentoo.el2
-rw-r--r--app-emacs/osm/metadata.xml23
-rw-r--r--app-emacs/osm/osm-0.9.ebuild31
4 files changed, 60 insertions, 0 deletions
diff --git a/app-emacs/osm/Manifest b/app-emacs/osm/Manifest
new file mode 100644
index 000000000000..eddcbc1830c2
--- /dev/null
+++ b/app-emacs/osm/Manifest
@@ -0,0 +1,4 @@
+AUX 50osm-gentoo.el 67 BLAKE2B 0486bd17d60abb53433943335ed7584a0ab6f3b2a1dcdf23174e6f790f95044d4000d5b37a3b1c2549337268b5b296c6528e68e061ad75aaae8bf3ff141069f8 SHA512 b4aed2a5c285c94489371fa297a44d7bd3ac6172199cea0218d0469cf4c2d36b819ada8f3da6b0a95c44f729e4d77f5051826081137c0f68cd58829705ccc50e
+DIST osm-0.9.tar.gz 31248 BLAKE2B ac9bc39ad42046bbec408006a375ad5bda2f561ed5fec7c489c5448ec9f4867ee2d3a7aeecfafbcf078cb4f4780c0e43442e7fa7c7fbe03755835bd56b9312e1 SHA512 4fe88be3bf99175cab4f90d516ef99e3ee7e5209d0046675c92f29a4786fccd92470560771fcfd8887e214b776fac9b75cdd8a0334d2de2d6b42d4313cacd4bd
+EBUILD osm-0.9.ebuild 604 BLAKE2B 1c5b2dbf4481468c23adf3addbaaa8718a1901a3175d7fe757e9e692c72dd3ccb2c70b63e56620af79e1e141bdb658e2bf594dbe1cd5080b2f9a98be0a0867f8 SHA512 9e2559aed8d570436846efde8b1286cbcc5a90414a98f66fc37cf7be541420d852c4a0a38c1655f62adf1880a5929e32005f511a0877bd946803208749d3e4c7
+MISC metadata.xml 1007 BLAKE2B f28de509f2c4d32cbc67695ed97d2e4231baaa56e29a55993bb6b6c85323bbab51ba6ea398d6b0f562cb93975c6c09a5962f7f504509c4a6dcf19a6efca08750 SHA512 8ea20302c01493f320e2ad72e2a3530088a9a7d8db5a72c33286f31e82ba4a60e1dcaf6c4a11ded416ad864c27bb42d3833aeda58b261ea054ab71cb5fd26736
diff --git a/app-emacs/osm/files/50osm-gentoo.el b/app-emacs/osm/files/50osm-gentoo.el
new file mode 100644
index 000000000000..41333f4b1a0c
--- /dev/null
+++ b/app-emacs/osm/files/50osm-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "osm-autoloads" nil t)
diff --git a/app-emacs/osm/metadata.xml b/app-emacs/osm/metadata.xml
new file mode 100644
index 000000000000..69b999da8796
--- /dev/null
+++ b/app-emacs/osm/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ Osm.el is a tile-based map viewer, with a responsive movable and zoomable
+ display. The map can be controlled with the keyboard or with the mouse. The
+ viewer fetches the map tiles in parallel from tile servers via the curl
+ program. The package comes with a list of multiple preconfigured tile
+ servers. You can bookmark your favorite locations using regular Emacs
+ bookmarks or create links from Org files to locations. Furthermore the
+ package provides commands to search for locations by name and to open and
+ display GPX tracks.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/minad/osm/issues/</bugs-to>
+ <remote-id type="github">minad/osm</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/osm/osm-0.9.ebuild b/app-emacs/osm/osm-0.9.ebuild
new file mode 100644
index 000000000000..a96d34a47bb3
--- /dev/null
+++ b/app-emacs/osm/osm-0.9.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="OpenStreetMap tile-based viewer for GNU Emacs"
+HOMEPAGE="https://github.com/minad/osm/"
+SRC_URI="https://github.com/minad/osm/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND=">=app-editors/emacs-${NEED_EMACS}:*[jpeg,json,libxml2,png,svg]"
+RDEPEND="
+ ${BDEPEND}
+ net-misc/curl[ssl]
+"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}