summaryrefslogtreecommitdiff
path: root/app-emacs/org-superstar-mode
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /app-emacs/org-superstar-mode
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'app-emacs/org-superstar-mode')
-rw-r--r--app-emacs/org-superstar-mode/Manifest4
-rw-r--r--app-emacs/org-superstar-mode/files/50org-superstar-mode-gentoo.el3
-rw-r--r--app-emacs/org-superstar-mode/metadata.xml13
-rw-r--r--app-emacs/org-superstar-mode/org-superstar-mode-1.5.0.ebuild23
4 files changed, 43 insertions, 0 deletions
diff --git a/app-emacs/org-superstar-mode/Manifest b/app-emacs/org-superstar-mode/Manifest
new file mode 100644
index 000000000000..75f563ec43d0
--- /dev/null
+++ b/app-emacs/org-superstar-mode/Manifest
@@ -0,0 +1,4 @@
+AUX 50org-superstar-mode-gentoo.el 139 BLAKE2B f675172e3ab88ebf2dd7dc81cc496be223a73ee429c84a91e7a4d57e52aff9b63fea447b273796f23cecf75410ba2a5f2805f9aac5c45ed8fc3b9a2ac838b07d SHA512 04f02dbdaa69a9f2df52f2e8c31b5a3d5bf0d751ac0fdfcc1ac34be88c4b78f6dcea8e469509f6baf01a91c7111707b1cb6f31ad3aa12c2219960626448a7d46
+DIST org-superstar-mode-1.5.0.tar.gz 622275 BLAKE2B 03c3b652d422d145e916dce02e3e0d7dc0583090803984da67c7e06aae6c3f3a7bfed43bb88fdc2891703cfca6adddf29135f6e93241b137a83d85c7ae165b03 SHA512 3c8f8168011c7f5df96620af6d12d3ab093f994c2875042e88b8f132ce7c44c42b86fd6502f050c0cf5375f986252bc5e45125f08a97db9b8ed0cd5bcd8548bd
+EBUILD org-superstar-mode-1.5.0.ebuild 557 BLAKE2B 823c13c701aa96d49fe5747af9d54eb8132db8f60503a46a6815c34f81ecff94e7baafe4e5173bc07a4d38aa0ec7828d7d345df9b198b965c12fef9938307901 SHA512 55a258906ba7d8b08c05506eb477befa56a4cd4d13d43d7342145d68ba1f3b07c283f0b9109af77bbe28b87e435947cbda295c1046eb968a33d77e80f8b9933a
+MISC metadata.xml 449 BLAKE2B dab5998f0e0e23ba741cc4ae469434798897f2a24557de5968bd67c33681b332a2235d20e576c2a1f79fd45e726069617341261b5725f4c4c532d707fdfb123f SHA512 7c71714e8a08c8dacc26c3d4a8af610fae08493a927a56c88ee3795052dc57d94a18bb69851a8f2fa3e65fdbdd81032aff697f59738dfcb8896bc4ee3a659223
diff --git a/app-emacs/org-superstar-mode/files/50org-superstar-mode-gentoo.el b/app-emacs/org-superstar-mode/files/50org-superstar-mode-gentoo.el
new file mode 100644
index 000000000000..0c65805a0407
--- /dev/null
+++ b/app-emacs/org-superstar-mode/files/50org-superstar-mode-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'org-superstar-mode "org-superstar"
+ "Use UTF8 bullets for headlines and plain lists." t)
diff --git a/app-emacs/org-superstar-mode/metadata.xml b/app-emacs/org-superstar-mode/metadata.xml
new file mode 100644
index 000000000000..921a094acd19
--- /dev/null
+++ b/app-emacs/org-superstar-mode/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/integral-dw/org-superstar-mode/issues/</bugs-to>
+ <remote-id type="github">integral-dw/org-superstar-mode</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/org-superstar-mode/org-superstar-mode-1.5.0.ebuild b/app-emacs/org-superstar-mode/org-superstar-mode-1.5.0.ebuild
new file mode 100644
index 000000000000..89f453b5e044
--- /dev/null
+++ b/app-emacs/org-superstar-mode/org-superstar-mode-1.5.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26.1
+
+inherit elisp
+
+DESCRIPTION="Prettify headings and plain lists in Org mode (use UTF8 bullets)"
+HOMEPAGE="https://github.com/integral-dw/org-superstar-mode/"
+SRC_URI="https://github.com/integral-dw/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( DEMO.org README.org demos )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ emake EMACS="${EMACS}" EFLAGS="${EMACSFLAGS}" -C tests
+}