summaryrefslogtreecommitdiff
path: root/app-emacs/orderless/orderless-0.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-20 01:49:56 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-20 01:49:56 +0000
commit30be4d7d2806b014770312920fcda743d4dc67d0 (patch)
tree229c7337dfd56654c52009367273c078b016a25c /app-emacs/orderless/orderless-0.8.ebuild
parentf287ecad888abdeb38e617d0485de282cd6819db (diff)
gentoo auto-resync : 20:12:2022 - 01:49:56
Diffstat (limited to 'app-emacs/orderless/orderless-0.8.ebuild')
-rw-r--r--app-emacs/orderless/orderless-0.8.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-emacs/orderless/orderless-0.8.ebuild b/app-emacs/orderless/orderless-0.8.ebuild
new file mode 100644
index 000000000000..4e2b3347a81c
--- /dev/null
+++ b/app-emacs/orderless/orderless-0.8.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+NEED_EMACS=26
+
+inherit readme.gentoo-r1 elisp
+
+DESCRIPTION="Completion style that matches multiple regexps in any order"
+HOMEPAGE="https://github.com/oantolin/orderless"
+SRC_URI="https://github.com/oantolin/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="sys-apps/texinfo"
+
+SITEFILE="50${PN}-gentoo.el"
+DOC_CONTENTS="Enable orderless completion by placing
+ \"(setq completion-styles '(orderless))\" in your .emacs file."
+ELISP_TEXTINFO="${PN}.texi"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}