summaryrefslogtreecommitdiff
path: root/app-emacs/oauth2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-15 20:53:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-15 20:53:45 +0000
commit20e7188871e6d724b707132f925b9872536a91a0 (patch)
tree1b8d527714db0a937011ad650939d9152d36506c /app-emacs/oauth2
parente4769acf6646f4b0ef28cb695cec8ed128aba920 (diff)
gentoo auto-resync : 15:12:2023 - 20:53:45
Diffstat (limited to 'app-emacs/oauth2')
-rw-r--r--app-emacs/oauth2/Manifest3
-rw-r--r--app-emacs/oauth2/metadata.xml12
-rw-r--r--app-emacs/oauth2/oauth2-0.16.ebuild18
3 files changed, 33 insertions, 0 deletions
diff --git a/app-emacs/oauth2/Manifest b/app-emacs/oauth2/Manifest
new file mode 100644
index 000000000000..08c8de7d99d1
--- /dev/null
+++ b/app-emacs/oauth2/Manifest
@@ -0,0 +1,3 @@
+DIST oauth2-0.16.tar.gz 3527 BLAKE2B af5ea470267ada0efe7bb28c383576bdd737da1352fff1047f0a26ca133efbb96e2dcb9dd53ad6793b7a73a6fa42c002955ab751389a30f2200f6a00e6de646e SHA512 525408581c146e369df2e2a79c76bc06f631a55c0f42ed537bc05fdeb7d399e6308b3e99135b49e66366941722710340cd18c184c09d510444c765ad19b0eb6f
+EBUILD oauth2-0.16.ebuild 503 BLAKE2B 96dc1cba6e554d589eb9058a6bf348117de94d4bd56e3b4af9122630c2fe52ee4595c5b5f67182aad789f892a4c0803c095ce06cae14a4b56561f239fe59eaf8 SHA512 e7df5f1147cae6d7b02a82536cb8ec2e07432cf273db624157f11ae93ecad36b9e3d916d5ca49675a185b677d9f59427852b6db0fd3412ee460aecdfa6237d69
+MISC metadata.xml 364 BLAKE2B 84c0e47033fb2ebe7eed99db6ef5e82b7b31c44014156e9c9615d79fbcafa0693bf7d66408af310593eab40ae6d4596faad699b399ce20327b8f3d587e503d99 SHA512 52661def31909412973e45df6d5494ef03171465de37d724e2a657fd6978ec9cedf42d67a936eee5fb4198473a66bac8a93e4723289d675212073ab50edaad4e
diff --git a/app-emacs/oauth2/metadata.xml b/app-emacs/oauth2/metadata.xml
new file mode 100644
index 000000000000..4e171f620ebe
--- /dev/null
+++ b/app-emacs/oauth2/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<stabilize-allarches/>
+<upstream>
+ <remote-id type="github">emacsmirror/oauth2</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/app-emacs/oauth2/oauth2-0.16.ebuild b/app-emacs/oauth2/oauth2-0.16.ebuild
new file mode 100644
index 000000000000..7aad463165cf
--- /dev/null
+++ b/app-emacs/oauth2/oauth2-0.16.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="OAuth 2.0 authorization protocol"
+HOMEPAGE="https://elpa.gnu.org/packages/oauth2.html"
+GITHUB_SHA1="dc069550616fb0a72507489ea796d0e1bd8b48c9"
+SRC_URI="https://github.com/emacsmirror/${PN}/archive/${GITHUB_SHA1}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${GITHUB_SHA1}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+SITEFILE="50${PN}-gentoo.el"