summaryrefslogtreecommitdiff
path: root/app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20231022.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-23 02:38:53 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-23 02:38:53 +0100
commit0118ac4510d7b85ca62da20e4abd1286dd8bd752 (patch)
tree83ec10da0441d566914c9e66e10c8210202888ea /app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20231022.ebuild
parentea6f03ddd591a238d9c5004d5ffbfaf7215c01ee (diff)
gentoo auto-resync : 23:10:2023 - 02:38:53
Diffstat (limited to 'app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20231022.ebuild')
-rw-r--r--app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20231022.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20231022.ebuild b/app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20231022.ebuild
new file mode 100644
index 000000000000..94311b25501f
--- /dev/null
+++ b/app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20231022.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Extension for nxml-mode with Gentoo-specific schemas"
+HOMEPAGE="https://gitweb.gentoo.org/proj/nxml-gentoo-schemas.git/"
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+
+LICENSE="MIT GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
+
+SITEFILE="60${PN}-gentoo.el"
+
+src_compile() { :; }
+
+src_install() {
+ insinto "${SITEETC}/${PN}"
+ doins schemas.xml *.rnc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}