summaryrefslogtreecommitdiff
path: root/app-emacs/noflet
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /app-emacs/noflet
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'app-emacs/noflet')
-rw-r--r--app-emacs/noflet/Manifest5
-rw-r--r--app-emacs/noflet/files/50noflet-gentoo.el1
-rw-r--r--app-emacs/noflet/files/noflet-fix-requires.patch28
-rw-r--r--app-emacs/noflet/metadata.xml13
-rw-r--r--app-emacs/noflet/noflet-0.0.15_p20141102-r1.ebuild27
5 files changed, 74 insertions, 0 deletions
diff --git a/app-emacs/noflet/Manifest b/app-emacs/noflet/Manifest
new file mode 100644
index 000000000000..dc48aa0c8acd
--- /dev/null
+++ b/app-emacs/noflet/Manifest
@@ -0,0 +1,5 @@
+AUX 50noflet-gentoo.el 38 BLAKE2B e96c6cf48d1522d89450e11d339c76210c672377208b56951791b83c6ef22b2c872d313084e199dd5d7b533a99106a87dbc7f15b5ee6126f71bf5f2e84165ffa SHA512 5c00bcabe2d7cc03013dc7a54b2c653940c08098ca5646d7c73624cb1ca04376ae9dcf88a7166b1925c69f0c5d192d90f6bd790fdef8ed8c3b0f9d163c987da5
+AUX noflet-fix-requires.patch 735 BLAKE2B 513a05b2343411771968d4caec6e81f5b8f5b66f8ea5d663aff256160df8a891bb821eb5ea39c60959326ce29677bd9ca1e6a09ab52783cd4cf324c981989f12 SHA512 8b6b21f5e67e57d20e1555201e248eaa6f6f32fb7e9fe68557a27b27708758de714e5031f9c50dcaf50208e216df41455d82a6bf5d34b2897ca89a9d635b91df
+DIST noflet-0.0.15_p20141102.tar.gz 3123 BLAKE2B 0886da1af599e8ca226fbbefa31b6130c76d704d62c5323803543c31e975c375c1cfc12a5a3cfb5e2491488a31fce5538ab80f826de43fa4c77bdc7e8bd84315 SHA512 7007cb09f3ceaba652042a1ba9ff669e73b0a01775de573f0cfab33eef963e7b9125bb16ce1cd809479ea3ec0277eeed757a716538b1ca1f5b559b1ecdf7ed73
+EBUILD noflet-0.0.15_p20141102-r1.ebuild 641 BLAKE2B 4459ad27d23ce9b45c550f2dcb3a00c1b7cb6c653d02390e205dd9ebba63f1808e3d26b263a59ab72055a4141396fc2e0e89fe4881a86942511c2713d14351e4 SHA512 f560f08feae4b5889b24bd1b0440c35b95c2f98bc7b1a1845243467978ad708a34663dd3b653c6fa54f11768fe914a54ae39ff02e023f32ecb6650e37a18d9a3
+MISC metadata.xml 435 BLAKE2B ce7fd39a001c15f061147a3419acc25566ca6db9ac3868f410da7289fba33df1d274fc9efa970b38dc4f27f543219ce7ab125834264daddccdd7c15b3bf26d46 SHA512 2e95b227aebb9f38dc34861a0a56d4edefa20575ec0d0ec0cbf50418f7dcc853512ea170e6fd7e317e6932aa65cb5f4049fc62a413b78e244f4e979f8e4a9f73
diff --git a/app-emacs/noflet/files/50noflet-gentoo.el b/app-emacs/noflet/files/50noflet-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/noflet/files/50noflet-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/noflet/files/noflet-fix-requires.patch b/app-emacs/noflet/files/noflet-fix-requires.patch
new file mode 100644
index 000000000000..142229d547e1
--- /dev/null
+++ b/app-emacs/noflet/files/noflet-fix-requires.patch
@@ -0,0 +1,28 @@
+index 58d3b8d..c003987 100644
+--- a/noflet.el
++++ b/noflet.el
+@@ -28,10 +28,8 @@
+
+ ;;; Code:
+
+-(eval-when-compile (require 'cl))
+-(if (version< emacs-version "24.4.1")
+- (load-library "cl-indent")
+- (require 'cl-indent))
++(require 'dash)
++(require 'cl-lib)
+
+ (defun noflet|base ()
+ "A base function."
+index 58d3b8d..73f0719 100644
+--- a/noflet.el
++++ b/noflet.el
+@@ -155,7 +155,7 @@ maintainers refuse to add the correct indentation spec to
+ (indent noflet-indent-func))
+ `(cl-flet ,bindings ,@body))
+
+-(defmacro* letn (tag bindings &rest body)
++(cl-defmacro letn (tag bindings &rest body)
+ (declare (debug (sexp sexp &rest form))
+ (indent 2))
+ `(cl-labels ((,tag ,(-map 'car bindings) ,@body))
diff --git a/app-emacs/noflet/metadata.xml b/app-emacs/noflet/metadata.xml
new file mode 100644
index 000000000000..09739af554d8
--- /dev/null
+++ b/app-emacs/noflet/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/nicferrier/emacs-noflet/issues/</bugs-to>
+ <remote-id type="github">nicferrier/emacs-noflet</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/noflet/noflet-0.0.15_p20141102-r1.ebuild b/app-emacs/noflet/noflet-0.0.15_p20141102-r1.ebuild
new file mode 100644
index 000000000000..461c04cef26d
--- /dev/null
+++ b/app-emacs/noflet/noflet-0.0.15_p20141102-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=7ae84dc3257637af7334101456dafe1759c6b68a
+
+inherit elisp
+
+DESCRIPTION="Dynamic, local advice for Emacs-Lisp code"
+HOMEPAGE="https://github.com/nicferrier/emacs-noflet/"
+SRC_URI="https://github.com/nicferrier/emacs-${PN}/archive/${H}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/emacs-${PN}-${H}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="app-emacs/dash"
+BDEPEND="${RDEPEND}"
+
+DOCS=( README.creole )
+PATCHES=( "${FILESDIR}"/${PN}-fix-requires.patch )
+
+ELISP_REMOVE="let-while-tests.el"
+SITEFILE="50${PN}-gentoo.el"