summaryrefslogtreecommitdiff
path: root/app-emacs/nerd-icons
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-10 22:36:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-10 22:36:46 +0100
commit783da4542a9c3e0e1ec703644212707cde610679 (patch)
tree3e0cf56ac37ddf9d5fdc6ff0ced9135b1c7fc5e0 /app-emacs/nerd-icons
parentd0041c590ed45bbfeae458ea926e36bc64e41dd7 (diff)
gentoo auto-resync : 10:09:2023 - 22:36:45
Diffstat (limited to 'app-emacs/nerd-icons')
-rw-r--r--app-emacs/nerd-icons/Manifest4
-rw-r--r--app-emacs/nerd-icons/files/50nerd-icons-gentoo.el2
-rw-r--r--app-emacs/nerd-icons/metadata.xml13
-rw-r--r--app-emacs/nerd-icons/nerd-icons-0.1.0.ebuild60
4 files changed, 79 insertions, 0 deletions
diff --git a/app-emacs/nerd-icons/Manifest b/app-emacs/nerd-icons/Manifest
new file mode 100644
index 000000000000..9b8f31cb46ac
--- /dev/null
+++ b/app-emacs/nerd-icons/Manifest
@@ -0,0 +1,4 @@
+AUX 50nerd-icons-gentoo.el 74 BLAKE2B fec766eee3d24c57e320f7f11f5651a6f21bee9488319881e6002e760bd2165ac8e23db9daa7091a228dc9824151a2e9e731c20409f4a4d53ea1929b812be661 SHA512 44a3987b106f1c670f1f0abba80a4f9cdff69989716352f3b85d6120fd9614ffd8158dccf4dcd32fc68289ef0633a82f653cd4332887a59103379d1cda70b049
+DIST nerd-icons-0.1.0.tar.gz 1485030 BLAKE2B f70411118071cc360d6c335e7276cc27839c35fa35a015540649d9cc2624e1e32f2bac10a4afef40f0fb6cb4a7063919b4fd8f02d73941d7c055be999164340c SHA512 7d7e03f4aa85f8b16cf0eb5c272f22bbecbf54f51a5d52dfadc509743e5bf02397de5ca9f2946bb6cbdadd5aa4dc105b1245e7b86f8589211aff354f03b7aa0a
+EBUILD nerd-icons-0.1.0.ebuild 1102 BLAKE2B 09037e03931ad6a2eab0389f63d5055250269beb93dadee938b144caee8e2de46acc810bd9830f0c8cb65e578e5de509dd8f6fd31aaa36b58f24390225e36a85 SHA512 35cc041de7e27f017890be5ab49c1c171d42d1eeaf442bb2045d300fc67a935d3f8ad56ba6e406437335d7339552bd7c9052562e40a7d23647e18c0220571d04
+MISC metadata.xml 447 BLAKE2B d801471fa96f4c776f34e4be3ff1538c68a6e9be58d780f84c5534aea3eb46ee2c8839a941eee7985a6e9f95e677a18135dbdfc1edbeeca0fe5e34ca3243500b SHA512 e9be8bff935c45be109075a3047e78024391693e91dd97cf930b1498c9d070ee9e4c7b4b665ab8b6e81660061cc55dcee972eba3b692e126d4c5188683f90a93
diff --git a/app-emacs/nerd-icons/files/50nerd-icons-gentoo.el b/app-emacs/nerd-icons/files/50nerd-icons-gentoo.el
new file mode 100644
index 000000000000..c8a2fe789c48
--- /dev/null
+++ b/app-emacs/nerd-icons/files/50nerd-icons-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "nerd-icons-autoloads" nil t)
diff --git a/app-emacs/nerd-icons/metadata.xml b/app-emacs/nerd-icons/metadata.xml
new file mode 100644
index 000000000000..b127ea8dc2c5
--- /dev/null
+++ b/app-emacs/nerd-icons/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/rainstormstudio/nerd-icons.el/issues/</bugs-to>
+ <remote-id type="github">rainstormstudio/nerd-icons.el</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/nerd-icons/nerd-icons-0.1.0.ebuild b/app-emacs/nerd-icons/nerd-icons-0.1.0.ebuild
new file mode 100644
index 000000000000..1a235f3d93d0
--- /dev/null
+++ b/app-emacs/nerd-icons/nerd-icons-0.1.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp font readme.gentoo-r1
+
+DESCRIPTION="Emacs Nerd Font Icons Library"
+HOMEPAGE="https://github.com/rainstormstudio/nerd-icons.el/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/rainstormstudio/${PN}.el.git"
+else
+ SRC_URI="https://github.com/rainstormstudio/${PN}.el/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}.el-${PV}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+FONT_PN="NFM"
+FONT_S="${S}/fonts"
+FONT_SUFFIX="ttf"
+
+DOC_CONTENTS="You may need to install the required fonts by executing
+ the \"nerd-icons-install-fonts\" function."
+SITEFILE="50${PN}-gentoo.el"
+
+pkg_setup() {
+ elisp_pkg_setup
+ font_pkg_setup
+}
+
+src_compile() {
+ elisp_src_compile
+
+ elisp-make-autoload-file
+ elisp-compile data/*.el
+}
+
+src_install() {
+ elisp_src_install
+ font_src_install
+
+ elisp-install "${PN}/data" data/*.el{,c}
+}
+
+pkg_postinst() {
+ elisp_pkg_postinst
+ font_pkg_postinst
+}
+
+pkg_postrm() {
+ elisp_pkg_postrm
+ font_pkg_postrm
+}