summaryrefslogtreecommitdiff
path: root/app-emacs/muse
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/muse
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/muse')
-rw-r--r--app-emacs/muse/Manifest4
-rw-r--r--app-emacs/muse/files/50muse-gentoo.el2
-rw-r--r--app-emacs/muse/metadata.xml34
-rw-r--r--app-emacs/muse/muse-3.20.ebuild34
4 files changed, 74 insertions, 0 deletions
diff --git a/app-emacs/muse/Manifest b/app-emacs/muse/Manifest
new file mode 100644
index 000000000000..c341a6a05b40
--- /dev/null
+++ b/app-emacs/muse/Manifest
@@ -0,0 +1,4 @@
+AUX 50muse-gentoo.el 64 BLAKE2B 1af4c3cb29edfe7f0263b2eefb1483c2f680a4199c1ec27ae7b4db26f7923d86418b3b3a87fdfae90edff728fa20cf628075a320985bde0a132d1bc864e2ad49 SHA512 c4b1049b70cd62c2490621d123227e5cc62d80c8a2fa3575d69443ec09e5fbb6294b1f3b3dda530139d9318610bc3c806f3984ae697e246778aab5aad0bbc632
+DIST muse-3.20.tar.gz 411316 BLAKE2B a67c72a470e7e2d75cf94ed262b0e9503166326666a119f41968a603b4e48f3527705691a1b4b819ae6ec69c382a09074eef74ddad598faa08be6c74793b1e97 SHA512 23cd0e864586f907418753bc3284afde51b4f8559c5d043c52baa70de70ec4a845d9e8362b93e701308dbbd662e3429035df8ad440916e61d5909498cd55f7be
+EBUILD muse-3.20.ebuild 798 BLAKE2B c1e1bfa6ee31439f39693a20edd4e6ae3fce0ecbde857fdbfae4972f5eaa85bfbf390e8e69cf01a5e88218e10139ce276101a466d41db738aa569273932892d4 SHA512 73f3d55410e94b60f40be8ddf8ce9e64e19534e26f67326bfa06d88bfae7d624026e56d1167484da5a70741ff8656f3c74fcc96b1e34c92eb4705a2c7e310856
+MISC metadata.xml 1573 BLAKE2B df1f66340b61bf97f534274155310fabbfaa2ae8b4cf64f1bd1cba27b38ca4bc1d9f7a5ea4e6c9c74e02ba333a81638c97a8cd0cf540a3433182cfce02f26b5a SHA512 e61095db5b26acf2fdd0143cffe5146a4d1755ce3a2a5fb27041d94b0f76d09c1423af83b3d65caae3ac784f6155c8ee0bcde05e3c6f3a02e677aeeda5435aea
diff --git a/app-emacs/muse/files/50muse-gentoo.el b/app-emacs/muse/files/50muse-gentoo.el
new file mode 100644
index 000000000000..63bea6e9b3ed
--- /dev/null
+++ b/app-emacs/muse/files/50muse-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(require 'muse-autoloads)
diff --git a/app-emacs/muse/metadata.xml b/app-emacs/muse/metadata.xml
new file mode 100644
index 000000000000..2e78cfd4f883
--- /dev/null
+++ b/app-emacs/muse/metadata.xml
@@ -0,0 +1,34 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<longdescription>
+ Emacs Muse is an authoring and publishing environment for Emacs.
+ It simplifies the process of writing documents and publishing them
+ to various output formats.
+
+ Muse consists of two main parts: an enhanced text-mode for authoring
+ documents and navigating within Muse projects, and a set of
+ publishing styles for generating different kinds of output.
+
+ This idea is not in any way new. Numerous systems exist - even one
+ other for Emacs itself (Bhl Mode). What Muse adds to the picture is
+ a more modular environment, with a rather simple core, in which
+ "styles" are derived from to create new styles. Much of Muse's
+ overall functionality is optional. For example, you can use the
+ publisher without the major-mode, or the mode without doing any
+ publishing; or if you don't load the Texinfo or LaTeX modules, those
+ styles won't be available.
+
+ The Muse codebase is a departure from emacs-wiki.el version 2.44.
+ The code has been restructured and rewritten, especially its
+ publishing functions. The focus in this revision is on the authoring
+ and publishing aspects, and the "wikiness" has been removed as a
+ default behavior (available as the optional module muse-wiki.el).
+ CamelCase words are no longer special by default.
+</longdescription>
+<stabilize-allarches/>
+</pkgmetadata>
diff --git a/app-emacs/muse/muse-3.20.ebuild b/app-emacs/muse/muse-3.20.ebuild
new file mode 100644
index 000000000000..0b93b90bc77b
--- /dev/null
+++ b/app-emacs/muse/muse-3.20.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit elisp
+
+DESCRIPTION="An authoring and publishing environment for Emacs"
+HOMEPAGE="http://mwolson.org/projects/EmacsMuse.html"
+SRC_URI="http://download.gna.org/muse-el/${P}.tar.gz"
+
+LICENSE="GPL-3 FDL-1.2 GPL-2 MIT"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+IUSE="test"
+RESTRICT="test" #426546
+
+DEPEND="test? ( app-emacs/htmlize )"
+RDEPEND=""
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ default
+}
+
+src_install() {
+ elisp-install ${PN} lisp/*.el lisp/*.elc || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ doinfo texi/muse.info
+ dodoc AUTHORS NEWS README ChangeLog*
+ insinto /usr/share/doc/${PF}
+ doins -r contrib etc examples experimental scripts
+}