summaryrefslogtreecommitdiff
path: root/app-emacs/metamath-mode
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-15 19:51:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-15 19:51:12 +0100
commitca144cbf71b2faf598564847378fa40a0090d67c (patch)
treed9dc05cd474f9feb1649b145b41e453bbebc1ad4 /app-emacs/metamath-mode
parent7b0230b9f0a5cbd2779e7b25d57df8c33b6d0a88 (diff)
gentoo auto-resync : 15:10:2022 - 19:51:12
Diffstat (limited to 'app-emacs/metamath-mode')
-rw-r--r--app-emacs/metamath-mode/Manifest4
-rw-r--r--app-emacs/metamath-mode/files/50metamath-mode-gentoo.el4
-rw-r--r--app-emacs/metamath-mode/metadata.xml14
-rw-r--r--app-emacs/metamath-mode/metamath-mode-0_p20221005.ebuild21
4 files changed, 43 insertions, 0 deletions
diff --git a/app-emacs/metamath-mode/Manifest b/app-emacs/metamath-mode/Manifest
new file mode 100644
index 000000000000..791360841004
--- /dev/null
+++ b/app-emacs/metamath-mode/Manifest
@@ -0,0 +1,4 @@
+AUX 50metamath-mode-gentoo.el 185 BLAKE2B c426f84b359692e8ec0c18b43c9ad80ec4ec911d248504dd0a684ddc5e18f2a6a20c749f8aa5e410a993760b9876f5f3c36f70ddcfc67c523923efb578609b0d SHA512 29594b37fea09d0848c14d5fff63d445637d3a043e114c4e252a042a12068d93d0d2f4d4a2c9da468279125d06e40c281a04aa7dc90530274a8166cb6fd23f2a
+DIST metamath-mode-0_p20221005.tar.gz 1490 BLAKE2B fabb0c6c69306e6998a144d19774d442c5803446218607f62c134d5912a891ffa09cedf06c19e16a05cf3790528ba4063054540834ecab42d6852068b88be682 SHA512 39b5dd4a3967ecdc29d7637fc592c9fd398d0fe3c12344e1930fc5082057f3cb78e564319655d063fce62bc4b9581fad7debb5cb4085e5cc642a7d9d7ccede45
+EBUILD metamath-mode-0_p20221005.ebuild 486 BLAKE2B b1d1f10a6407d7c96fda777b12d79821c78b25375d670b5a15f1d37089880d425155df45a04408f026260267ae2a1cc4afcb697ceb4d59587a174ae5b911665e SHA512 fd1468de0200dddd34e196f82ff53f02dc9a9472b919341b761949e055995ede324198432555bdb885766cf1cdecc79d82c178d40da8e6eb504a7d9eed434f5a
+MISC metadata.xml 463 BLAKE2B 27260920c069dae2fed6a4ba482bc11c7ca9fba9c5f917f3d229a2b0141f2f18ce3e30efcb00360cbe22e9ddd4a1b5f87df7338d21bb97a7d8d2d32955e8dd12 SHA512 e01c0de8c4363242a55756db5f74b6831f2f2bbbd201655dfb22862fe84a182e920e221c8d903c79194fe455c5c3cc877ba35ecafe22051b36f1daf850c0b75b
diff --git a/app-emacs/metamath-mode/files/50metamath-mode-gentoo.el b/app-emacs/metamath-mode/files/50metamath-mode-gentoo.el
new file mode 100644
index 000000000000..fd0d03a31115
--- /dev/null
+++ b/app-emacs/metamath-mode/files/50metamath-mode-gentoo.el
@@ -0,0 +1,4 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'metamath-mode "metamath-mode"
+ "Major mode for editing metamath files" t)
+(add-to-list 'auto-mode-alist '("\\.mm\\'" . metamath-mode))
diff --git a/app-emacs/metamath-mode/metadata.xml b/app-emacs/metamath-mode/metadata.xml
new file mode 100644
index 000000000000..946548fce536
--- /dev/null
+++ b/app-emacs/metamath-mode/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <stabilize-allarches />
+ <upstream>
+ <bugs-to>https://github.com/samrushing/metamath-mode/issues/</bugs-to>
+ <remote-id type="github">samrushing/metamath-mode</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/metamath-mode/metamath-mode-0_p20221005.ebuild b/app-emacs/metamath-mode/metamath-mode-0_p20221005.ebuild
new file mode 100644
index 000000000000..4bb809ed1bad
--- /dev/null
+++ b/app-emacs/metamath-mode/metamath-mode-0_p20221005.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=85bd63b88378e9f2dee2f7d5585ec6610bf098a6
+
+inherit elisp
+
+DESCRIPTION="Major GNU Emacs mode for metamath files"
+HOMEPAGE="https://github.com/samrushing/metamath-mode/"
+SRC_URI="https://github.com/samrushing/${PN}/archive/${H}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${H}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"