summaryrefslogtreecommitdiff
path: root/app-emacs/magit-popup
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-02 17:36:40 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-02 17:36:40 +0100
commit171a011ad3a131671aeb5a98b9e3adf219ad2865 (patch)
tree0c877a3d1a37f10e37ad7168cfc52054aa0948a7 /app-emacs/magit-popup
parent75fc75ae1f0481ffdb78450e801a9b443ba641bd (diff)
gentoo resync : 02.04.2018
Diffstat (limited to 'app-emacs/magit-popup')
-rw-r--r--app-emacs/magit-popup/Manifest4
-rw-r--r--app-emacs/magit-popup/files/50magit-popup-gentoo.el1
-rw-r--r--app-emacs/magit-popup/magit-popup-2.12.3.ebuild23
-rw-r--r--app-emacs/magit-popup/metadata.xml27
4 files changed, 55 insertions, 0 deletions
diff --git a/app-emacs/magit-popup/Manifest b/app-emacs/magit-popup/Manifest
new file mode 100644
index 000000000000..44d6ae7ef248
--- /dev/null
+++ b/app-emacs/magit-popup/Manifest
@@ -0,0 +1,4 @@
+AUX 50magit-popup-gentoo.el 38 BLAKE2B e96c6cf48d1522d89450e11d339c76210c672377208b56951791b83c6ef22b2c872d313084e199dd5d7b533a99106a87dbc7f15b5ee6126f71bf5f2e84165ffa SHA512 5c00bcabe2d7cc03013dc7a54b2c653940c08098ca5646d7c73624cb1ca04376ae9dcf88a7166b1925c69f0c5d192d90f6bd790fdef8ed8c3b0f9d163c987da5
+DIST magit-popup-2.12.3.tar.gz 40195 BLAKE2B a351e949207b674c734f66b0431fa4c137293ccff880e3f457dfb825d7a36afd37f59197170a86d52606d371c181cd8a23be54d74aeee192a2d1a56588a55b3d SHA512 50620ce1d364ae28f30658dedd8f235bb1055be5cf4320142b7648e2ff6137f84cf865ea8f41e34ad7fb42612ff5d36fc0c4f6caa0aa0d2071bf775c15be5833
+EBUILD magit-popup-2.12.3.ebuild 565 BLAKE2B dab3675e63c5c51a565a33a05e06cc045ba3a0f31414bd801da5ffab1766713e62724117cd80fcfd64f813499c7e7ada9d1ff6f3572a72ef1dfc1ac27f249eb5 SHA512 fffc8dcc34242f066b58a6a833c0e720eab0f016b6a060c230e3bd3cacd851abadd96180de4872c171b067f4d7816a8320c766ae993f55e610b761a5a3f695ef
+MISC metadata.xml 1147 BLAKE2B 68fe5e7240434621fe4d1148e8f05d162771f8c90123790d757fec03d3c54dd686630860eec299371bf2f5356e0b8880a8ec46e1c7bff3d697d477fc095f58e1 SHA512 1e1aac2080140c50012bb3e35cb62c53fb782f9ac3041df3b7d1f8c86822bd7eba2f773c65205a58c65c791a095fc82bd39265dd05cdff52ace51e38a58666e0
diff --git a/app-emacs/magit-popup/files/50magit-popup-gentoo.el b/app-emacs/magit-popup/files/50magit-popup-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/magit-popup/files/50magit-popup-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/magit-popup/magit-popup-2.12.3.ebuild b/app-emacs/magit-popup/magit-popup-2.12.3.ebuild
new file mode 100644
index 000000000000..2a8b77e6c533
--- /dev/null
+++ b/app-emacs/magit-popup/magit-popup-2.12.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="Define prefix-infix-suffix command combos"
+HOMEPAGE="https://magit.vc/manual/magit-popup"
+SRC_URI="https://github.com/magit/magit-popup/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+SITEFILE="50${PN}-gentoo.el"
+ELISP_TEXINFO="*.texi"
+DOCS="README.md"
+
+CDEPEND=">=app-emacs/dash-2.13.0"
+DEPEND="${CDEPEND} sys-apps/texinfo"
+RDEPEND=$CDEPEND
diff --git a/app-emacs/magit-popup/metadata.xml b/app-emacs/magit-popup/metadata.xml
new file mode 100644
index 000000000000..ab63c931bf35
--- /dev/null
+++ b/app-emacs/magit-popup/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<longdescription>
+This package implements a generic interface for toggling switches
+and setting options and then invoking an Emacs command which does
+something with these arguments. The prototypical use is for the
+command to call an external process, passing on the arguments as
+command line arguments. But this is only one of many possible
+uses (though the one this library is optimized for).
+
+With the Emacs concept of "prefix arguments" in mind this could be
+described as "infix arguments with feedback in a buffer".
+
+Commands that set the prefix argument for the subsequent command do
+not limit what that next command could be. But entering a command
+console popup does limit the selection to the commands defined for
+that popup, and so we use the term "infix" instead of "prefix".
+</longdescription>
+<upstream>
+ <remote-id type="github">magit/magit-popup</remote-id>
+</upstream>
+</pkgmetadata>