summaryrefslogtreecommitdiff
path: root/app-emacs/macrostep/macrostep-0.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-27 03:09:13 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-27 03:09:13 +0100
commit8d3ae5c288a62253ed3bc3d71336bf2061cfdb51 (patch)
treed303ef81057f764dd5468859b1d8af22d21475b9 /app-emacs/macrostep/macrostep-0.9.ebuild
parent90e9e4843d7d63c5e7fa1f5d6d6f4cc7350ce77c (diff)
gentoo auto-resync : 27:09:2022 - 03:09:13
Diffstat (limited to 'app-emacs/macrostep/macrostep-0.9.ebuild')
-rw-r--r--app-emacs/macrostep/macrostep-0.9.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-emacs/macrostep/macrostep-0.9.ebuild b/app-emacs/macrostep/macrostep-0.9.ebuild
new file mode 100644
index 000000000000..bfe4654194fc
--- /dev/null
+++ b/app-emacs/macrostep/macrostep-0.9.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24.3
+
+inherit elisp
+
+DESCRIPTION="Interactive macro-expander for Emacs"
+HOMEPAGE="https://github.com/joddie/macrostep/"
+SRC_URI="https://github.com/joddie/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.org )
+PATCHES=( "${FILESDIR}"/${PN}-test.patch )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . --load ${PN}-test.el || die "test failed"
+}
+
+src_install() {
+ rm macrostep-test.el{,c} || die
+
+ elisp_src_install
+}