summaryrefslogtreecommitdiff
path: root/app-emacs/lsp-mode
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
commite9d044d4b9b71200a96adfa280848858c0f468c9 (patch)
tree1bd8ef816043a8cd340f1d774e79553a1a7d31d8 /app-emacs/lsp-mode
parentfc2f1018fc323ef2c6572734a9b130427cba76a6 (diff)
gentoo resync : 13.11.2021
Diffstat (limited to 'app-emacs/lsp-mode')
-rw-r--r--app-emacs/lsp-mode/Manifest4
-rw-r--r--app-emacs/lsp-mode/files/50lsp-mode-gentoo.el35
-rw-r--r--app-emacs/lsp-mode/lsp-mode-8.0.0.ebuild39
-rw-r--r--app-emacs/lsp-mode/metadata.xml12
4 files changed, 90 insertions, 0 deletions
diff --git a/app-emacs/lsp-mode/Manifest b/app-emacs/lsp-mode/Manifest
new file mode 100644
index 000000000000..d4637db414a9
--- /dev/null
+++ b/app-emacs/lsp-mode/Manifest
@@ -0,0 +1,4 @@
+AUX 50lsp-mode-gentoo.el 2081 BLAKE2B ac9eee2a41fa09e1ee72cabef2380b6095f469f1c668833b4d6d59964796a974457e2f85f4cdb7b66ea652ad23a6806326f9a43c20b4d1592fc1f19eb33a3773 SHA512 632fb2b9d0af9735c16fffbe6d0aca7ba0a494edd001ea289f17836e9ddd34d9ea60cf22035194e1837505cc214370be31e0dff0637a59361eeb6a4f2d12e816
+DIST lsp-mode-8.0.0.tar.gz 14703640 BLAKE2B ab7993772cfc127ee94ba4a0af75e8d7f6789ac22c76acce8df250b5579c1dd2f41e353b26cbdcf6e1a2e6a8d1f8a179d4736b67914cdec31c23032f93dffd3c SHA512 2620288142cea7b06ad2725b63e5db945b1d62d0b4c215e8d35d79d6c3f05bcdf2736dab34bd10c2b9f8928caf36ef617182c41c309e62e2ce8ddf45df376cbc
+EBUILD lsp-mode-8.0.0.ebuild 770 BLAKE2B a71c666d6657bbf9660564be35f1214f2bdc27e300809452e021e2e759456092b1e50f7ffc53432243de45eedfdea23b1c3b464b5b96213fdf2c5cc99c6394cb SHA512 0bf24d7d6a8077b40bf2197cb684a262407140539187b126c84f99e27855c9d5f06c662ee871e3f9dddeb5cd265bb61e9cf9eea02a36f773f3ff61c304e80246
+MISC metadata.xml 364 BLAKE2B d28d1feb1f2948839ed9759bd1d7f22285218f301e2862e50b6a58aad591f81d8d94ff8bf2fce8c399c04839467e89b82c2487b2ff09a129f4636d81555db4f8 SHA512 1b9aff2f7852a2af981b93c1e2ca1a0df378e52d0a0817a7fe4a00e5c74721389979df9367a6e93c3a62ac02adb118fbdfff84272f9f902c5883d0759a422d4c
diff --git a/app-emacs/lsp-mode/files/50lsp-mode-gentoo.el b/app-emacs/lsp-mode/files/50lsp-mode-gentoo.el
new file mode 100644
index 000000000000..c7cd4f608612
--- /dev/null
+++ b/app-emacs/lsp-mode/files/50lsp-mode-gentoo.el
@@ -0,0 +1,35 @@
+;;; lsp-mode site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+
+(autoload 'lsp-completion-at-point "lsp-completion" "Get lsp completions." t)
+(autoload 'lsp-completion--enable "lsp-completion" "Enable LSP completion support.")
+(autoload 'lsp-completion-mode "lsp-completion" "Toggle LSP completion support." t)
+
+(autoload 'lsp-diagnostics--enable "lsp-diagnostics" "Enable LSP checker support.")
+(autoload 'lsp-diagnostics-mode "lsp-diagnostics" "Toggle LSP diagnostics integration." t)
+
+(autoload 'lsp-dired-mode "lsp-dired" "Display `lsp-mode' icons for each file in a dired buffer." t)
+
+(autoload 'lsp-headerline--enable-breadcrumb "lsp-headerline" "Enable breadcrumb on headerline.")
+(autoload 'lsp-headerline-breadcrumb-mode "lsp-headerline" "Toggle breadcrumb on headerline." t)
+
+(autoload 'lsp-ido-workspace-symbol "lsp-ido" "`ido' for lsp workspace/symbol." t)
+
+(autoload 'lsp-iedit-highlights "lsp-iedit" "Start an `iedit' operation on the documentHighlights at point." t)
+
+(autoload 'lsp-lens--enable "lsp-lens" "Enable lens mode.")
+(autoload 'lsp-lens-show "lsp-lens" "Display lenses in the buffer." t)
+(autoload 'lsp-lens-mode "lsp-lens" "Toggle code-lens overlays." t)
+
+(autoload 'lsp "lsp-mode" "Entry point for the server startup." t)
+(autoload 'lsp-deferred "lsp-mode" "Entry point that defers server startup until buffer is visible." t)
+
+(autoload 'lsp-modeline-code-actions-mode "lsp-modeline" "Toggle code actions on modeline." t)
+(autoload 'lsp-modeline-diagnostics-mode "lsp-modeline" "Toggle diagnostics modeline." t)
+(autoload 'lsp-modeline-workspace-status-mode "lsp-modeline" "Toggle workspace status on modeline." t)
+
+(autoload 'lsp--semantic-tokens-initialize-buffer "lsp-semantic-tokens" "Initialize the buffer for semantic tokens.")
+(autoload 'lsp--semantic-tokens-initialize-workspace "lsp-semantic-tokens" "Initialize semantic tokens for WORKSPACE.")
+(autoload 'lsp-semantic-tokens--enable "lsp-semantic-tokens" "Enable semantic tokens mode.")
+(autoload 'lsp-semantic-tokens-mode "lsp-semantic-tokens" "Toggle semantic-tokens support.")
diff --git a/app-emacs/lsp-mode/lsp-mode-8.0.0.ebuild b/app-emacs/lsp-mode/lsp-mode-8.0.0.ebuild
new file mode 100644
index 000000000000..610948576522
--- /dev/null
+++ b/app-emacs/lsp-mode/lsp-mode-8.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26.1
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Emacs client/library for the Language Server Protocol"
+HOMEPAGE="https://emacs-lsp.github.io/lsp-mode/"
+SRC_URI="https://github.com/emacs-lsp/lsp-mode/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+DOCS="CHANGELOG.org README.md"
+
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND="
+ >=app-emacs/dash-2.18.0
+ >=app-emacs/f-0.20.0
+ >=app-emacs/ht-2.3
+ app-emacs/lv
+ >=app-emacs/markdown-mode-2.3
+ >=app-emacs/spinner-1.7.3
+"
+DEPEND=${RDEPEND}
+
+# Requires unpackaged dependencies, e.g. Cask
+RESTRICT="test"
+
+src_install() {
+ elisp_src_install
+
+ elisp-install ${PN}/clients clients/*
+}
diff --git a/app-emacs/lsp-mode/metadata.xml b/app-emacs/lsp-mode/metadata.xml
new file mode 100644
index 000000000000..75a2e5515257
--- /dev/null
+++ b/app-emacs/lsp-mode/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<stabilize-allarches/>
+<upstream>
+ <remote-id type="github">emacs-lsp/lsp-mode</remote-id>
+</upstream>
+</pkgmetadata>