summaryrefslogtreecommitdiff
path: root/app-emacs/lsp-mode
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-19 07:53:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-19 07:53:50 +0000
commit32b8124b0a5827960601f2183a970103b3d231b7 (patch)
treefebd1cb81d2417f5452d0e21f81d06663f12caa3 /app-emacs/lsp-mode
parent89e7f1cd6dd17f245898939477ef38d45dd112b9 (diff)
gentoo auto-resync : 19:12:2023 - 07:53:49
Diffstat (limited to 'app-emacs/lsp-mode')
-rw-r--r--app-emacs/lsp-mode/Manifest2
-rw-r--r--app-emacs/lsp-mode/lsp-mode-8.0.1_pre20231218.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/app-emacs/lsp-mode/Manifest b/app-emacs/lsp-mode/Manifest
index 794f8311c933..0270f7ab3557 100644
--- a/app-emacs/lsp-mode/Manifest
+++ b/app-emacs/lsp-mode/Manifest
@@ -1,4 +1,6 @@
AUX 50lsp-mode-gentoo.el 2081 BLAKE2B ac9eee2a41fa09e1ee72cabef2380b6095f469f1c668833b4d6d59964796a974457e2f85f4cdb7b66ea652ad23a6806326f9a43c20b4d1592fc1f19eb33a3773 SHA512 632fb2b9d0af9735c16fffbe6d0aca7ba0a494edd001ea289f17836e9ddd34d9ea60cf22035194e1837505cc214370be31e0dff0637a59361eeb6a4f2d12e816
DIST lsp-mode-8.0.0_p20220620.tar.gz 15464614 BLAKE2B 10e50a52e2a725b1a275b81514bb268619b128370f8989970c75c87bc37516588e798c5f2531b73689d9d102fbd6b965841c6d8a0c337cb8d9052b632a01e289 SHA512 d464418df6eb99d8a1f4cad8c9e31ca057286f846afbb0078fdff21cfc685ffc158b1b37d22224372bee67eb5298f20bb4db83ed466c09e4b4b3a83db865ef09
+DIST lsp-mode-8.0.1_pre20231218.tar.gz 16396690 BLAKE2B e841e1cda6e26ba1d646ea8ffeee7212fb3352e4ed73c323212e9bd883ddbe3461918b3ab435a16e6568d2fdaf97b165accd8876625415dfa428259c0c93998f SHA512 d3f5a26e40b7b569ba185d605208bd888aed6430f1fa5b608db47ba727e72fb540646a3908b80ab04db763d9be9adb8b58ef88165f31c874749ed26f7086c0fc
EBUILD lsp-mode-8.0.0_p20220620.ebuild 1193 BLAKE2B dd0b6d59ea797ab34d8c59f54c2e6ccbbedc1d7f7257630b86f2f0373b7f782fcf1d4172d80ed1571818e67ddd37a00d6193b990847bd565432e33b580cbf866 SHA512 95ddadbaf53d5c444e295b56457bf201908242a71e262db4662289baee588fd58beb9161b1ab8e72c3090720caf1af0490612bce6c85af347e56c91a1d2a5915
+EBUILD lsp-mode-8.0.1_pre20231218.ebuild 1255 BLAKE2B a273fe7d4a20e3e08b74f372a20e5d87d344d1119d8e375e25330c89ad302dc3ab4e28b26923bdf1ddf45843000de02bc1b4d562ae406f359bb6f78ffac4029d SHA512 75e2941bdac6f81bb8fb66ebb16bbbf8c4f90444af9a2000c58ca047ef09f9984d491f5c2eff6d425bab0f70bd53a306bee8f69ac3161b8e610d0ba1faa8a2f7
MISC metadata.xml 364 BLAKE2B d28d1feb1f2948839ed9759bd1d7f22285218f301e2862e50b6a58aad591f81d8d94ff8bf2fce8c399c04839467e89b82c2487b2ff09a129f4636d81555db4f8 SHA512 1b9aff2f7852a2af981b93c1e2ca1a0df378e52d0a0817a7fe4a00e5c74721389979df9367a6e93c3a62ac02adb118fbdfff84272f9f902c5883d0759a422d4c
diff --git a/app-emacs/lsp-mode/lsp-mode-8.0.1_pre20231218.ebuild b/app-emacs/lsp-mode/lsp-mode-8.0.1_pre20231218.ebuild
new file mode 100644
index 000000000000..1910811a73ae
--- /dev/null
+++ b/app-emacs/lsp-mode/lsp-mode-8.0.1_pre20231218.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+COMMIT=5b2f3741bb797371bba2932653ca829167f9745a
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Emacs client/library for the Language Server Protocol"
+HOMEPAGE="https://emacs-lsp.github.io/lsp-mode/"
+SRC_URI="https://github.com/emacs-lsp/${PN}/archive/${COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND="
+ >=app-emacs/dash-2.18.0
+ >=app-emacs/f-0.20.0
+ app-emacs/ht
+ app-emacs/lv
+ app-emacs/markdown-mode
+ app-emacs/spinner
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ app-emacs/deferred
+ app-emacs/ecukes
+ app-emacs/el-mock
+ app-emacs/espuds
+ app-emacs/flycheck
+ app-emacs/undercover
+ )
+"
+
+DOCS=( AUTHORS CHANGELOG.org README.md refcard )
+BYTECOMPFLAGS="-L . -L clients"
+ELISP_REMOVE="
+ test/lsp-clangd-test.el
+ test/lsp-common-test.el
+ test/lsp-integration-test.el
+" # Remove failing tests.
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests ert-runner "${S}" -t "!no-win" -t "!org"
+
+src_compile() {
+ elisp_src_compile
+ elisp-compile clients/*.el
+}
+
+src_install() {
+ elisp_src_install
+ elisp-install "${PN}/clients" clients/*
+}