summaryrefslogtreecommitdiff
path: root/app-emacs/lsp-mode/lsp-mode-8.0.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /app-emacs/lsp-mode/lsp-mode-8.0.0-r1.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'app-emacs/lsp-mode/lsp-mode-8.0.0-r1.ebuild')
-rw-r--r--app-emacs/lsp-mode/lsp-mode-8.0.0-r1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/app-emacs/lsp-mode/lsp-mode-8.0.0-r1.ebuild b/app-emacs/lsp-mode/lsp-mode-8.0.0-r1.ebuild
new file mode 100644
index 000000000000..ec668118c0b9
--- /dev/null
+++ b/app-emacs/lsp-mode/lsp-mode-8.0.0-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26.1
+
+inherit elisp
+
+DESCRIPTION="Emacs client/library for the Language Server Protocol"
+HOMEPAGE="https://emacs-lsp.github.io/lsp-mode/"
+SRC_URI="https://github.com/emacs-lsp/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=app-emacs/dash-2.18.0
+ >=app-emacs/f-0.20.0
+ app-emacs/ht
+ app-emacs/lv
+ app-emacs/markdown-mode
+ app-emacs/spinner
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ app-emacs/deferred
+ app-emacs/ecukes
+ app-emacs/el-mock
+ app-emacs/ert-runner
+ app-emacs/espuds
+ app-emacs/flycheck
+ app-emacs/undercover
+ )
+"
+
+DOCS=( AUTHORS CHANGELOG.org README.md refcard )
+BYTECOMPFLAGS="-L . -L clients"
+ELISP_REMOVE="test/lsp-clangd-test.el test/lsp-common-test.el
+ test/lsp-integration-test.el" # Remove failing tests
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-compile clients/*.el
+}
+
+src_test() {
+ ert-runner -L clients --reporter ert+duration -t "!no-win" -t "!org" || die
+}
+
+src_install() {
+ elisp_src_install
+ elisp-install ${PN}/clients clients/*
+}