summaryrefslogtreecommitdiff
path: root/app-emacs/kind-icon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-27 22:51:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-27 22:51:10 +0000
commitee0c4d5e506a6c64994a15c3af5cf1ca22045567 (patch)
treebdf578939023d42f04092ddb4bcd190eb391770f /app-emacs/kind-icon
parent161eaa4b12ca6314376288834bba20b7824d0d77 (diff)
gentoo auto-resync : 27:11:2023 - 22:51:09
Diffstat (limited to 'app-emacs/kind-icon')
-rw-r--r--app-emacs/kind-icon/Manifest2
-rw-r--r--app-emacs/kind-icon/kind-icon-0.2.1.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/app-emacs/kind-icon/Manifest b/app-emacs/kind-icon/Manifest
index 11154eb9940b..915c17e8f17d 100644
--- a/app-emacs/kind-icon/Manifest
+++ b/app-emacs/kind-icon/Manifest
@@ -1,4 +1,6 @@
AUX 50kind-icon-gentoo.el 160 BLAKE2B 172306977f0fefb5a50499d7de9dab64f90e1004ef259ec253d7ea94cca670cb1f33849fe282b290413b0a7715f40c5dc72c72b8a474b4d2e64db249c7ecbca8 SHA512 fd8a2f37b43f8747533d25a773c4a849e59e0b420ef1f4eff4f9daa97f91aa56d41f0a803e6cd8cb9a2161fa62ac9ac5966542701d4a15005506b323c16e4eb2
DIST kind-icon-0.2.0.tar.xz 19804 BLAKE2B 6efd4470114adf451bd08a7158b0e9c6fa5d51978d0228997983d3164d0e4451dbb0ea413bcf64967a18a08e78a76ac59de4acd61a2304512920a37cd9c187f8 SHA512 fafe8eccd2ad7f459105357b6a097cdcdb2e4e3e1567acb3bdaa4fa9e861fcbf44ac5b697ff8755d0c9789e4575de6e6504f86bb851283e89d0571c3b5b65e0a
+DIST kind-icon-0.2.1.tar.gz 21869 BLAKE2B 788dad3e334bb2f85dbd260eb04b60970dcea1030d920f922bc1b00fc561fe825e959891af73af391efa4f3408d72bbd5f021fa3a52edaf27ebdb8894c76a708 SHA512 9ebea8c1bca4b85f1486b0114df06b29463d3852ebaf66a8cf221a73c5456444ba0e1c6d4e43ddac8f51ea2cece18edc2208ab341a8124c5f71a06141f8f641e
EBUILD kind-icon-0.2.0.ebuild 471 BLAKE2B 28744c5b32cc3793447464dc595e1dd9bae962cd4533f88eec7b99803234c5db032489d29a722f84bbb6c9faefcfc724e543adbcf384fd0d515804c5b893b75e SHA512 62ded363d8ea0cd4d8a39ddee469ccec1de59cd9d8e0c639c6a7e106b1d61bf44a063f84bb4d917aa34b7132e52feafea12281550143539b0d938bafbc6c8375
+EBUILD kind-icon-0.2.1.ebuild 628 BLAKE2B a3e0972d8338eed5db93c51b5a92a30bf7d1c903f0ecd0550b5f87cf3a4ce7dfe3b9dda5b1c7485e5da2377315cbe5c2f32f1a7aa6912b595f04a94b80f6942c SHA512 feaf5e402038f6cf695a15dd2757db2d80bebb7674bd65f95abce9275bf8d53d9887d8e2806d81e822e2916a01f48566d58e75f08def42fce1ba6b35b7d60ca8
MISC metadata.xml 578 BLAKE2B e5e0450ac488021d88a578f1322cdeea8a94bb2d2dacfd3f84b75addf0c5506a3f78418cc35f72eb0e38cba4f507acc6de3d5ae24676c7f5e9cb0e88501fb7e3 SHA512 477e1571f256bef169893ee7a23541f7a0f1e1dd37c4df7a30a5d9461c082570bdc4b8a8eef6588643e8b968ac82c63ee2307247b04be4252e3f89689fc1e43b
diff --git a/app-emacs/kind-icon/kind-icon-0.2.1.ebuild b/app-emacs/kind-icon/kind-icon-0.2.1.ebuild
new file mode 100644
index 000000000000..be600aa4026c
--- /dev/null
+++ b/app-emacs/kind-icon/kind-icon-0.2.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS="27.1"
+
+inherit elisp
+
+DESCRIPTION="Completion kind icons"
+HOMEPAGE="https://github.com/jdtsmith/kind-icon/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/jdtsmith/${PN}.git"
+else
+ SRC_URI="https://github.com/jdtsmith/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ app-emacs/svg-lib
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-make-autoload-file
+ elisp_src_compile
+}