summaryrefslogtreecommitdiff
path: root/app-emacs/kind-icon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-07 23:37:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-07 23:37:50 +0100
commit8dfbaa8100b5c51e1de0e4e476ef5513e3ed1bdd (patch)
tree6514153552d2daad7d178ee75d47332710e2979e /app-emacs/kind-icon
parent2fe5661a32d6ec0ba1d6b37cc8ae67e3f81459ec (diff)
gentoo auto-resync : 07:05:2023 - 23:37:50
Diffstat (limited to 'app-emacs/kind-icon')
-rw-r--r--app-emacs/kind-icon/Manifest4
-rw-r--r--app-emacs/kind-icon/files/50kind-icon-gentoo.el3
-rw-r--r--app-emacs/kind-icon/kind-icon-0.1.9.ebuild26
-rw-r--r--app-emacs/kind-icon/metadata.xml20
4 files changed, 53 insertions, 0 deletions
diff --git a/app-emacs/kind-icon/Manifest b/app-emacs/kind-icon/Manifest
new file mode 100644
index 000000000000..fd5c89be9310
--- /dev/null
+++ b/app-emacs/kind-icon/Manifest
@@ -0,0 +1,4 @@
+AUX 50kind-icon-gentoo.el 160 BLAKE2B 172306977f0fefb5a50499d7de9dab64f90e1004ef259ec253d7ea94cca670cb1f33849fe282b290413b0a7715f40c5dc72c72b8a474b4d2e64db249c7ecbca8 SHA512 fd8a2f37b43f8747533d25a773c4a849e59e0b420ef1f4eff4f9daa97f91aa56d41f0a803e6cd8cb9a2161fa62ac9ac5966542701d4a15005506b323c16e4eb2
+DIST kind-icon-0.1.9.tar.lz 19417 BLAKE2B 9d1590627d1d6bff65af9d0658a0aed9245f43b9d27abc57fdc43edae200f8d5fff993d43d0eae84499975a847fae069d706fd47cb0f7b81406f220fd047bfb4 SHA512 b9cd384399eadd898001ae502315b0c78efb483ccb4414f41eab51cfd2a18a98a53618507f6d2bd5c7f6758a358d744b143f00a7912237efcc9451591505933e
+EBUILD kind-icon-0.1.9.ebuild 544 BLAKE2B 98c10b72963e7b6797797de7ae7d3522f6ab2fb1c131570857ef2ba1e179c6c00bec21a358d386689524b3eb259ba3b4882c7b92dd7cec4822d0114292b60599 SHA512 3198f603eff56ac0f01de049278fd8fc4aaf08a13656be5f867c33492b434edf02956b997b5d453b2247e9ce5d503df83295ae93d95a41943ef859fa4c30555c
+MISC metadata.xml 578 BLAKE2B e5e0450ac488021d88a578f1322cdeea8a94bb2d2dacfd3f84b75addf0c5506a3f78418cc35f72eb0e38cba4f507acc6de3d5ae24676c7f5e9cb0e88501fb7e3 SHA512 477e1571f256bef169893ee7a23541f7a0f1e1dd37c4df7a30a5d9461c082570bdc4b8a8eef6588643e8b968ac82c63ee2307247b04be4252e3f89689fc1e43b
diff --git a/app-emacs/kind-icon/files/50kind-icon-gentoo.el b/app-emacs/kind-icon/files/50kind-icon-gentoo.el
new file mode 100644
index 000000000000..b9e72be87371
--- /dev/null
+++ b/app-emacs/kind-icon/files/50kind-icon-gentoo.el
@@ -0,0 +1,3 @@
+;;; app-emacs/kind-icon site configuration -*- lexical-binding: t; -*-
+(add-to-list 'load-path "@SITELISP@")
+(load "@SITELISP@/kind-icon-autoloads.el" nil t)
diff --git a/app-emacs/kind-icon/kind-icon-0.1.9.ebuild b/app-emacs/kind-icon/kind-icon-0.1.9.ebuild
new file mode 100644
index 000000000000..eb4ee87bfc08
--- /dev/null
+++ b/app-emacs/kind-icon/kind-icon-0.1.9.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS="27.1"
+inherit elisp unpacker
+
+DESCRIPTION="Completion kind icons"
+HOMEPAGE="https://github.com/jdtsmith/kind-icon"
+SRC_URI="https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.tar.lz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="app-emacs/svg-lib"
+DEPEND="${RDEPEND}"
+BDEPEND="$(unpacker_src_uri_depends)"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ elisp-make-autoload-file
+ elisp_src_install
+}
diff --git a/app-emacs/kind-icon/metadata.xml b/app-emacs/kind-icon/metadata.xml
new file mode 100644
index 000000000000..fda2bb3e66ad
--- /dev/null
+++ b/app-emacs/kind-icon/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>arsen@gentoo.org</email>
+ <name>Arsen Arsenović</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">jdtsmith/kind-icon</remote-id>
+ </upstream>
+</pkgmetadata>