summaryrefslogtreecommitdiff
path: root/app-emacs/jinx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-29 01:37:52 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-29 01:37:52 +0000
commitdd5af718da993c9a6f040afb037ba1246974c6e5 (patch)
treec8544b7bb70c29e5cb9a3858fd0c16c62c1f6f27 /app-emacs/jinx
parent29eb24bde1b57b17d24078f22ee071e27f6b5348 (diff)
gentoo auto-resync : 29:12:2023 - 01:37:52
Diffstat (limited to 'app-emacs/jinx')
-rw-r--r--app-emacs/jinx/Manifest2
-rw-r--r--app-emacs/jinx/jinx-1.1.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/app-emacs/jinx/Manifest b/app-emacs/jinx/Manifest
index 803c03db0d93..b3f810fea759 100644
--- a/app-emacs/jinx/Manifest
+++ b/app-emacs/jinx/Manifest
@@ -1,6 +1,8 @@
AUX 50jinx-gentoo.el 191 BLAKE2B a183a9485eea61590192547a8c99e8c974b1974851073a49a33304ec0d9d43158279669aa8dc2ca26d9521c61b229c9fd490dec81643126f678585974dea7483 SHA512 dc0378743253f61f1c94d7fbcf8e3fff767296eecb26e856bbb5f24409b879e3d1a4f52efe87ea0ce106281b216396e94a72a7842b0fe4a48a80b4c41cb05921
DIST jinx-0.9.tar.xz 20852 BLAKE2B 09a6a765cf51c2efe3a90317cdaeff03c2bc35bd6202b71070a19d51189c2ee6fc7406881130986dcdcfd9a9f6cec4aee25e0e71924a38aca7708aa3b99eb550 SHA512 a61e377fdee84fc91c3714f12f1bfffd95d6618a78c48dbcda6ff134f2ce3b604f283ddc5e7040c125e406ec573e3f6e7bfcde681fe574b84d7736e114ea7c0b
DIST jinx-1.0.tar.gz 33255 BLAKE2B 19edfc30e85b5da047962f61256036c2e07fdb304632e8a07edd313616343214e74a981ca971eacf5ec23e595144edb4f511313c94140639d85b704d0517d9a3 SHA512 7990d7bb090ad8aec6afdaa68d7125ad2dfe0259327afd596f9f6c44b4b80f29a92aa6f0057f85f76f42b28004240edc85eb8e48ef21e02c95643e138751bbba
+DIST jinx-1.1.tar.gz 33820 BLAKE2B 457214768c7220376a8f1e5c05eedf855fdd560b265ca0431840aee05428d1cf3576e3ef0214cf64b164984adb0951e7932271dd80b6b0d06ed740172335c5fe SHA512 3bb1981557e35d3834834cbdc0fc1360b5a931f0e16cc68c2eb0739956db9e8e97d615236e575758cbb282087a7baad3c956fc9e628679a791ca744e8365355b
EBUILD jinx-0.9.ebuild 868 BLAKE2B b70353ad46b10c507c1f2206c8acb07334b35d296ff90ffc0397cdebdf9decffbf05a24c5402ad8166c575e8f5b56f430e8f6dcd4e359fa9f9bb6c80003917d8 SHA512 773729eb0c757b07d9deff9935d0cf91f18227da1afb01308657cc55c07f252f3bcfa2e9e78ec97e245b5199e8f3c2f039c695622ebcf4991e1ae3fe753f308f
EBUILD jinx-1.0.ebuild 921 BLAKE2B c1c1363d7a1351bf9b9acd59aec72bef46990563f6f087e334b19750792a3e7513e8e7bb70b74f40bf9771d85a63b9322047fd62cd8171bdd7ce2a3ac3ab2bdf SHA512 2beaddd869ca40133928640e5163d18e407ebb97c6003577f05f0266591125b8c9e39069679efc5eef9db9d23385169ee74c8f9657d0873232309c67cc883656
+EBUILD jinx-1.1.ebuild 921 BLAKE2B c1c1363d7a1351bf9b9acd59aec72bef46990563f6f087e334b19750792a3e7513e8e7bb70b74f40bf9771d85a63b9322047fd62cd8171bdd7ce2a3ac3ab2bdf SHA512 2beaddd869ca40133928640e5163d18e407ebb97c6003577f05f0266591125b8c9e39069679efc5eef9db9d23385169ee74c8f9657d0873232309c67cc883656
MISC metadata.xml 596 BLAKE2B 637e6f9f170f3ce64857712ff8156e123e42fa1e3495291ca05fc260f69ba267df6536c08b2a1ba042d8cc13f86f499d1e5f8dd223b89efd2c62ca38a9f37d2d SHA512 1fd1a6b8ba360f7aa2c03e8c318482b564afcf2392c20fe0c70d96b181df9323706c3b81bd3aa98916b65cff29aafcf9c9a486bfbbd55b775ff7adee85886950
diff --git a/app-emacs/jinx/jinx-1.1.ebuild b/app-emacs/jinx/jinx-1.1.ebuild
new file mode 100644
index 000000000000..141f27f3d77f
--- /dev/null
+++ b/app-emacs/jinx/jinx-1.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+inherit edo elisp toolchain-funcs
+
+DESCRIPTION="Enchanted Spell Checker for GNU Emacs"
+HOMEPAGE="https://github.com/minad/jinx"
+
+SRC_URI="
+ https://github.com/minad/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz
+"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-text/enchant:2
+ >=app-emacs/compat-29.1.4.0
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+SITEFILE="50${PN}-gentoo.el"
+
+ELISP_TEXINFO="${PN}.texi"
+
+src_compile() {
+ edo $(tc-getCC) -fPIC -Wall -Wextra -shared \
+ $($(tc-getPKG_CONFIG) --cflags --libs enchant-2) \
+ ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} -o jinx-mod.so jinx-mod.c
+ elisp-org-export-to texinfo README.org
+ elisp_src_compile
+}
+
+src_install() {
+ elisp-make-autoload-file
+ elisp_src_install
+
+ elisp-modules-install "${PN}" jinx-mod.so
+ doinfo jinx.info
+}