summaryrefslogtreecommitdiff
path: root/app-emacs/jinx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-28 17:13:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-28 17:13:02 +0100
commit670fe3b64a21a723fda1e52fe61cad2327f81f67 (patch)
treee6699a97f6776ef2588129c3ad5b895621d4e4aa /app-emacs/jinx
parent7aa28e7310855bc5ef0d32b22e8b58eec55c28c9 (diff)
gentoo auto-resync : 28:04:2023 - 17:13:02
Diffstat (limited to 'app-emacs/jinx')
-rw-r--r--app-emacs/jinx/Manifest2
-rw-r--r--app-emacs/jinx/jinx-0.8.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/app-emacs/jinx/Manifest b/app-emacs/jinx/Manifest
index c55cc66a030d..63a04e040701 100644
--- a/app-emacs/jinx/Manifest
+++ b/app-emacs/jinx/Manifest
@@ -1,4 +1,6 @@
AUX 50jinx-gentoo.el 191 BLAKE2B a183a9485eea61590192547a8c99e8c974b1974851073a49a33304ec0d9d43158279669aa8dc2ca26d9521c61b229c9fd490dec81643126f678585974dea7483 SHA512 dc0378743253f61f1c94d7fbcf8e3fff767296eecb26e856bbb5f24409b879e3d1a4f52efe87ea0ce106281b216396e94a72a7842b0fe4a48a80b4c41cb05921
DIST jinx-0.7.tar.xz 17816 BLAKE2B d31ae1c35c5808237890c5c6ecaab915af7cc70260ae05de06c049a9bc250c3ff824a18256715fb7ed12e02df60b24aa957192b95fd3a0ab28e5102f5cf63718 SHA512 ed291b1d5eb5b799f629ed3d0d5bfca65e7f11d9349a672f09087a47ebe65a7bc8bef8fda6d344472dc8bc14c97c5d49c79365d45da5c9570e0cf84d51723928
+DIST jinx-0.8.tar.xz 19064 BLAKE2B f5c2382e635b4266ac7ea4a500f3ca56f029c1104608ae12570a5983e971dff17bd2d4c7c721b080ac7ab136e7a7cc305cc96b2a5dc825caf17c5713d37702d8 SHA512 63ef5031252a98e3c4e22a331fbe99d6fb0465f965fbf7ce4e319514b2ddd8230db66d48c72bc5d957a77b2c8609f08636f1579fe4cefb44e2f56b654638fb52
EBUILD jinx-0.7.ebuild 851 BLAKE2B 34a93054271372e697f5432bde9fe725fb0b357251a4866c3748c816c30910df8a0c130f06ef42e8ebe643117e3033f8710f4eba26fd3ca9ce99129d8af9988f SHA512 e9f0d8cc02c507f1952d09a65a3954e90517dc3a9bd390c235e26713dc5f50816ed53c0f7f9a09d9a31edd3c9062ec744ae0e7fec4d6c507962e24f4533fa0fc
+EBUILD jinx-0.8.ebuild 851 BLAKE2B 34a93054271372e697f5432bde9fe725fb0b357251a4866c3748c816c30910df8a0c130f06ef42e8ebe643117e3033f8710f4eba26fd3ca9ce99129d8af9988f SHA512 e9f0d8cc02c507f1952d09a65a3954e90517dc3a9bd390c235e26713dc5f50816ed53c0f7f9a09d9a31edd3c9062ec744ae0e7fec4d6c507962e24f4533fa0fc
MISC metadata.xml 596 BLAKE2B 637e6f9f170f3ce64857712ff8156e123e42fa1e3495291ca05fc260f69ba267df6536c08b2a1ba042d8cc13f86f499d1e5f8dd223b89efd2c62ca38a9f37d2d SHA512 1fd1a6b8ba360f7aa2c03e8c318482b564afcf2392c20fe0c70d96b181df9323706c3b81bd3aa98916b65cff29aafcf9c9a486bfbbd55b775ff7adee85886950
diff --git a/app-emacs/jinx/jinx-0.8.ebuild b/app-emacs/jinx/jinx-0.8.ebuild
new file mode 100644
index 000000000000..3708e4eda694
--- /dev/null
+++ b/app-emacs/jinx/jinx-0.8.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+inherit edo elisp toolchain-funcs
+
+DESCRIPTION="Enchanted Spell Checker for GNU Emacs"
+HOMEPAGE="https://github.com/minad/jinx"
+
+# Recompressed from ELPA.
+SRC_URI="https://dev.gentoo.org/~arsen/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-text/enchant:2
+ >=app-emacs/compat-29.1.4.0
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+ELISP_REMOVE="${PN}-pkg.el"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ edo $(tc-getCC) -fPIC -Wall -Wextra -shared \
+ $($(tc-getPKG_CONFIG) --cflags --libs enchant-2) \
+ ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} -o jinx-mod.so jinx-mod.c
+ elisp_src_compile
+}
+
+src_install() {
+ elisp-make-autoload-file
+ elisp_src_install
+
+ elisp-modules-install "${PN}" jinx-mod.so
+}