summaryrefslogtreecommitdiff
path: root/app-emacs/jinx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-18 05:54:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-18 05:54:20 +0100
commit5a1fb66df455454109e1de61d38b48f509dc68b8 (patch)
tree0213f12db1b0138bffda43d11208c5d701967638 /app-emacs/jinx
parent3a8423ee2874c2fd96358b28af08d38d83e9bdc0 (diff)
gentoo auto-resync : 18:04:2023 - 05:54:20
Diffstat (limited to 'app-emacs/jinx')
-rw-r--r--app-emacs/jinx/Manifest5
-rw-r--r--app-emacs/jinx/files/50jinx-gentoo.el4
-rw-r--r--app-emacs/jinx/files/jinx-0.6-try-load-path.patch32
-rw-r--r--app-emacs/jinx/jinx-0.6.ebuild44
-rw-r--r--app-emacs/jinx/metadata.xml19
5 files changed, 104 insertions, 0 deletions
diff --git a/app-emacs/jinx/Manifest b/app-emacs/jinx/Manifest
new file mode 100644
index 000000000000..999ebd3515a5
--- /dev/null
+++ b/app-emacs/jinx/Manifest
@@ -0,0 +1,5 @@
+AUX 50jinx-gentoo.el 190 BLAKE2B 8b113ff9d9d377b46055bd4c485aa8e7e93db737b1997ba0c6ee951691441a66e16c31bd2ac4485d1f34b8f170c5046da1bb927b582004482f43dc87a962bd4e SHA512 d09e497620b9f7056c7c55cee35bd0bba2cb2a5aaad4d3b760364b28c3ce2a76da7c07d31fd49e33025754a8883bce390fdf3c2e0c6f855182f2326aff0c689a
+AUX jinx-0.6-try-load-path.patch 1066 BLAKE2B 73746f6bab3633f7d9a22410c8726685d778dcbed60bcee9a1dd4e3eef8dc49e97d30c8b15364a865be2718bca5f6a27e34b526fa022302fbd77d1f5b00d23a1 SHA512 ca610b05fb205fb74d38d84871fbf507ad5a9bbf878858ae40e195d8dd6bda0a350e3e4352d6403a0b3c58ce3a0b2c9b6b1a6a156d3ff933477fe00bed138ba4
+DIST jinx-0.6.tar.xz 16692 BLAKE2B 49a391b55b809dd6749ce264b4f732b5c902c1ea67a39e681327ddcf8f728271897202ecd282dc5c4999cf336a5b37c89b9863239291fc944cee352920d99189 SHA512 aa253836d04aec04674ca6dbbd1e73719bee78f4d01d4d93eef2cb05f4c3edc6ec4a11c352fb8952780523f187581fae9c33ea0d30416ec30803b7a196d03f60
+EBUILD jinx-0.6.ebuild 880 BLAKE2B 35139546fd7ff06b7f8eb361f11263befedfb820a4f65871ba99d3c1e0f004f0b15b580eb361c05e5233cfdf8a4c4a222f7b02f06494de3e9e19b2d7cbc2be3c SHA512 a6120ceac27d5124bde41c631f5aea1bed4e3ea5cf752fbc59adc5101dcf84e5e3d9d2da09f01579d754044adcbb9786704892eec1ae416f479adf38be070e33
+MISC metadata.xml 596 BLAKE2B 637e6f9f170f3ce64857712ff8156e123e42fa1e3495291ca05fc260f69ba267df6536c08b2a1ba042d8cc13f86f499d1e5f8dd223b89efd2c62ca38a9f37d2d SHA512 1fd1a6b8ba360f7aa2c03e8c318482b564afcf2392c20fe0c70d96b181df9323706c3b81bd3aa98916b65cff29aafcf9c9a486bfbbd55b775ff7adee85886950
diff --git a/app-emacs/jinx/files/50jinx-gentoo.el b/app-emacs/jinx/files/50jinx-gentoo.el
new file mode 100644
index 000000000000..35fde43c0137
--- /dev/null
+++ b/app-emacs/jinx/files/50jinx-gentoo.el
@@ -0,0 +1,4 @@
+;;; app-emacs/jinx site configuration -*- lexical-binding: t; -*-
+(add-to-list 'load-path "@SITELISP@")
+(add-to-list 'load-path "@EMACSMODULES@")
+(load "@SITELISP@/jinx-autoload.el" nil t)
diff --git a/app-emacs/jinx/files/jinx-0.6-try-load-path.patch b/app-emacs/jinx/files/jinx-0.6-try-load-path.patch
new file mode 100644
index 000000000000..5cb498015791
--- /dev/null
+++ b/app-emacs/jinx/files/jinx-0.6-try-load-path.patch
@@ -0,0 +1,32 @@
+From 3c0aa84130e07cf69219adce8a3494e76977fc26 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Arsen=20Arsenovi=C4=87?= <arsen@gentoo.org>
+Date: Tue, 18 Apr 2023 01:29:55 +0200
+Subject: [PATCH] Try searching the whole load-path for jinx-mod
+
+* jinx.el (jinx--load-module): Try to (locate-library module)
+before trying to look for a sibling file of jinx.el.
+---
+https://github.com/minad/jinx/pull/42
+
+ jinx.el | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/jinx.el b/jinx.el
+index d0cf56d..e829d50 100644
+--- a/jinx.el
++++ b/jinx.el
+@@ -472,6 +472,11 @@ If VISIBLE is non-nil, only include visible overlays."
+ (let ((default-directory
+ (file-name-directory (locate-library "jinx.el" t)))
+ (module (file-name-with-extension "jinx-mod" module-file-suffix)))
++
++ (let ((located-module (locate-library module)))
++ (when located-module
++ (setq module located-module)))
++
+ (unless (file-exists-p module)
+ (let ((command
+ `("cc" "-I." "-O2" "-Wall" "-Wextra" "-fPIC" "-shared"
+--
+2.40.0
+
diff --git a/app-emacs/jinx/jinx-0.6.ebuild b/app-emacs/jinx/jinx-0.6.ebuild
new file mode 100644
index 000000000000..4cb2cfcb7ae9
--- /dev/null
+++ b/app-emacs/jinx/jinx-0.6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+inherit edo elisp toolchain-funcs
+
+DESCRIPTION="Enchanted Spell Checker for GNU Emacs"
+HOMEPAGE="https://github.com/minad/jinx"
+
+# Recompressed from ELPA.
+SRC_URI="https://dev.gentoo.org/~arsen/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-text/enchant:2
+ >=app-emacs/compat-29.1.4.0
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+SITEFILE="50${PN}-gentoo.el"
+
+PATCHES=(
+ "${FILESDIR}"/jinx-0.6-try-load-path.patch
+)
+
+src_compile() {
+ edo $(tc-getCC) -fPIC -Wall -Wextra -shared \
+ $($(tc-getPKG_CONFIG) --cflags --libs enchant-2) \
+ ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} -o jinx-mod.so jinx-mod.c
+ elisp_src_compile
+}
+
+src_install() {
+ elisp-make-autoload-file
+ elisp_src_install
+
+ elisp-modules-install "${PN}" jinx-mod.so
+}
diff --git a/app-emacs/jinx/metadata.xml b/app-emacs/jinx/metadata.xml
new file mode 100644
index 000000000000..983a85253bdd
--- /dev/null
+++ b/app-emacs/jinx/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>arsen@gentoo.org</email>
+ <description>Arsen Arsenović</description>
+ </maintainer>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <description>Sam James</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">minad/jinx</remote-id>
+ </upstream>
+</pkgmetadata>