summaryrefslogtreecommitdiff
path: root/app-emacs/ivy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /app-emacs/ivy
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'app-emacs/ivy')
-rw-r--r--app-emacs/ivy/Manifest5
-rw-r--r--app-emacs/ivy/files/50ivy-gentoo.el3
-rw-r--r--app-emacs/ivy/files/ivy-0.13.4-ivy-test.el-skip.patch39
-rw-r--r--app-emacs/ivy/ivy-0.13.4.ebuild57
-rw-r--r--app-emacs/ivy/metadata.xml15
5 files changed, 119 insertions, 0 deletions
diff --git a/app-emacs/ivy/Manifest b/app-emacs/ivy/Manifest
new file mode 100644
index 000000000000..8fb01188294f
--- /dev/null
+++ b/app-emacs/ivy/Manifest
@@ -0,0 +1,5 @@
+AUX 50ivy-gentoo.el 98 BLAKE2B 4d474a2c101b1cee20da1c56e5336b31df2a75cf5bf24251ba4c72c9d7cfb6cad9cac61923ca1d5ae83370e94cae545cb276cfa6df3f7bd528bd36fdb9e3156a SHA512 ccd9987b868c613535465b9c3041fb2a8c44561b678fe7bf40a276dff272deafb4bc14ce61228ed9cc27f2d0439652aa888e07c0120f6e2a246b0b5fa30a246e
+AUX ivy-0.13.4-ivy-test.el-skip.patch 1352 BLAKE2B b45c62f336e903d35514c00d8f3f1c922b4191c96c0ad4dfcaede594449f075909d77d012cd162e16d6e442c32101124af10db9e2e7d1dcb1a38270a581562a8 SHA512 f56b610d973b9aa62e5474012c1a3ef61a2be39f1d828e714576e15bb5e53d3e9ea8891915db5cee347b747be8b19c8849ab2912eb3a2f2e522160ee6573c1f2
+DIST swiper-0.13.4.tar.gz 245190 BLAKE2B c4da021b92fcedfec39cc60f670c97e4a421b8d4aef8183f50c4872bed835db79884cff113f58cf21dfa7ce33158218aa0cf25d72fc0081dc1c24a3b4376c60e SHA512 bf096a13f675f87af6ea68c974455896b64921ca4d7880c9ccc444aa3cea7c7e04c61be5deb2fd57d0568ff4d86f96ffcf94494b55d84d7a9f647f49b69aec9a
+EBUILD ivy-0.13.4.ebuild 1399 BLAKE2B 0e2c9dccaf2baced75677fa0e3049a0f204684018362b11b833a5c23f0fec3a8eb2429868b26158c20995e5e0723d2a69b7824585bbdba5a2b61ae2e5e8ca9a4 SHA512 c89d34ca459b4ec5b4b3f2c6b8de83f04f2dacd21e4130a910daeaa55301b587b48b532d2333b5d9dc1012701a7f8af035cb10f9853e15a5d6f390288e76f1d9
+MISC metadata.xml 571 BLAKE2B 26ca5a5dfb1bc67ad37086ddc2c2e5976d1b4c763789a27ee83fb08c4a106a21c33b4c9632a3f2858a6b6249c8c49da3e2eafa7efc5267b655c0c9b2066598e2 SHA512 1879881be5eaeb2a6bac023fd06476a2ccbd25909f7c2f722b4af3680db44b4d3a959e1ac864e86580813a0bc68a2120d936f1c2efd67a6738ee8d83a5adb6f4
diff --git a/app-emacs/ivy/files/50ivy-gentoo.el b/app-emacs/ivy/files/50ivy-gentoo.el
new file mode 100644
index 000000000000..f9115d44c43a
--- /dev/null
+++ b/app-emacs/ivy/files/50ivy-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'ivy-mode "ivy"
+ "Toggle Ivy mode on or off." t)
diff --git a/app-emacs/ivy/files/ivy-0.13.4-ivy-test.el-skip.patch b/app-emacs/ivy/files/ivy-0.13.4-ivy-test.el-skip.patch
new file mode 100644
index 000000000000..e94070cca9c3
--- /dev/null
+++ b/app-emacs/ivy/files/ivy-0.13.4-ivy-test.el-skip.patch
@@ -0,0 +1,39 @@
+diff --git a/ivy-test.el b/ivy-test.el
+index 2062b81..8613337 100644
+--- a/ivy-test.el
++++ b/ivy-test.el
+@@ -2022,6 +1076,7 @@ Since `execute-kbd-macro' doesn't pick up a let-bound `default-directory'.")
+ (should (eq (ivy--sort-function 'c) fn1))))
+
+ (ert-deftest ivy-read-directory-name ()
++ (skip-unless nil)
+ (ivy-mode 1)
+ (unless (file-exists-p ivy-empty)
+ (make-directory ivy-empty))
+@@ -1136,6 +1137,7 @@ Since `execute-kbd-macro' doesn't pick up a let-bound `default-directory'.")
+ :dir "/tmp/"))))
+
+ (ert-deftest ivy-partial-files ()
++ (skip-unless nil)
+ (when (file-exists-p "/tmp/ivy-partial-test")
+ (delete-directory "/tmp/ivy-partial-test" t))
+ (mkdir "/tmp/ivy-partial-test/test1" t)
+@@ -1452,8 +1454,7 @@ a buffer visiting a file."
+
+ (ert-deftest ivy-swiper-wgrep ()
+ ;; `wgrep' requires Emacs 25 or later.
+- (skip-unless (and (>= emacs-major-version 25)
+- (require 'wgrep nil t)))
++ (skip-unless nil)
+ (dolist (search-cmd '(swiper swiper-isearch))
+ (should
+ (string=
+@@ -1585,7 +1586,7 @@ a buffer visiting a file."
+ '("one" "two"))))
+
+ (ert-deftest ivy-avy ()
+- (skip-unless (require 'avy nil t))
++ (skip-unless nil)
+ (require 'ivy-avy)
+ (let ((enable-recursive-minibuffers t)
+ (read-numbers '(ivy-read "test: " (mapcar #'number-to-string
diff --git a/app-emacs/ivy/ivy-0.13.4.ebuild b/app-emacs/ivy/ivy-0.13.4.ebuild
new file mode 100644
index 000000000000..9736ba05dfd7
--- /dev/null
+++ b/app-emacs/ivy/ivy-0.13.4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24.5
+
+inherit elisp
+
+DESCRIPTION="Generic completion mechanism for Emacs"
+HOMEPAGE="https://github.com/abo-abo/swiper/"
+SRC_URI="https://github.com/abo-abo/swiper/archive/${PV}.tar.gz
+ -> swiper-${PV}.tar.gz"
+S="${WORKDIR}"/swiper-${PV}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="sys-apps/texinfo"
+
+DOCS=( CONTRIBUTING.org README.md doc/{ivy-help.org,Changelog.org,ivy.org} )
+ELISP_REMOVE=".dir-locals.el"
+SITEFILE="50${PN}-gentoo.el"
+
+# Some tests are broken (but fixed on master as of 2022--04-10),
+# tests depending on Avy and Wgrep we force to skip.
+PATCHES=( "${FILESDIR}"/${P}-ivy-test.el-skip.patch )
+
+# Main Ivy sources. Swiper, Counsel and Ivy extensions have their own packages.
+IVY_SOURCES=( colir.el ivy{,-overlay,-faces}.el )
+
+src_prepare() {
+ elisp_src_prepare
+
+ # Wipe "elpa.el" to prevent initialization of the "package" library.
+ [[ ! -f elpa.el ]] && die "no \"elpa.el\" found"
+ echo "" > elpa.el || die "failed to wipe \"elpa.el\""
+}
+
+src_compile() {
+ elisp-compile ${IVY_SOURCES[@]}
+
+ emake -C doc ivy.info
+}
+
+src_test() {
+ emake emacs="${EMACS} ${EMACSFLAGS} ${BYTECOMPFLAGS}" test
+}
+
+src_install() {
+ elisp-install ${PN} ${IVY_SOURCES[@]} *.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ doinfo doc/ivy.info
+ einstalldocs
+}
diff --git a/app-emacs/ivy/metadata.xml b/app-emacs/ivy/metadata.xml
new file mode 100644
index 000000000000..37581bba4db7
--- /dev/null
+++ b/app-emacs/ivy/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <changelog>https://raw.githubusercontent.com/abo-abo/swiper/master/doc/Changelog.org</changelog>
+ <bugs-to>https://github.com/abo-abo/swiper/issues/</bugs-to>
+ <remote-id type="github">abo-abo/swiper</remote-id>
+ <doc lang="en">https://oremacs.com/swiper/</doc>
+ </upstream>
+</pkgmetadata>