summaryrefslogtreecommitdiff
path: root/app-emacs/indent-bars
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-21 01:50:31 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-21 01:50:31 +0000
commit2ac4d6eef70b0af1c7380b190dd14c8df8a4b9a5 (patch)
tree99640217df95ed54255127d0f54f43d19474348f /app-emacs/indent-bars
parent1fb8608d6f0b1acf0e34361c105533087a09c710 (diff)
gentoo auto-resync : 21:12:2023 - 01:50:31
Diffstat (limited to 'app-emacs/indent-bars')
-rw-r--r--app-emacs/indent-bars/Manifest2
-rw-r--r--app-emacs/indent-bars/indent-bars-0.2-r1.ebuild35
-rw-r--r--app-emacs/indent-bars/indent-bars-0.2.ebuild21
3 files changed, 36 insertions, 22 deletions
diff --git a/app-emacs/indent-bars/Manifest b/app-emacs/indent-bars/Manifest
index df5754f1f809..2a3f45b0b9ed 100644
--- a/app-emacs/indent-bars/Manifest
+++ b/app-emacs/indent-bars/Manifest
@@ -1,4 +1,4 @@
AUX 50indent-bars-gentoo.el 87 BLAKE2B 2f7c9c919be0a3165187fd99d11ec7dc848b09363dbf399150f3f4f3f828d262aa57a7be2b94915605e4646a4720863dc3e7499231dba949b7f61ab3677e07f6 SHA512 12c51ca505120d3cc5e5f71d35c10bdb80eeea53143dcd3a68a10f14ba3ff55c9a92ff3a421b7cd77f1c050ec37ecdf9c2a3d593eaf47edd361c3a4bf6f2e5a5
DIST indent-bars-0.2.tar.gz 33072 BLAKE2B b5f0b80f1b4291c19fec603a5610ae020ae1cd1531278c5eedf814c3aae4be76d5731b553220314ef67f785f1822c7861e088a5ec163505d9303e9ec2c5fda5c SHA512 e5eab37d5963855948efdd9739a44306c60fafef0cd589edcb6550ff52a4e6a0e403bde8124838d250c1bb78aff0bfbfa1e45275458af3e0ae00472628981b1b
-EBUILD indent-bars-0.2.ebuild 471 BLAKE2B e8daefeed01fa16530070cb73d485af34555970d4029b637277108f6c07894fad0815e4fa1f4e68a9430be91b3cae0e3ea87a8980425793692a7c63f58ea86ee SHA512 38ccd641a726d4436f0489f2f7aa95c802cc3cfa4770b5259e6ab1a1cf039e766e4dba13920e3ff95b46a6062855ed66cdd7c2ffaa560184832896756cace06e
+EBUILD indent-bars-0.2-r1.ebuild 630 BLAKE2B ced9c96debcb0647577eccaf6a45da212f76cba5a385c33cdeb47e0473c86124192250fa543d924e29554d43ae350db29dc2e3de74693109e4910c3cb0ab2341 SHA512 1b59b730db34b17b183170b89f207f9df516f3d8db9b684bbaa6ee58f2a0a9db8aaf5263ae2ea5dfed46ad8ea70f66d0c9d25ce0a472fdabbb3ef7c8f7412b0b
MISC metadata.xml 360 BLAKE2B f8f3e9c9350a90db3540b41a9bba9720402a0f0529baf0f31dc90a7a6e7a0d302ea6fe3da642b9f7536f31b44dc5da20a11b54f9ecf3b7e53243bbe310a9f93b SHA512 fa8d016d6434ed6ee2048fa36fc1f11b97315d63e0efd16580b9780db7854a2bb670493f28a2c84c5cb5899ba0349ee203ab4ca45436f3f32409aed4f63626b9
diff --git a/app-emacs/indent-bars/indent-bars-0.2-r1.ebuild b/app-emacs/indent-bars/indent-bars-0.2-r1.ebuild
new file mode 100644
index 000000000000..59407095b39d
--- /dev/null
+++ b/app-emacs/indent-bars/indent-bars-0.2-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Fast, configurable indentation guide-bars for Emacs"
+HOMEPAGE="https://github.com/jdtsmith/indent-bars/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/jdtsmith/${PN}.git"
+else
+ SRC_URI="https://github.com/jdtsmith/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ app-emacs/compat
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+SITEFILE="50${PN}-gentoo.el"
+DOCS=( README.md examples.md )
diff --git a/app-emacs/indent-bars/indent-bars-0.2.ebuild b/app-emacs/indent-bars/indent-bars-0.2.ebuild
deleted file mode 100644
index 2f46c530c735..000000000000
--- a/app-emacs/indent-bars/indent-bars-0.2.ebuild
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-NEED_EMACS=27.1
-
-inherit elisp
-
-IUSE=""
-
-DESCRIPTION="Fast, configurable indentation guide-bars for Emacs"
-HOMEPAGE="https://github.com/jdtsmith/indent-bars"
-SRC_URI="https://github.com/jdtsmith/indent-bars/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-
-SITEFILE="50${PN}-gentoo.el"
-
-DOCS="examples.md README.md"