summaryrefslogtreecommitdiff
path: root/app-emacs/igrep
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/igrep
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/igrep')
-rw-r--r--app-emacs/igrep/Manifest4
-rw-r--r--app-emacs/igrep/files/50igrep-gentoo.el33
-rw-r--r--app-emacs/igrep/igrep-2.113.ebuild16
-rw-r--r--app-emacs/igrep/metadata.xml9
4 files changed, 62 insertions, 0 deletions
diff --git a/app-emacs/igrep/Manifest b/app-emacs/igrep/Manifest
new file mode 100644
index 000000000000..070d7f3b9393
--- /dev/null
+++ b/app-emacs/igrep/Manifest
@@ -0,0 +1,4 @@
+AUX 50igrep-gentoo.el 1173 BLAKE2B 681d9a26295a34f20707b776792e77eb97015a661d06957390a6c6c5aebf4bd5babadc238b1923bfe22adb12aa75e20e4bced88669e09fd22c34b6f9a877e8c8 SHA512 404abf4e786145b276c6dddfefc1d335e4f941e7f8b77fae3668bd7028330f4ee3a19e8940c94e0a7a32cd90813787bcc3317011f1430f084698f2b97f465f7f
+DIST igrep-2.113.tar.bz2 10662 BLAKE2B fa854e1975548e037f33ce97988b9e4abf8182c13f6cce804a8b305e03282fc7990cccc2061aa3ed829279721f13610b89e2a4125b637d0584ccfd28ba628d0b SHA512 60ca8fa09cb2aa02ec7178afc7d8a2a6d98ebd98b951b29c9c7150588d5ca0dbf01e23e77c6524e2ce510466bd17aba607a172efde1fb4bc56e8478a752d5ff1
+EBUILD igrep-2.113.ebuild 362 BLAKE2B 6b3313b4a34c99ef34b2eb9c28a2ff7b6433a5e69df9b2d7f7031a5672fa0bc21b5017ffcf18e9de7bfd31f8306a7f0dc2d2105b9d8298159c0b30919890b39d SHA512 c0ca991c1a657beabb0f098e5ea3f70a446af9487947b2e9c16503bdba9673a03e46e04e614eb56439a3657a8a1078881fe472b3a59b2418f21d85784032482d
+MISC metadata.xml 282 BLAKE2B 432e60a3b04def9f566fde3852011e006c0d578c72c42115734d1af5c128440fcee68134c8f891baad437e64a8d61fbbac49e70a35ed4f6f85641e888d3a2547 SHA512 1838e22e1f5b849b816a05d1b25bd81333c8cf67ceb996177e05ba7a555b8e0e307e62cb53e6f1217f4216823e2fecf050e85437678503d60e10c6b2d5303072
diff --git a/app-emacs/igrep/files/50igrep-gentoo.el b/app-emacs/igrep/files/50igrep-gentoo.el
new file mode 100644
index 000000000000..5b44e5f88d5b
--- /dev/null
+++ b/app-emacs/igrep/files/50igrep-gentoo.el
@@ -0,0 +1,33 @@
+(add-to-list 'load-path "@SITELISP@")
+
+(autoload 'igrep "igrep"
+ "*Run `grep` PROGRAM to match EXPRESSION in FILES..." t)
+(autoload 'igrep-find "igrep"
+ "*Run `grep` via `find`..." t)
+(autoload 'igrep-visited-files "igrep"
+ "*Run `grep` ... on all visited files." t)
+(autoload 'dired-do-igrep "igrep"
+ "*Run `grep` on the marked (or next prefix ARG) files." t)
+(autoload 'dired-do-igrep-find "igrep"
+ "*Run `grep` via `find` on the marked (or next prefix ARG) directories." t)
+(autoload 'Buffer-menu-igrep "igrep"
+ "*Run `grep` on the files visited in buffers marked with '>'." t)
+(autoload 'igrep-insinuate "igrep"
+ "Define `grep' aliases for the corresponding `igrep' commands." t)
+(autoload 'grep "igrep"
+ "*Run `grep` PROGRAM to match EXPRESSION in FILES..." t)
+(autoload 'egrep "igrep"
+ "*Run `egrep`..." t)
+(autoload 'fgrep "igrep"
+ "*Run `fgrep`..." t)
+(autoload 'agrep "igrep"
+ "*Run `agrep`..." t)
+(autoload 'grep-find "igrep"
+ "*Run `grep` via `find`..." t)
+(autoload 'egrep-find "igrep"
+ "*Run `egrep` via `find`..." t)
+(autoload 'fgrep-find "igrep"
+ "*Run `fgrep` via `find`..." t)
+(autoload 'agrep-find "igrep"
+ "*Run `agrep` via `find`..." t)
+
diff --git a/app-emacs/igrep/igrep-2.113.ebuild b/app-emacs/igrep/igrep-2.113.ebuild
new file mode 100644
index 000000000000..132d1f208cd0
--- /dev/null
+++ b/app-emacs/igrep/igrep-2.113.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION='An improved interface to "grep" and "find"'
+HOMEPAGE="https://www.emacswiki.org/emacs/GrepMode"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/igrep/metadata.xml b/app-emacs/igrep/metadata.xml
new file mode 100644
index 000000000000..c918cdef9591
--- /dev/null
+++ b/app-emacs/igrep/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<stabilize-allarches/>
+</pkgmetadata>