summaryrefslogtreecommitdiff
path: root/app-emacs/helm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-07 11:18:59 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-07 11:18:59 +0100
commita2810985afabcc31d3eace5e61d8ea25b852ba17 (patch)
treed254e77a7aeadd875db2dc73532da78094238ffd /app-emacs/helm
parenteab5731cdf11d4ae8cdf111461d46fd96c5bdd37 (diff)
gentoo resync : 07.05.2019
Diffstat (limited to 'app-emacs/helm')
-rw-r--r--app-emacs/helm/Manifest4
-rw-r--r--app-emacs/helm/files/50helm-gentoo.el2
-rw-r--r--app-emacs/helm/helm-3.2.ebuild31
-rw-r--r--app-emacs/helm/metadata.xml20
4 files changed, 57 insertions, 0 deletions
diff --git a/app-emacs/helm/Manifest b/app-emacs/helm/Manifest
new file mode 100644
index 000000000000..ca2727bdc9d3
--- /dev/null
+++ b/app-emacs/helm/Manifest
@@ -0,0 +1,4 @@
+AUX 50helm-gentoo.el 79 BLAKE2B 7f188281cba0bf1f683977149ffa01f2bf6679cec1d73553e27c445ebcf97d2a6b227d09c77a01dadce49e755d97cc572af4fc5358ca35866a4c12dd8caa61b6 SHA512 30d2ce1f8073f15439cc6d68620e9ca776ed74fdedfca4944d7d749891f33aa2ad1dccffdfb85f1e1049460015daf2104f0b9cd0f5b872c5d5c5ee1eccd25b21
+DIST helm-3.2.tar.gz 2285972 BLAKE2B b5385b805825d89ed87ba438ce830ce1e694cf842db590576b0ceaa2c110f5d0853b24211fdeebb77394c5ecca8460bcd52fe58240233ea10993504030328e9e SHA512 006e53f1984d38fa6305830179bc4ef04fa3007effa07685ddf479c1fbca547b6f8e99dd370f5653d57b2f8e519a54948a4730a0fdf9af8574cbfa27c09662d5
+EBUILD helm-3.2.ebuild 626 BLAKE2B d5005a4fb7cce4946a13a240b6cbaa83779f25f4c2aaeaa32eb42524dd2041c55852aa81580b4ec314871a40ac9bacf2722ad9c3de0eb5d781dc33511b536d82 SHA512 330e7950020a7b44f91d7336f8493024133908eba44642666e4a3df5cdfdc00a24cbb48e86674058477a84e4aa52b4ccde3fedb32089ab5484cbc09fa7932315
+MISC metadata.xml 821 BLAKE2B 8e6df42f4d0e908d9fbb032483f727d274ced02989c4bfb076c51f11db2c70663de22dc3efd4ce2f547a4be32c5c7e84a0b2e50c1b5e7e07a10409fe7d723315 SHA512 2d8fc21274c2858c8c656f6d93477dc81b6f9a31f4f10e02bcf7925d54e78f20cc792508e63bf61beee7d2bf01d0daee5cccc1cb7542e1f4812344f9baf8524e
diff --git a/app-emacs/helm/files/50helm-gentoo.el b/app-emacs/helm/files/50helm-gentoo.el
new file mode 100644
index 000000000000..2eeea8036582
--- /dev/null
+++ b/app-emacs/helm/files/50helm-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "@SITELISP@/helm-autoloads" nil t)
diff --git a/app-emacs/helm/helm-3.2.ebuild b/app-emacs/helm/helm-3.2.ebuild
new file mode 100644
index 000000000000..f852381e5353
--- /dev/null
+++ b/app-emacs/helm/helm-3.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp
+
+DESCRIPTION="Emacs incremental completion and selection narrowing framework"
+HOMEPAGE="https://emacs-helm.github.io/helm/"
+SRC_URI="https://github.com/emacs-helm/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="app-emacs/async
+ app-emacs/popup"
+BDEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}
+
+src_install() {
+ elisp_src_install
+ exeinto "${SITEETC}/${PN}"
+ doexe emacs-helm.sh
+}
diff --git a/app-emacs/helm/metadata.xml b/app-emacs/helm/metadata.xml
new file mode 100644
index 000000000000..a17d69b2f155
--- /dev/null
+++ b/app-emacs/helm/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<longdescription>
+ Helm is an Emacs framework for incremental completions and narrowing
+ selections. It provides an easy-to-use API for developers wishing to
+ build their own Helm applications in Emacs, powerful search tools and
+ dozens of already built-in commands providing completion to almost
+ everything. It is a must-have for anyone using Emacs as a main work
+ environment. Helm has been widely adopted by many Emacs power-users.
+</longdescription>
+<stabilize-allarches/>
+<upstream>
+ <remote-id type="github">emacs-helm/helm</remote-id>
+</upstream>
+</pkgmetadata>