summaryrefslogtreecommitdiff
path: root/app-emacs/helm/helm-3.8.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-01 19:11:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-01 19:11:24 +0100
commit0a772e9952c6683769ac22be1b2304fcd86f02cb (patch)
tree913ccfa8988bae59ab9651b5b9a20e1265157f7d /app-emacs/helm/helm-3.8.8.ebuild
parent8598ab9ad325d12d0f2901ecc0973e430dacd2b3 (diff)
gentoo auto-resync : 01:10:2022 - 19:11:24
Diffstat (limited to 'app-emacs/helm/helm-3.8.8.ebuild')
-rw-r--r--app-emacs/helm/helm-3.8.8.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-emacs/helm/helm-3.8.8.ebuild b/app-emacs/helm/helm-3.8.8.ebuild
new file mode 100644
index 000000000000..a99c12c1de3c
--- /dev/null
+++ b/app-emacs/helm/helm-3.8.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Emacs incremental completion and selection narrowing framework"
+HOMEPAGE="https://emacs-helm.github.io/helm/
+ https://github.com/emacs-helm/helm/"
+SRC_URI="https://github.com/emacs-helm/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-emacs/async
+ app-emacs/popup
+"
+BDEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-no-autoload-check.patch )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}
+
+src_install() {
+ elisp_src_install
+
+ exeinto /usr/bin/
+ doexe emacs-helm.sh
+}