summaryrefslogtreecommitdiff
path: root/app-emacs/google-c-style
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/google-c-style
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/google-c-style')
-rw-r--r--app-emacs/google-c-style/Manifest4
-rw-r--r--app-emacs/google-c-style/files/50google-c-style-gentoo.el5
-rw-r--r--app-emacs/google-c-style/google-c-style-20091009-r1.ebuild26
-rw-r--r--app-emacs/google-c-style/metadata.xml16
4 files changed, 51 insertions, 0 deletions
diff --git a/app-emacs/google-c-style/Manifest b/app-emacs/google-c-style/Manifest
new file mode 100644
index 000000000000..77b9b1507d88
--- /dev/null
+++ b/app-emacs/google-c-style/Manifest
@@ -0,0 +1,4 @@
+AUX 50google-c-style-gentoo.el 258 BLAKE2B 7ec733ac75a1d1570d11f3b978e0f55c3641b6e1ded4792afe54c3757453424fa0f76724f13bd060d5a63be7f37442649669043a8b7ed326c6b46cd58db1572b SHA512 f39b91a6af6e16ac70a5baee459790efb00aa10c3a83c16429fa5d97201bec2bfb3f6645ab1327f7325eb3428a3c938914b4a63c6009109dda99a4f0fe7d89c2
+DIST google-c-style-20091009.tar.bz2 2178 BLAKE2B 72d7b430f9148589e8b4b1a57c9b4b96203c7ffddae3bbbc7aa9978e85c2c51510571f8617ac5d2bcaabe5688ed7799d5de597e96a2479d844a49e6661f93a05 SHA512 5d61d6e021643ffc1468c14cdbbde0b52dc9346330983c19bdb7f4d6fb8960c662ca6198658963ff6d2b4d7d2dc96853a8c58de48da77364a860f2f777855b5a
+EBUILD google-c-style-20091009-r1.ebuild 602 BLAKE2B 5e9cbb6e0f5df7a7aaf1695b28a20ce0ecfac59fbe8a2357f2534a848ab720500c2ac3de410adcf9eda084a914b5da3fdf86fbfdddd02162c020cab232ff7615 SHA512 454136b3a79e9b4cd21a51b8771daa4efeab80b13c1fc09c8d372b864c96e10b26bcdcbe21e48b934689f69b263ba8cb8d758a8b32ac8f41a25ddc3c5c5621a3
+MISC metadata.xml 483 BLAKE2B 5321c357a3c496a72254753a00ca9e11ad6fdc420b2ab01990348c3d232d744d433ed01e5fc3de3aa6017dd805b057d3b2004d500db6fe1e38d69053c0d73179 SHA512 0f0c374e0ced07f64bf529899a190e7c4d1dadac58ef44355021fe00eeda190e2f270951242e8b1cc0b405328f2c251272da4713557600391e0ee82a35f689cb
diff --git a/app-emacs/google-c-style/files/50google-c-style-gentoo.el b/app-emacs/google-c-style/files/50google-c-style-gentoo.el
new file mode 100644
index 000000000000..3e9768b65db7
--- /dev/null
+++ b/app-emacs/google-c-style/files/50google-c-style-gentoo.el
@@ -0,0 +1,5 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'google-set-c-style "google-c-style"
+ "Set the current buffer's c-style to Google C/C++ Programming Style." t)
+(autoload 'google-make-newline-indent "google-c-style"
+ "Sets up preferred newline behavior." t)
diff --git a/app-emacs/google-c-style/google-c-style-20091009-r1.ebuild b/app-emacs/google-c-style/google-c-style-20091009-r1.ebuild
new file mode 100644
index 000000000000..c7353765122e
--- /dev/null
+++ b/app-emacs/google-c-style/google-c-style-20091009-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit elisp
+
+DESCRIPTION="Provides the google C/C++ coding style"
+HOMEPAGE="https://github.com/google/styleguide"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="|| ( Artistic GPL-1 GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+S="${WORKDIR}"
+SITEFILE="50${PN}-gentoo.el"
+
+pkg_postinst() {
+ elisp-site-regen
+
+ elog "Example usage (~/.emacs):"
+ elog " (add-hook 'c-mode-common-hook 'google-set-c-style)"
+ elog " (add-hook 'c-mode-common-hook 'google-make-newline-indent)"
+}
diff --git a/app-emacs/google-c-style/metadata.xml b/app-emacs/google-c-style/metadata.xml
new file mode 100644
index 000000000000..9508b69a2cc5
--- /dev/null
+++ b/app-emacs/google-c-style/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<maintainer type="project">
+ <email>chromium@gentoo.org</email>
+ <name>Chromium in Gentoo Project</name>
+</maintainer>
+<stabilize-allarches/>
+<upstream>
+ <remote-id type="github">google/styleguide</remote-id>
+</upstream>
+</pkgmetadata>