summaryrefslogtreecommitdiff
path: root/app-emacs/gnuplot-mode
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/gnuplot-mode
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/gnuplot-mode')
-rw-r--r--app-emacs/gnuplot-mode/Manifest4
-rw-r--r--app-emacs/gnuplot-mode/files/50gnuplot-mode-gentoo.el6
-rw-r--r--app-emacs/gnuplot-mode/gnuplot-mode-0.7.0.ebuild43
-rw-r--r--app-emacs/gnuplot-mode/metadata.xml12
4 files changed, 65 insertions, 0 deletions
diff --git a/app-emacs/gnuplot-mode/Manifest b/app-emacs/gnuplot-mode/Manifest
new file mode 100644
index 000000000000..ebb3287ec64c
--- /dev/null
+++ b/app-emacs/gnuplot-mode/Manifest
@@ -0,0 +1,4 @@
+AUX 50gnuplot-mode-gentoo.el 347 BLAKE2B 6a72d3ac75c8ef7629b8c018f9652b924137f56feb7c1578d7d5b572846bb22b248ae569412e7d9f6969ce6daca4aa21debccac7b7d5b63c4c66b04959d72836 SHA512 eb342c60bee1a9e45a50373093207545b8b37888432b082afb7c4f0911eed08481379094ee5a73888a03a12898c3c41016c2d9161f92a1a7cf7be7f2010c1c83
+DIST gnuplot-mode-0.7.0.tar.gz 373475 BLAKE2B 6aa547b90922fa445de10825ae8f0c05249a335a1cc531118200bc49c4b62f610e07a7c5bd694a3c6bf6605b937a520a8008d67263d2e83cabf009fb855e7a97 SHA512 fdf04a3a32755892d422de8a535682ff44d1b635ecdc814738564376f5c7027a82c23807439835f2b7bf959f4f8b7a7d38d07a643f84ab2056ba187f3558e596
+EBUILD gnuplot-mode-0.7.0.ebuild 1002 BLAKE2B b6d2dc95275398ff12d94400fa30ad5b1a41757485bbad24c1b18b41ae94051af18b2e3d99c3905cb9d67feb115b3fa04a2bef57e37d1e8e35637d120f91c0ac SHA512 37f0ceae8aa23dac56e0064baf6498c1e0aee61ace0469f80d71051dc8a110a2e6c99796f71456ab18f2aeed030f783cc0e29434a4478e6fadf959768d5cd9a4
+MISC metadata.xml 368 BLAKE2B b1313c69a215b2231db94ed717741bcc3a771b183736a92c8fc81494eeb50fd634572c1dfa550acee7b182f6e587d0fa401738b8bf40403ae92ae37468f24fd5 SHA512 631de1c715d46e3ec59a3e973a508ac4686749f2d2929ec50a17f53c4f7f0615b08a539ea84ca88eb541bd2217817fd47c4941a97a25ac6a2b132ee776041191
diff --git a/app-emacs/gnuplot-mode/files/50gnuplot-mode-gentoo.el b/app-emacs/gnuplot-mode/files/50gnuplot-mode-gentoo.el
new file mode 100644
index 000000000000..e79a7f0d2585
--- /dev/null
+++ b/app-emacs/gnuplot-mode/files/50gnuplot-mode-gentoo.el
@@ -0,0 +1,6 @@
+(add-to-list 'load-path "@SITELISP@")
+;; extracted from dotemacs file distributed with the source tarball
+(autoload 'gnuplot-mode "gnuplot" "gnuplot major mode" t)
+(autoload 'gnuplot-make-buffer "gnuplot" "open a buffer in gnuplot mode" t)
+(add-to-list 'auto-mode-alist '("\\.gp\\'" . gnuplot-mode))
+;;(global-set-key [(f9)] 'gnuplot-make-buffer)
diff --git a/app-emacs/gnuplot-mode/gnuplot-mode-0.7.0.ebuild b/app-emacs/gnuplot-mode/gnuplot-mode-0.7.0.ebuild
new file mode 100644
index 000000000000..1a90fa983b9a
--- /dev/null
+++ b/app-emacs/gnuplot-mode/gnuplot-mode-0.7.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit readme.gentoo elisp
+
+DESCRIPTION="Gnuplot mode for Emacs"
+HOMEPAGE="http://xafs.org/BruceRavel/GnuplotMode"
+SRC_URI="https://github.com/bruceravel/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~hppa ia64 ppc ppc64 ~s390 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc"
+
+DEPEND="doc? ( virtual/latex-base )"
+RDEPEND="sci-visualization/gnuplot[-emacs(-)]"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_configure() {
+ econf \
+ EMACS="${EMACS}" \
+ --with-lispdir="${EPREFIX}${SITELISP}/${PN}"
+}
+
+src_compile() {
+ emake
+ use doc && emake pdf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ dodoc README.org
+ use doc && dodoc gpelcard.pdf
+
+ DOC_CONTENTS="Please see ${SITELISP}/${PN}/gnuplot.el for the
+ complete documentation."
+ readme.gentoo_create_doc
+}
diff --git a/app-emacs/gnuplot-mode/metadata.xml b/app-emacs/gnuplot-mode/metadata.xml
new file mode 100644
index 000000000000..c3270eb3ebef
--- /dev/null
+++ b/app-emacs/gnuplot-mode/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<stabilize-allarches/>
+<upstream>
+ <remote-id type="github">bruceravel/gnuplot-mode</remote-id>
+</upstream>
+</pkgmetadata>