summaryrefslogtreecommitdiff
path: root/app-emacs/git-timemachine
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-17 16:03:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-17 16:03:04 +0100
commit29ef84a753ab20dbbb228238713a3c7443c6520e (patch)
treeebe889f9f8817c5c6601a6dbfd0b12d537b4e91d /app-emacs/git-timemachine
parentcf89ca044e37f79e2329552cda857215f9824e11 (diff)
gentoo auto-resync : 17:10:2023 - 16:03:04
Diffstat (limited to 'app-emacs/git-timemachine')
-rw-r--r--app-emacs/git-timemachine/Manifest5
-rw-r--r--app-emacs/git-timemachine/files/50git-timemachine-gentoo.el7
-rw-r--r--app-emacs/git-timemachine/git-timemachine-4.13.ebuild27
-rw-r--r--app-emacs/git-timemachine/git-timemachine-9999.ebuild27
-rw-r--r--app-emacs/git-timemachine/metadata.xml13
5 files changed, 79 insertions, 0 deletions
diff --git a/app-emacs/git-timemachine/Manifest b/app-emacs/git-timemachine/Manifest
new file mode 100644
index 000000000000..e02d5edd4f8e
--- /dev/null
+++ b/app-emacs/git-timemachine/Manifest
@@ -0,0 +1,5 @@
+AUX 50git-timemachine-gentoo.el 372 BLAKE2B 4253d3da184d4a837d9837bc541f1456f03fd399ac802a7c35d863ddad96cbb290af1767118d96c21cfad58ff3caf3463e8030cced4fa10caffe57df550e466a SHA512 17fb49a223379b56884339e3803fc9c812e092a70015a01c1b5bfca5f0eb1ed339f13580f40f24c420351a391ef5567e78ff8656eeca8cb5309f920c8756b65a
+DIST git-timemachine-4.13.tar.gz 429649 BLAKE2B 8a0fc6185f0f2408f9953a59df5818e165ebd8703d429cd1abfcf671506b263228033b18ff14d1dc6a65f1c9b28ddc8461836a38eedf55c7a8415ca85374e8a1 SHA512 f47a169c16c07d4f80ba9539332d302b1539b0315eadf5ffbf7d55bb1c77124bef183b22641f321ca0c48ae61ed450d0f3133a7875ffce22272608d3fd3d74cb
+EBUILD git-timemachine-4.13.ebuild 581 BLAKE2B 9e436f12617a1096d6add178801b86ee663a401c4002387d0560ceffdb01ac44be46d0f34d234ad65e025f026f03eae1b683be5392fe8a7300538c2a23e4ddb2 SHA512 fff9db98d785c1103a4d8f239fa128ce2b7e5cf2199678b397eda2eb0a1fb184a59de8552d5a231c414833114f8c69fcb6269dbab866a253736ae60fb6e8a6b2
+EBUILD git-timemachine-9999.ebuild 581 BLAKE2B 9e436f12617a1096d6add178801b86ee663a401c4002387d0560ceffdb01ac44be46d0f34d234ad65e025f026f03eae1b683be5392fe8a7300538c2a23e4ddb2 SHA512 fff9db98d785c1103a4d8f239fa128ce2b7e5cf2199678b397eda2eb0a1fb184a59de8552d5a231c414833114f8c69fcb6269dbab866a253736ae60fb6e8a6b2
+MISC metadata.xml 433 BLAKE2B da10097024a1a725be8b2198d9b261125309ba4036d1c829874a54de04c95fadd7df8740375d74dee8af7919fd4da176fcc269c399f04e57a5456b4202e32faa SHA512 e4548ebc015a053a4c941455f2b97fbb438e4ccf312591582b97ea7ea13622879f65585d61bb891989772f791612d447939c4a9ffe019f0828e179057245b278
diff --git a/app-emacs/git-timemachine/files/50git-timemachine-gentoo.el b/app-emacs/git-timemachine/files/50git-timemachine-gentoo.el
new file mode 100644
index 000000000000..0afabf3af5c1
--- /dev/null
+++ b/app-emacs/git-timemachine/files/50git-timemachine-gentoo.el
@@ -0,0 +1,7 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'git-timemachine-toggle "git-timemachine.el"
+ "Toggle git timemachine mode." t)
+(autoload 'git-timemachine "git-timemachine.el"
+ "Enable git timemachine for file of current buffer." t)
+(autoload 'git-timemachine-switch-branch "git-timemachine.el"
+ "Enable git timemachine for current buffer, switching to GIT-BRANCH." t)
diff --git a/app-emacs/git-timemachine/git-timemachine-4.13.ebuild b/app-emacs/git-timemachine/git-timemachine-4.13.ebuild
new file mode 100644
index 000000000000..34600dc73e46
--- /dev/null
+++ b/app-emacs/git-timemachine/git-timemachine-4.13.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Step through historic versions of git controlled files in GNU Emacs"
+HOMEPAGE="https://codeberg.org/pidu/git-timemachine/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://codeberg.org/pidu/${PN}.git"
+else
+ SRC_URI="https://codeberg.org/pidu/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/git-timemachine/git-timemachine-9999.ebuild b/app-emacs/git-timemachine/git-timemachine-9999.ebuild
new file mode 100644
index 000000000000..34600dc73e46
--- /dev/null
+++ b/app-emacs/git-timemachine/git-timemachine-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Step through historic versions of git controlled files in GNU Emacs"
+HOMEPAGE="https://codeberg.org/pidu/git-timemachine/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://codeberg.org/pidu/${PN}.git"
+else
+ SRC_URI="https://codeberg.org/pidu/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/git-timemachine/metadata.xml b/app-emacs/git-timemachine/metadata.xml
new file mode 100644
index 000000000000..5e8038e3d367
--- /dev/null
+++ b/app-emacs/git-timemachine/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://codeberg.org/pidu/git-timemachine/issues/</bugs-to>
+ <remote-id type="codeberg">pidu/git-timemachine</remote-id>
+ </upstream>
+</pkgmetadata>