summaryrefslogtreecommitdiff
path: root/app-emacs/git-modes
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /app-emacs/git-modes
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'app-emacs/git-modes')
-rw-r--r--app-emacs/git-modes/Manifest4
-rw-r--r--app-emacs/git-modes/files/50git-modes-gentoo.el2
-rw-r--r--app-emacs/git-modes/git-modes-1.4.0.ebuild24
-rw-r--r--app-emacs/git-modes/metadata.xml13
4 files changed, 43 insertions, 0 deletions
diff --git a/app-emacs/git-modes/Manifest b/app-emacs/git-modes/Manifest
new file mode 100644
index 000000000000..3c575ea61813
--- /dev/null
+++ b/app-emacs/git-modes/Manifest
@@ -0,0 +1,4 @@
+AUX 50git-modes-gentoo.el 73 BLAKE2B f756bc038b5b0c6dec420176142336902f9a350bb63ac5a10ac51895e28d1f0a5446ef1f959ce10638b97ebd1f6405ece3b2e101238ec835f62d91fe0b189cea SHA512 56c251fa8100e882225d0220f6ce656bf8012fe47ab9dd3a98c240a01e257689ab6867a8fcb6f9d11b911fb958ab3950589cd238434f27e10ca86aaecae74d69
+DIST git-modes-1.4.0.tar.gz 18218 BLAKE2B 7e08ce42d683d4a8224df6255304e3beb7db2a5d97f6c758bf229e020dd3c0e5ed5f75acf9a7fdf8a5d313b904cc59d0de1419244067a5975d5174f45aca0071 SHA512 2511575a4d5d578fca5bde50e103d0fe777eed9bc3c520d5172aff7c65baa47a0a0f633e0950b7efb3eaa891debd3e34df3612d713412d547bb58733c9f00cbc
+EBUILD git-modes-1.4.0.ebuild 501 BLAKE2B 14c50372dd97d8df166e20ad6f8a4bff45f7405b861d6d4cbbc5e5e64fea45d4b46e3a4f63c318a682e79d5f68f41fb0e9adba368de5a779d0b412be79dbc1f4 SHA512 424e4a22002cce2d5bda8dee2c11b1b6dd93cb5672855ea2c19f3ecc3c72fbd1aff060f21eab2a1d45ca2f44bae6c8d6eaad43998b3c59e518cb5a0b32488312
+MISC metadata.xml 419 BLAKE2B 6e3a5051a08003fb5450a0a4a9eb68df7c91878d1f61c7f5dbb58569dc1235ee4101f69a8d6bb35c846c3a78bfbf5f2e0fdfadd69a359e159818b3b145b04a5e SHA512 31f2551caca2dcb46aefdf851e01fc518260b6b8900d76c86106c7789f74de306357d4f0fa2e9852d9a8bad91253284cf5a68e6d66004a1e0abf25ba6a82ad58
diff --git a/app-emacs/git-modes/files/50git-modes-gentoo.el b/app-emacs/git-modes/files/50git-modes-gentoo.el
new file mode 100644
index 000000000000..db930d7eed5c
--- /dev/null
+++ b/app-emacs/git-modes/files/50git-modes-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "git-modes-autoloads" nil t)
diff --git a/app-emacs/git-modes/git-modes-1.4.0.ebuild b/app-emacs/git-modes/git-modes-1.4.0.ebuild
new file mode 100644
index 000000000000..42d918ba7cc7
--- /dev/null
+++ b/app-emacs/git-modes/git-modes-1.4.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24.3
+
+inherit elisp
+
+DESCRIPTION="Emacs major modes for editing Git configuration files"
+HOMEPAGE="https://github.com/magit/git-modes/"
+SRC_URI="https://github.com/magit/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}
diff --git a/app-emacs/git-modes/metadata.xml b/app-emacs/git-modes/metadata.xml
new file mode 100644
index 000000000000..8d7670cb22a9
--- /dev/null
+++ b/app-emacs/git-modes/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/magit/git-modes/issues/</bugs-to>
+ <remote-id type="github">magit/git-modes</remote-id>
+ </upstream>
+</pkgmetadata>