summaryrefslogtreecommitdiff
path: root/app-emacs/ghub
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-31 10:55:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-03-31 10:55:17 +0100
commit75fc75ae1f0481ffdb78450e801a9b443ba641bd (patch)
treecef96ea0860ae39a202bbf1e226100335209627d /app-emacs/ghub
parent1173ad5704ce725916e0c332416aff326d850d06 (diff)
gentoo resync : 31.03.2018
Diffstat (limited to 'app-emacs/ghub')
-rw-r--r--app-emacs/ghub/Manifest4
-rw-r--r--app-emacs/ghub/files/50ghub-gentoo.el3
-rw-r--r--app-emacs/ghub/ghub-2.0.0.ebuild21
-rw-r--r--app-emacs/ghub/metadata.xml29
4 files changed, 57 insertions, 0 deletions
diff --git a/app-emacs/ghub/Manifest b/app-emacs/ghub/Manifest
new file mode 100644
index 000000000000..d836e4f0d9b3
--- /dev/null
+++ b/app-emacs/ghub/Manifest
@@ -0,0 +1,4 @@
+AUX 50ghub-gentoo.el 124 BLAKE2B 84170098bd01bb9f165eaf06f7cb21c56d2caaf964d2658520311757845d053072a7704fcb90cce2a2dfbd2385f357d2e7569061ebe0ca41b575efd752d29fd8 SHA512 596c7e75560f3734b57525bdfb42f3985fb49ab4d86637231361f6673d2431c0a6e73f91f58f003f9027f1143b9be3f4330ef2e1ff6c627ca6057256f4afbfca
+DIST ghub-2.0.0.tar.gz 48150 BLAKE2B b9142f33f92dc08a1d5f3f3467361866b41d0d2c943465e803987a41a7bbba1bc4c7e30c058e6e3899110a57d3e1d49545df01efbceb67711186e6411ebc9a58 SHA512 39e1ac1760e1a8532ee5d6fd29386ccc24d7f0278f6c900d565a709f86ac6acf01ae49a3462b54054d5b0040102db82ea048157a12663c46b0c45fe11f2e86d6
+EBUILD ghub-2.0.0.ebuild 490 BLAKE2B a96add2961b13f3dfe3da9ae81223a92cc81e822b314379d5217e6591f4dcf323d38208d8b278f6094273ab901c72ed96f5b920ff445a43599b030e303450ac0 SHA512 8f4c91c9485dcb48253231006114a7f8112e250e296b89d752caee2d85fe9587941f27a35178d658aec29b56eb71d891154d35f147c91b154288b5c7fcfd21fb
+MISC metadata.xml 1273 BLAKE2B d1248c9061827cfb587b5d4a54ba5aeaba5be8302bc1a2f11252b9fe0946d96ce292f01983a2e82b23008649ee44af169d570a3226887fc22852edb022d1608a SHA512 e8161b23fd2310b303508c80c6af7b428c77ce2eb594bc3bd52b71eab874350d8f8920fa7e348fe48b5f6302fe6242665724dfbe83e308ee5e9d0e8813f2dbf1
diff --git a/app-emacs/ghub/files/50ghub-gentoo.el b/app-emacs/ghub/files/50ghub-gentoo.el
new file mode 100644
index 000000000000..37d6696a3da1
--- /dev/null
+++ b/app-emacs/ghub/files/50ghub-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'ghub-create-token "ghub" nil t)
+(autoload 'ghub-token-scopes "ghub" nil t)
diff --git a/app-emacs/ghub/ghub-2.0.0.ebuild b/app-emacs/ghub/ghub-2.0.0.ebuild
new file mode 100644
index 000000000000..4b577810fe60
--- /dev/null
+++ b/app-emacs/ghub/ghub-2.0.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="minuscule client library for the Github API"
+HOMEPAGE="https://magit.vc/manual/ghub"
+SRC_URI="https://github.com/magit/ghub/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+SITEFILE="50${PN}-gentoo.el"
+ELISP_TEXINFO="*.texi"
+DOCS="README.md"
+
+DEPEND="sys-apps/texinfo"
diff --git a/app-emacs/ghub/metadata.xml b/app-emacs/ghub/metadata.xml
new file mode 100644
index 000000000000..864702cccea5
--- /dev/null
+++ b/app-emacs/ghub/metadata.xml
@@ -0,0 +1,29 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<longdescription>
+Ghub is a library that provides basic support for using the Github API
+from Emacs packages. It abstracts access to API resources using only
+a handful of functions that are not resource-specific.
+
+Ghub handles the creation, storage and use of access tokens using a
+setup wizard to make it easier for users to get started and to reduce
+the support burden imposed on package maintainers. It also comes with
+a comprehensive manual to address the cases when things don't just
+work as expected or in case you don't want to use the wizard.
+
+Ghub is intentionally limited to only provide these two essential
+features — basic request functions and guided setup — to avoid being
+too opinionated, which would hinder wide adoption. It is assumed that
+wide adoption would make life easier for users and maintainers alike,
+because then all packages that talk to the Github API could be
+configured the same way.
+</longdescription>
+<upstream>
+ <remote-id type="github">magit/ghub</remote-id>
+</upstream>
+</pkgmetadata>