summaryrefslogtreecommitdiff
path: root/app-emacs/flycheck
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
commitc719fdcee603a5a706a45d10cb598762d56a727d (patch)
tree620cbf137661399a3fb1eff92914204f9a970713 /app-emacs/flycheck
parentcc4618c9ba3d974948ebf340b542d8cb01db2f55 (diff)
gentoo resync : 25.09.2021
Diffstat (limited to 'app-emacs/flycheck')
-rw-r--r--app-emacs/flycheck/Manifest4
-rw-r--r--app-emacs/flycheck/files/50flycheck-gentoo.el4
-rw-r--r--app-emacs/flycheck/flycheck-32_p20210825.ebuild26
-rw-r--r--app-emacs/flycheck/metadata.xml20
4 files changed, 54 insertions, 0 deletions
diff --git a/app-emacs/flycheck/Manifest b/app-emacs/flycheck/Manifest
new file mode 100644
index 000000000000..412fe039d8a1
--- /dev/null
+++ b/app-emacs/flycheck/Manifest
@@ -0,0 +1,4 @@
+AUX 50flycheck-gentoo.el 168 BLAKE2B e1a9855c04e42743261f2d1483772fac65c8c6a30702aefbff97cb6e90d631e4e6e862f93b3bdba175d83c4e9dd95db5b13e07fb8a428cdda4e046d58cbae71f SHA512 a1a6bfe0a380d948e3e2e6b7f3d7034aaf25f110966ab991a04f818d493892d9cd50078cb709205189e7a7f59ea052ab16b5e4d4c43f66c1f0b3dfd2ada00988
+DIST flycheck-32_p20210825.tar.gz 1042020 BLAKE2B 1663340de24980b3a1e58929e327841b743495dbd5d5c8306f007d0dfa989707015ceadaf6e5cac673eddb45adf9ec05dc35d8cb35af322c9cde6644194dd75d SHA512 472e25956d804e7f7ba8ebda2e3a7527eaaf3aee47fa5bd43a46ae651f94d857657cf4594f5a1ed0c169ec0ac610139956d182818ffeedf2c4132a5583ca870d
+EBUILD flycheck-32_p20210825.ebuild 704 BLAKE2B 839051da4eb453f2796f02e08e7c713679d2cc77807bafed0d95fdd99988f7441206024bc1cfd12efc0f7d44cb687852fe654b75d31bda53d1b182fd5457ff8c SHA512 cf5ad3096aeb05ac0e6c13bde5929db94c2a24576033a3c1dbd2bac7864fef83c16ab59e6966f7da61e249e17b6471177cb8fc9bfcd958a72d73288dd11269fb
+MISC metadata.xml 781 BLAKE2B 34786e0414f89a30ee69426228f2b4cb79eddc511d0574f8d67502a28a52a662bd1af54166266306d5af6c22d82c155ae8d6bdba1994967384f296a9d290ea61 SHA512 a4aba903b34c0d385a4f595b9201a5ccfd4d65a0173982ce840d7229d915c522de1c28987f8c8557b7bde26531f73605d5c82102fd7086280c411d3bf6cea8ba
diff --git a/app-emacs/flycheck/files/50flycheck-gentoo.el b/app-emacs/flycheck/files/50flycheck-gentoo.el
new file mode 100644
index 000000000000..5f6c703df909
--- /dev/null
+++ b/app-emacs/flycheck/files/50flycheck-gentoo.el
@@ -0,0 +1,4 @@
+;;; Flycheck site-lisp configuration
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'flycheck-mode "flycheck" nil t)
+(autoload 'global-flycheck-mode "flycheck" nil t)
diff --git a/app-emacs/flycheck/flycheck-32_p20210825.ebuild b/app-emacs/flycheck/flycheck-32_p20210825.ebuild
new file mode 100644
index 000000000000..2f6ead369883
--- /dev/null
+++ b/app-emacs/flycheck/flycheck-32_p20210825.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+NEED_EMACS="24.3"
+
+inherit elisp
+
+DESCRIPTION="Modern on-the-fly syntax checking extension for GNU Emacs"
+HOMEPAGE="https://www.flycheck.org/"
+COMMIT="784f184cdd9f9cb4e3dbb997c09d93e954142842"
+SRC_URI="https://github.com/flycheck/flycheck/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test" # test requires cask and ert-runner which are not packaged yet
+
+RDEPEND=">=app-emacs/dash-2.12.1
+>=app-emacs/pkg-info-0.4"
+
+SITEFILE="50${PN}-gentoo.el"
+DOCS=( README.md )
+ELISP_REMOVE="flycheck-buttercup.el flycheck-ert.el"
diff --git a/app-emacs/flycheck/metadata.xml b/app-emacs/flycheck/metadata.xml
new file mode 100644
index 000000000000..e96ebcfc18fc
--- /dev/null
+++ b/app-emacs/flycheck/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>jturner.usa+gentoo@gmail.com</email>
+ <name>John Turner</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">flycheck/flycheck</remote-id>
+ <doc>https://github.com/flycheck/flycheck/blob/master/README.md</doc>
+ </upstream>
+ <longdescription>
+ Flycheck is a modern on-the-fly syntax checking extension for GNU Emacs,
+ intended as replacement for the older Flymake extension which is part of GNU Emacs.
+ </longdescription>
+</pkgmetadata>