summaryrefslogtreecommitdiff
path: root/app-emacs/expand-region
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-emacs/expand-region
reinit the tree, so we can have metadata
Diffstat (limited to 'app-emacs/expand-region')
-rw-r--r--app-emacs/expand-region/Manifest5
-rw-r--r--app-emacs/expand-region/expand-region-0.11.0.ebuild23
-rw-r--r--app-emacs/expand-region/files/50expand-region-gentoo.el2
-rw-r--r--app-emacs/expand-region/metadata.xml19
4 files changed, 49 insertions, 0 deletions
diff --git a/app-emacs/expand-region/Manifest b/app-emacs/expand-region/Manifest
new file mode 100644
index 000000000000..a88357468a12
--- /dev/null
+++ b/app-emacs/expand-region/Manifest
@@ -0,0 +1,5 @@
+AUX 50expand-region-gentoo.el 77 SHA256 2a34f6512fd5a8ccac15b415cdbc54641eb4f72f4731236d183b2f1d92e5d1c1 SHA512 a2ac0c38a2693979ead82dbde2f88161315fa62e1632a3be242ae158caa0e4ce91585d11eb61265955910294e9e483834d282917ed6ebdd7da8d82fd496f72ee WHIRLPOOL 25478a4338ea8e614a64b310d50e8bb62ba32dbe0c0bd9237df3fe4758e9cd25c8fd16dab3ef4ff13f58c51238b27c4f861c4cc60d679da9d07eaf58fb4b44c4
+DIST expand-region-0.11.0.tar.gz 31562 SHA256 e085621267b250486856422d13e7ddc3b11601e2328fc239e709ea10880bbe21 SHA512 3469ab0420d85fbaaa1ae9f3d0101c28b6e1786d761ecd186d744537795226917314b8b748d3499b02ea269a46a62350c37fecb34dd4183a73eafc67ce1344a8 WHIRLPOOL 762ceeefaae4728776d493daac6453d00c6ff232dab4130fcb5965a71b4da6bcc046ed3894912b38716a7047f83286335e4b01616dfc8c8e30edd1360869c79d
+EBUILD expand-region-0.11.0.ebuild 547 SHA256 23e887458c00cea5e67fb1357c5c38bb5ed3ea6c123f87d2669af8d6580b5c09 SHA512 860286841c831c01a36b9b311e480b5111bbacd6fcf012831a5e91b855fcd367612e7be597ae87145d1eb63adb83a6da37d349f980319bf11909fec7e805fad9 WHIRLPOOL a0421361e99a169313babbb6e601eed6f5a8038d2e550b34760c8093bfabe483d6a691114342917f4a972a631f8eb4630bc64881f26e512d1124bf7ecdbed0f0
+MISC ChangeLog 473 SHA256 14e35a97ff45ead29abdfcc63bc861e18cf3554de3cf9aec089b6cca42f0e0c8 SHA512 41de281f84e89a1fda5e327d499c11b7fdcd9a55501f3ef54995437c30861e1eed77a4bef84fcc5aa3e1e7c1499caeb70dd4b1fee8789237567797c3bd25d363 WHIRLPOOL bf2f5030058de3017ab464e8700f8aead333279d7a766fbfff9986d934236e47fb12e21b560e948bc4d5e68c31fe218f35ee2f8dfc4c939029157abe12071014
+MISC metadata.xml 595 SHA256 1f1e15e5edcea8a2c04ebc15e2769f03325ea13ba1d7bb353a7d71bbca300a58 SHA512 07f342c92a2612f99d2e4fa114118e4cba0965780b1b5d0b85df6180ba4795358938e81890a6d1a2c2742705506e2b8e1fef286c6e79e4ef830d2577bb28acc9 WHIRLPOOL 2bdebfb9a9dd37fa745b16fca17ae5e7d9210bf1cdb72a327129048dac9dcbd54619fb83f4d2221caa9fc120f6ab86d751521836c22516c41e429a2286fa1ae3
diff --git a/app-emacs/expand-region/expand-region-0.11.0.ebuild b/app-emacs/expand-region/expand-region-0.11.0.ebuild
new file mode 100644
index 000000000000..b151534d2ef7
--- /dev/null
+++ b/app-emacs/expand-region/expand-region-0.11.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit elisp
+
+DESCRIPTION="Emacs extension to increase selected region by semantic units"
+HOMEPAGE="https://github.com/magnars/expand-region.el"
+SRC_URI="https://github.com/magnars/expand-region.el/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/expand-region.el-${PV}"
+SITEFILE="50${PN}-gentoo.el"
+DOCS="README.md"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}
diff --git a/app-emacs/expand-region/files/50expand-region-gentoo.el b/app-emacs/expand-region/files/50expand-region-gentoo.el
new file mode 100644
index 000000000000..bd5b40540780
--- /dev/null
+++ b/app-emacs/expand-region/files/50expand-region-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "expand-region-autoloads" nil t)
diff --git a/app-emacs/expand-region/metadata.xml b/app-emacs/expand-region/metadata.xml
new file mode 100644
index 000000000000..b0e06f1922e8
--- /dev/null
+++ b/app-emacs/expand-region/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>victor@enise.org</email>
+ <name>Victor Gaydov</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">magnars/expand-region.el</remote-id>
+ </upstream>
+</pkgmetadata>