summaryrefslogtreecommitdiff
path: root/app-emacs/esup
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /app-emacs/esup
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'app-emacs/esup')
-rw-r--r--app-emacs/esup/Manifest4
-rw-r--r--app-emacs/esup/esup-0.7.1_p20220203.ebuild38
-rw-r--r--app-emacs/esup/files/50esup-gentoo.el3
-rw-r--r--app-emacs/esup/metadata.xml19
4 files changed, 64 insertions, 0 deletions
diff --git a/app-emacs/esup/Manifest b/app-emacs/esup/Manifest
new file mode 100644
index 000000000000..127e154f28f1
--- /dev/null
+++ b/app-emacs/esup/Manifest
@@ -0,0 +1,4 @@
+AUX 50esup-gentoo.el 121 BLAKE2B 07a96ee443b10db2b385f9e1a1cc2937da5fa3707bb983259bb3196f357871a6b77389f614a5a5fb4f7071e161e9745317d9ed71e691fbbf862402eaa020ac8b SHA512 a826c4a4a2c66d29b8abc913373aad21a6a1e8a31c807052438d10a92abe02e083752db896f015bd4075f4038f2e321b6f0a11983ec23358fc4e9855ca96ee1f
+DIST esup-0.7.1_p20220203.tar.gz 54747 BLAKE2B 09d07300796b0874bbfe4c91f91ba9d56000e097c3ead2759d284f113ee3a34701952662f5e37a32cac889e9811b0ec53dbf93c7104d8530434c5fbb6fffb7da SHA512 4b361121273c8791f107e9b883bd6983d6be23f1abd9187347c510a4c11d8e8edf3b533aa7af561f869f9ebc8b1a6f12e5351127d30e8fd4127eface290cf8c7
+EBUILD esup-0.7.1_p20220203.ebuild 768 BLAKE2B fdd105cb9da06a20b6bb0ccf3cc7a34011bd381a139d9d6121033d5c5f81c527546d8f1aee21740e10f2f08cdfe5d65cf72c8473debbd1d5d6504461de8520a6 SHA512 d4dd16cf901fae63b2e95dc0dd933856eab54e13cb7e77069ab466a15c669ce03d857aa624a660a8377d3c876979df9e99259c3054b590a001c88d530a9db8a9
+MISC metadata.xml 713 BLAKE2B 0c4512dcbc81412e13084fde4fb12762492881ca8e69c8108628ed613c5b9fe97391379896c6c37ee0d6917db8fd5b937476f5d2945e8b2eb5696d7bbb660871 SHA512 2d9802de757ae62e32b4870e7f9b3a75ffaacd652717945a1f51479f7f188af92b7a03bb198783330e5a97e0cf3882b7a41c89cdaae1a9791e16333edbf0bde3
diff --git a/app-emacs/esup/esup-0.7.1_p20220203.ebuild b/app-emacs/esup/esup-0.7.1_p20220203.ebuild
new file mode 100644
index 000000000000..e3d78933734e
--- /dev/null
+++ b/app-emacs/esup/esup-0.7.1_p20220203.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=4b49c8d599d4cc0fbf994e9e54a9c78e5ab62a5f
+NEED_EMACS=25.1
+
+inherit elisp
+
+DESCRIPTION="Benchmark Emacs Startup time without ever leaving it"
+HOMEPAGE="https://github.com/jschaf/esup/"
+SRC_URI="https://github.com/jschaf/${PN}/archive/${H}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${H}
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="app-emacs/s"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ app-emacs/buttercup
+ app-emacs/dash
+ app-emacs/noflet
+ app-emacs/undercover
+ )
+"
+
+DOCS=( README.md esup-screenshot.png )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ buttercup -L . -L test --traceback full test || die
+}
diff --git a/app-emacs/esup/files/50esup-gentoo.el b/app-emacs/esup/files/50esup-gentoo.el
new file mode 100644
index 000000000000..0cd16df3f8e9
--- /dev/null
+++ b/app-emacs/esup/files/50esup-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'esup "esup"
+ "Profile the startup time of Emacs in the background." t)
diff --git a/app-emacs/esup/metadata.xml b/app-emacs/esup/metadata.xml
new file mode 100644
index 000000000000..de9476cad492
--- /dev/null
+++ b/app-emacs/esup/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/jschaf/esup/issues/</bugs-to>
+ <remote-id type="github">jschaf/esup</remote-id>
+ </upstream>
+ <longdescription>
+ Esup profiles your Emacs startup time by examining all top-level
+ S-expressions (sexps). Esup starts a new Emacs process from Emacs to
+ profile each SEXP. After the profiled Emacs is complete, it will exit and
+ your Emacs will display the results.
+ </longdescription>
+</pkgmetadata>