summaryrefslogtreecommitdiff
path: root/app-emacs/ert-runner
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /app-emacs/ert-runner
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'app-emacs/ert-runner')
-rw-r--r--app-emacs/ert-runner/Manifest5
-rw-r--r--app-emacs/ert-runner/ert-runner-0.8.0.ebuild49
-rw-r--r--app-emacs/ert-runner/files/50ert-runner-gentoo.el1
-rw-r--r--app-emacs/ert-runner/files/ert-runner-bin-launcher-fix.patch30
-rw-r--r--app-emacs/ert-runner/metadata.xml13
5 files changed, 98 insertions, 0 deletions
diff --git a/app-emacs/ert-runner/Manifest b/app-emacs/ert-runner/Manifest
new file mode 100644
index 000000000000..56017cccfd5b
--- /dev/null
+++ b/app-emacs/ert-runner/Manifest
@@ -0,0 +1,5 @@
+AUX 50ert-runner-gentoo.el 38 BLAKE2B e96c6cf48d1522d89450e11d339c76210c672377208b56951791b83c6ef22b2c872d313084e199dd5d7b533a99106a87dbc7f15b5ee6126f71bf5f2e84165ffa SHA512 5c00bcabe2d7cc03013dc7a54b2c653940c08098ca5646d7c73624cb1ca04376ae9dcf88a7166b1925c69f0c5d192d90f6bd790fdef8ed8c3b0f9d163c987da5
+AUX ert-runner-bin-launcher-fix.patch 875 BLAKE2B 27f860ae14f9b869891ad0ff7ab2a40511231418c5b377db3c04bd7e7366b0ecb6a1d977b93c22cd3759f53986d3d38101c981ee2642e3d036ddd78acd0e14e9 SHA512 750562585a4933a1c9e6c12ddc97e92b5fc987b85013118861f3fb5a25f6317d7838cb8fa2c79ab2c8207d8b64db3e0d39a6aa4f237d84e7e243c0ca374fd4e8
+DIST ert-runner-0.8.0.tar.gz 36263 BLAKE2B 8eceabea446ffde87c10cd5257264b61ad2e2617cd9a3243c9be5548298a61d5872b46359a798180e3bf450fc8c474f4651fb834959c30f93df807d4ba006401 SHA512 a8d17c10b7c4db3fb784725c22d382e7cf213c7a6bc320658b64f1aaf9597cfe9cedc436771ade239cc9ad59e0d3457c257ce9342f9bee8a3fd65f76eb6d9e9b
+EBUILD ert-runner-0.8.0.ebuild 976 BLAKE2B 288b09137570fd3842d6e0540fe2560bf985ee9e68ae941e4c2be7083f3676908caf85c2703cfacbea4a334c03837d2bc91d33c12dc6a367ccc9a09b9f824a1e SHA512 c2ab2fe9744072cb8b781647a7c8fca7aa4c062d517ddacfa40eab0ec2499ffbe11b9677aef417997c4cb72fd476554f941a45dcc82730f76cea6e45997b073d
+MISC metadata.xml 429 BLAKE2B c4a916f3c51d567bdf15e23e8c77c711f7bd8420cdfef969b60172915525a8333a901088abfad87117d8244279aadcec453d6247543b084e32d1df68c45430fb SHA512 4459325d760c43ec46f80c3bd4fc05514329f0cb7fa450764659677c82f41eec2946c30c4ff6e9594232a42654ce51b8b7517d8c0a83a27c3e3bdf9814f3e088
diff --git a/app-emacs/ert-runner/ert-runner-0.8.0.ebuild b/app-emacs/ert-runner/ert-runner-0.8.0.ebuild
new file mode 100644
index 000000000000..046b3a467a4e
--- /dev/null
+++ b/app-emacs/ert-runner/ert-runner-0.8.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Opinionated Emacs Ert testing workflow"
+HOMEPAGE="https://github.com/rejeep/ert-runner.el/"
+SRC_URI="https://github.com/rejeep/${PN}.el/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}.el-${PV}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test" # Tests fail (even with Cask installed)
+
+RDEPEND="
+ app-emacs/ansi
+ app-emacs/commander
+ app-emacs/dash
+ app-emacs/f
+ app-emacs/dash
+ app-emacs/shut-up
+"
+BDEPEND="${RDEPEND}"
+
+DOCS=( README.md )
+PATCHES=( "${FILESDIR}"/${PN}-bin-launcher-fix.patch )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ elisp_src_prepare
+
+ sed "s|@SITELISP@|${EPREFIX}${SITELISP}/${PN}|" -i bin/${PN} || die
+}
+
+src_compile() {
+ elisp_src_compile
+ elisp-compile reporters/*.el
+}
+
+src_install() {
+ elisp_src_install
+ elisp-install ${PN}/reporters reporters/*.el{,c}
+
+ dobin bin/${PN}
+}
diff --git a/app-emacs/ert-runner/files/50ert-runner-gentoo.el b/app-emacs/ert-runner/files/50ert-runner-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/ert-runner/files/50ert-runner-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/ert-runner/files/ert-runner-bin-launcher-fix.patch b/app-emacs/ert-runner/files/ert-runner-bin-launcher-fix.patch
new file mode 100644
index 000000000000..80f079ba867b
--- /dev/null
+++ b/app-emacs/ert-runner/files/ert-runner-bin-launcher-fix.patch
@@ -0,0 +1,30 @@
+index 97d4ff4..fc14077 100755
+--- a/bin/ert-runner
++++ b/bin/ert-runner
+@@ -1,6 +1,6 @@
+ #!/usr/bin/env bash
+
+-ERT_RUNNER="$(dirname $(dirname $0))/ert-runner.el"
++ERT_RUNNER="@SITELISP@/ert-runner.el"
+
+ function inside_emacs_24 {
+ if [[ -n $INSIDE_EMACS ]] &&
+@@ -31,9 +31,9 @@ if has_option "--win" $@ || has_option "--no-win" $@ ; then
+ export ERT_RUNNER_OUTFILE=$(mktemp /tmp/ert-runner.XXX)
+
+ if has_option "--win" $@; then
+- "$ERT_RUNNER_EMACS" --load "$ERT_RUNNER" -Q
++ "$ERT_RUNNER_EMACS" --load "$ERT_RUNNER" -q
+ else
+- "$ERT_RUNNER_EMACS" -nw --load "$ERT_RUNNER" -Q
++ "$ERT_RUNNER_EMACS" -nw --load "$ERT_RUNNER" -q
+ fi
+
+ STATUS=$?
+@@ -43,5 +43,5 @@ if has_option "--win" $@ || has_option "--no-win" $@ ; then
+
+ exit $STATUS
+ else
+- "$ERT_RUNNER_EMACS" --script "$ERT_RUNNER" -Q
++ "$ERT_RUNNER_EMACS" --script "$ERT_RUNNER" -q
+ fi
diff --git a/app-emacs/ert-runner/metadata.xml b/app-emacs/ert-runner/metadata.xml
new file mode 100644
index 000000000000..c98b3df1e827
--- /dev/null
+++ b/app-emacs/ert-runner/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/rejeep/ert-runner.el/issues/</bugs-to>
+ <remote-id type="github">rejeep/ert-runner.el</remote-id>
+ </upstream>
+</pkgmetadata>