summaryrefslogtreecommitdiff
path: root/app-emacs/erlang-mode
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
commitb8c7370a682e4e29cda623222d17a790c01c3642 (patch)
treef6caa14689bd00a5760eadaa381ff41e50ef3c1b /app-emacs/erlang-mode
parent8a4997a7e2d1e36c089d4d76935b5a902d98d3d0 (diff)
gentoo auto-resync : 07:08:2024 - 12:37:20
Diffstat (limited to 'app-emacs/erlang-mode')
-rw-r--r--app-emacs/erlang-mode/Manifest5
-rw-r--r--app-emacs/erlang-mode/erlang-mode-27.0.1.ebuild45
-rw-r--r--app-emacs/erlang-mode/erlang-mode-9999.ebuild45
-rw-r--r--app-emacs/erlang-mode/files/50erlang-mode-gentoo.el3
-rw-r--r--app-emacs/erlang-mode/metadata.xml16
5 files changed, 114 insertions, 0 deletions
diff --git a/app-emacs/erlang-mode/Manifest b/app-emacs/erlang-mode/Manifest
new file mode 100644
index 000000000000..80c0f69a06b2
--- /dev/null
+++ b/app-emacs/erlang-mode/Manifest
@@ -0,0 +1,5 @@
+AUX 50erlang-mode-gentoo.el 98 BLAKE2B 6a4838f9420ff644630fad7e0a2fd8d160683150d31ae54c41051a8fbf29e6e500cd106e6c15e0bf3dc2ac850619bc7fb280705300af4dc71ca5c2786088f303 SHA512 d124ccfea4cf52fac9bebb13f5f165ea201fb4279b1edff9c1c08c34a2c44fc1594fc6abc584615a597d9ee8f7d1922599acc60a075de24b868e4fdb316daa7f
+DIST erlang-27.0.1.tar.gz 62055749 BLAKE2B 2cbf74efb6e2bd821b30e9b39d13b5b16899a49eedcbedd171068cb4da5d2f5cd98697a4234387d194aeace3ec1c168d752a2afd5bc52c4c6799dfd68ade6916 SHA512 03bba7f7d8226474b4dba9855e78b59c7cf78973fbb2ed48893a26879dc0dce579336e9cae6870f154bdd48cf3be6398cc1ec4ff52f252017d84edb20d565e71
+EBUILD erlang-mode-27.0.1.ebuild 921 BLAKE2B 8dd16256bdf60377a710d4ba0884072411a170871c89deca9676b32dbddfca83260c7424cd14c8190d1abd900c16bc86da81d441311486edef2b45fcd3cf4ae8 SHA512 68e2d4beba512eb755301e8dffbedcf908b3a8494bc943b4a5cc59bcea25ea556321b62f227d4ff456fa5e3b2fd5a026cc78aa23418c84e53211728950a5c1aa
+EBUILD erlang-mode-9999.ebuild 921 BLAKE2B 8dd16256bdf60377a710d4ba0884072411a170871c89deca9676b32dbddfca83260c7424cd14c8190d1abd900c16bc86da81d441311486edef2b45fcd3cf4ae8 SHA512 68e2d4beba512eb755301e8dffbedcf908b3a8494bc943b4a5cc59bcea25ea556321b62f227d4ff456fa5e3b2fd5a026cc78aa23418c84e53211728950a5c1aa
+MISC metadata.xml 486 BLAKE2B b5c209ae50f0a5f34856efd5cd80979797a952248529d67af0c1a5920b80af8e956b7a99f0edc5c6c5d28a6e9e97724740fa0c64718cdb6e57b9e20aba013770 SHA512 c56c35752b53f62c403d45b4cc8fa8a8b6541facf152cbc40866fd001d2aea635c0f6a5173b843b03dd1b4dc7a04745864d5dee050988d3c525e243d2e45a60e
diff --git a/app-emacs/erlang-mode/erlang-mode-27.0.1.ebuild b/app-emacs/erlang-mode/erlang-mode-27.0.1.ebuild
new file mode 100644
index 000000000000..614c5b4699a1
--- /dev/null
+++ b/app-emacs/erlang-mode/erlang-mode-27.0.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="A major mode for editing Erlang"
+HOMEPAGE="https://www.erlang/
+ https://github.com/erlang/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/erlang/otp.git"
+ S="${WORKDIR}/${P}/lib/tools/emacs"
+else
+ # Distfile is shared with dev-lang/erlang.
+ SRC_URI="https://github.com/erlang/otp/archive/OTP-${PV}.tar.gz
+ -> erlang-${PV}.tar.gz"
+ S="${WORKDIR}/otp-OTP-${PV}/lib/tools/emacs"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="
+ !dev-lang/erlang[emacs(-)]
+"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ elisp_src_prepare
+
+ sed -e "s:/usr/share:${EPREFIX}/usr/share:g" \
+ "${FILESDIR}/${SITEFILE}" > "${T}/${SITEFILE}" || die
+}
+
+src_install() {
+ elisp-install erlang *.el{,c}
+ elisp-site-file-install "${T}/${SITEFILE}"
+}
diff --git a/app-emacs/erlang-mode/erlang-mode-9999.ebuild b/app-emacs/erlang-mode/erlang-mode-9999.ebuild
new file mode 100644
index 000000000000..614c5b4699a1
--- /dev/null
+++ b/app-emacs/erlang-mode/erlang-mode-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="A major mode for editing Erlang"
+HOMEPAGE="https://www.erlang/
+ https://github.com/erlang/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/erlang/otp.git"
+ S="${WORKDIR}/${P}/lib/tools/emacs"
+else
+ # Distfile is shared with dev-lang/erlang.
+ SRC_URI="https://github.com/erlang/otp/archive/OTP-${PV}.tar.gz
+ -> erlang-${PV}.tar.gz"
+ S="${WORKDIR}/otp-OTP-${PV}/lib/tools/emacs"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="
+ !dev-lang/erlang[emacs(-)]
+"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ elisp_src_prepare
+
+ sed -e "s:/usr/share:${EPREFIX}/usr/share:g" \
+ "${FILESDIR}/${SITEFILE}" > "${T}/${SITEFILE}" || die
+}
+
+src_install() {
+ elisp-install erlang *.el{,c}
+ elisp-site-file-install "${T}/${SITEFILE}"
+}
diff --git a/app-emacs/erlang-mode/files/50erlang-mode-gentoo.el b/app-emacs/erlang-mode/files/50erlang-mode-gentoo.el
new file mode 100644
index 000000000000..8dbd920433bc
--- /dev/null
+++ b/app-emacs/erlang-mode/files/50erlang-mode-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(require 'erlang-start)
+(setq erlang-root-dir "/usr/share")
diff --git a/app-emacs/erlang-mode/metadata.xml b/app-emacs/erlang-mode/metadata.xml
new file mode 100644
index 000000000000..03f107b69d89
--- /dev/null
+++ b/app-emacs/erlang-mode/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>matthew@gentoo.org</email>
+ <name>Matthew Smith</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">erlang/otp</remote-id>
+ </upstream>
+</pkgmetadata>