summaryrefslogtreecommitdiff
path: root/app-emacs/emms/emms-4.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-11-03 18:18:28 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-11-03 18:18:28 +0000
commitfceeaf01a28ee71065cf3798b70b77d3bc4ef199 (patch)
tree6be36785f6ffa594c4dbd785b3213c995b5195b9 /app-emacs/emms/emms-4.4.ebuild
parent27dfd272ae3be15b1017f733682211afa1c7c0f0 (diff)
gentoo resync : 03.11.2017
Diffstat (limited to 'app-emacs/emms/emms-4.4.ebuild')
-rw-r--r--app-emacs/emms/emms-4.4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-emacs/emms/emms-4.4.ebuild b/app-emacs/emms/emms-4.4.ebuild
new file mode 100644
index 000000000000..1aacf114f268
--- /dev/null
+++ b/app-emacs/emms/emms-4.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit elisp toolchain-funcs
+
+DESCRIPTION="The Emacs Multimedia System"
+HOMEPAGE="https://www.gnu.org/software/emms/
+ https://www.emacswiki.org/emacs/EMMS"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+ FDL-1.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="media-libs/taglib"
+RDEPEND="${DEPEND}"
+
+# EMMS can use almost anything for playing media files therefore the dependency
+# possibilities are so broad that we refrain from setting anything explicitly
+# in DEPEND/RDEPEND.
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" \
+ all emms-print-metadata
+}
+
+src_install() {
+ elisp-install ${PN} lisp/*.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ doinfo doc/emms.info*
+ dobin src/emms-print-metadata
+ doman emms-print-metadata.1
+ dodoc AUTHORS ChangeLog NEWS README THANKGNU
+}