summaryrefslogtreecommitdiff
path: root/app-emacs/embark-consult
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-13 15:59:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-13 15:59:12 +0100
commit724570cf64d3eddb687d69ef236582cdd6363fb4 (patch)
tree34fd19370847ea76632df0ea5ef4f9cc769d26c3 /app-emacs/embark-consult
parent74bdea52f57b5c6ac79078bc30a1c342dc3d49c7 (diff)
gentoo auto-resync : 13:05:2023 - 15:59:11
Diffstat (limited to 'app-emacs/embark-consult')
-rw-r--r--app-emacs/embark-consult/Manifest4
-rw-r--r--app-emacs/embark-consult/embark-consult-0.21.ebuild34
-rw-r--r--app-emacs/embark-consult/files/50embark-consult-gentoo.el1
-rw-r--r--app-emacs/embark-consult/metadata.xml13
4 files changed, 52 insertions, 0 deletions
diff --git a/app-emacs/embark-consult/Manifest b/app-emacs/embark-consult/Manifest
new file mode 100644
index 000000000000..33f98099059f
--- /dev/null
+++ b/app-emacs/embark-consult/Manifest
@@ -0,0 +1,4 @@
+AUX 50embark-consult-gentoo.el 38 BLAKE2B e96c6cf48d1522d89450e11d339c76210c672377208b56951791b83c6ef22b2c872d313084e199dd5d7b533a99106a87dbc7f15b5ee6126f71bf5f2e84165ffa SHA512 5c00bcabe2d7cc03013dc7a54b2c653940c08098ca5646d7c73624cb1ca04376ae9dcf88a7166b1925c69f0c5d192d90f6bd790fdef8ed8c3b0f9d163c987da5
+DIST embark-0.21.tar.gz 102588 BLAKE2B 5a578fe25018591e4dbbe4b683ce1e8669003fdedef3c6eecdf039fdcdc7b2d5accbd95faebe369b5dac90be8beb3be7c0507190f2cac4556a25a58709aef7c9 SHA512 ab450ab17d17fa4673615d6daef9495d4e567ab612f4a732f7536427b71dffecbb0456accc7adb28cedb3f1a73709fa2e51cb01f20902dc7748755ee1ea2442c
+EBUILD embark-consult-0.21.ebuild 685 BLAKE2B c4ceb6c7b6b1fca3a59e89a4315f9f6a3739d8739d09805c131503ebb66cfe2cb60ec69d8d73edfeea309ac9d59b14dac2db1af01f11541274ebe78b926ade0b SHA512 780cdcc67955b79954b7aaa5f6fa8f2d882ef21207b2a3bd736eb35367070f6cc6b9202810893a784ced439abbfc60a86829a3f0bfa5804219db1bbd72c23cda
+MISC metadata.xml 419 BLAKE2B 9c67112b069db1f3656bbe3f14d52212578fa04e2fa5a39e963014637aee47c2d635a881794f03004a8b2a03471de6106a2ace40483ab1218423a94ebcb3af83 SHA512 547d90d7b62b0c7413d63ce242ebd5f4795b8f253d34d273d07b01bafc0e7f6996c55a1244227b0c2f62ab43f09e85bae581ae23585d21f4b32edf4aa173cb44
diff --git a/app-emacs/embark-consult/embark-consult-0.21.ebuild b/app-emacs/embark-consult/embark-consult-0.21.ebuild
new file mode 100644
index 000000000000..5938c7ef66e4
--- /dev/null
+++ b/app-emacs/embark-consult/embark-consult-0.21.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Consult integration for Embark"
+HOMEPAGE="https://github.com/oantolin/embark/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/oantolin/embark.git"
+else
+ SRC_URI="https://github.com/oantolin/embark/archive/${PV}.tar.gz
+ -> embark-${PV}.tar.gz"
+ S="${WORKDIR}"/embark-${PV}
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ app-emacs/consult
+ app-emacs/embark
+"
+BDEPEND="${RDEPEND}"
+
+ELISP_REMOVE="avy-embark-collect.el embark-org.el embark.el"
+
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/embark-consult/files/50embark-consult-gentoo.el b/app-emacs/embark-consult/files/50embark-consult-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/embark-consult/files/50embark-consult-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/embark-consult/metadata.xml b/app-emacs/embark-consult/metadata.xml
new file mode 100644
index 000000000000..fda35757dfa2
--- /dev/null
+++ b/app-emacs/embark-consult/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/oantolin/embark/issues/</bugs-to>
+ <remote-id type="github">oantolin/embark</remote-id>
+ </upstream>
+</pkgmetadata>