summaryrefslogtreecommitdiff
path: root/app-emacs/emacs-wget
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/emacs-wget
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/emacs-wget')
-rw-r--r--app-emacs/emacs-wget/Manifest4
-rw-r--r--app-emacs/emacs-wget/emacs-wget-0.5.0-r1.ebuild26
-rw-r--r--app-emacs/emacs-wget/files/50emacs-wget-gentoo.el4
-rw-r--r--app-emacs/emacs-wget/metadata.xml9
4 files changed, 43 insertions, 0 deletions
diff --git a/app-emacs/emacs-wget/Manifest b/app-emacs/emacs-wget/Manifest
new file mode 100644
index 000000000000..6e3906e7daf5
--- /dev/null
+++ b/app-emacs/emacs-wget/Manifest
@@ -0,0 +1,4 @@
+AUX 50emacs-wget-gentoo.el 230 BLAKE2B bca8ec11b147a2017a663304ca68b9796c6f9049f5ee7ff7ed674f271805188b8c698c7165c7e9e17c7d9f750346fa9a056d9830e1303887ac35e141b4adc8a0 SHA512 803bf76202edd3d130a8050a026ddf84a4a2dbe65f6bf5fc159a66b3af12e2d46ce519a61296fcada0ad0ed3fbf61d62bcc87e3329dde02a83d09f94ff257d01
+DIST emacs-wget-0.5.0.tar.gz 37074 BLAKE2B d2922c0396dfc745335ee5adc7bad1ecc440ada6e43ac1be00939c592fca5a5de0ea0e4a69a4186efe7a23cbdabcae17fa146a146743add1c615eead3a42a75e SHA512 32d322cda7435b901115cdc01ef6b6e84f2af7f686f7d6a89cc486523d9d8b9807903c4ee0fb945a4ff457720033523beb34037e29ef7c9cdf2a10c62b725d54
+EBUILD emacs-wget-0.5.0-r1.ebuild 571 BLAKE2B 524df075eae96cbeffc0ce0a4f8dd953f7b5c50cb2f0e2d89a139edb3e50af41718c2f64617c6ac189e339cfd8ec4f3b3dee455975613a13fbabb662e946ccc9 SHA512 fa282f710316223ccec69d3d233d56e2b6fcec033b081fe16d33d8a8f71456509c18eb64c9790bb5fa452a75cd61f7130f64a8008188f87b1ee2bd07ed0a16b3
+MISC metadata.xml 282 BLAKE2B 432e60a3b04def9f566fde3852011e006c0d578c72c42115734d1af5c128440fcee68134c8f891baad437e64a8d61fbbac49e70a35ed4f6f85641e888d3a2547 SHA512 1838e22e1f5b849b816a05d1b25bd81333c8cf67ceb996177e05ba7a555b8e0e307e62cb53e6f1217f4216823e2fecf050e85437678503d60e10c6b2d5303072
diff --git a/app-emacs/emacs-wget/emacs-wget-0.5.0-r1.ebuild b/app-emacs/emacs-wget/emacs-wget-0.5.0-r1.ebuild
new file mode 100644
index 000000000000..348adb4562c7
--- /dev/null
+++ b/app-emacs/emacs-wget/emacs-wget-0.5.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Wget interface for Emacs"
+HOMEPAGE="https://www.emacswiki.org/emacs/EmacsWget"
+SRC_URI="http://pop-club.hp.infoseek.co.jp/emacs/emacs-wget/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc ppc64 x86"
+IUSE="l10n_ja"
+
+RDEPEND=">=net-misc/wget-1.8.2"
+
+ELISP_REMOVE="lpath.el"
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ elisp_src_install
+ dodoc ChangeLog README USAGE
+ use l10n_ja && dodoc README.ja USAGE.ja
+}
diff --git a/app-emacs/emacs-wget/files/50emacs-wget-gentoo.el b/app-emacs/emacs-wget/files/50emacs-wget-gentoo.el
new file mode 100644
index 000000000000..51afcaf6d4c1
--- /dev/null
+++ b/app-emacs/emacs-wget/files/50emacs-wget-gentoo.el
@@ -0,0 +1,4 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'wget "wget" "wget interface for Emacs." t)
+(autoload 'wget-web-page "wget" "wget interface to download whole web page." t)
+(add-hook 'w3m-mode-hook (lambda () (require 'w3m-wget)))
diff --git a/app-emacs/emacs-wget/metadata.xml b/app-emacs/emacs-wget/metadata.xml
new file mode 100644
index 000000000000..c918cdef9591
--- /dev/null
+++ b/app-emacs/emacs-wget/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<stabilize-allarches/>
+</pkgmetadata>