summaryrefslogtreecommitdiff
path: root/app-emacs/emacs-ipython-notebook
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /app-emacs/emacs-ipython-notebook
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'app-emacs/emacs-ipython-notebook')
-rw-r--r--app-emacs/emacs-ipython-notebook/Manifest4
-rw-r--r--app-emacs/emacs-ipython-notebook/emacs-ipython-notebook-0.17.0_p20220419.ebuild69
-rw-r--r--app-emacs/emacs-ipython-notebook/files/50emacs-ipython-notebook-gentoo.el4
-rw-r--r--app-emacs/emacs-ipython-notebook/metadata.xml13
4 files changed, 90 insertions, 0 deletions
diff --git a/app-emacs/emacs-ipython-notebook/Manifest b/app-emacs/emacs-ipython-notebook/Manifest
new file mode 100644
index 000000000000..fdccf39a78b4
--- /dev/null
+++ b/app-emacs/emacs-ipython-notebook/Manifest
@@ -0,0 +1,4 @@
+AUX 50emacs-ipython-notebook-gentoo.el 183 BLAKE2B 007608b7763cd9223bad524b5219503687c1e6665a2269a09621a9e381de9373ba299cc6b808c000d65b916f554f6ccef76b3f96fdd665b3ae4ec8443dc909a3 SHA512 be0e3a9e03a944947134a776164f8fdd206943609f7f84e7663363c3745c69d0a4d7fb8986b619e32e15ebe72c14ff1ec8cc9a47ab9b5c2ba16823b598adf648
+DIST emacs-ipython-notebook-0.17.0_p20220419.tar.gz 313340 BLAKE2B 5ab9b82d8d17c3f64c375de7638aa4006e7dc47137260ab0a8222f7c507a54b32aa145d1630b3d0018c8303e0f116da81b61df27cd401875dfad5fd49ecdae13 SHA512 f6c2c293e7d2ddcba9dfac751523e0f8d55047ed01d4546ba1ece1f8833a1d54a1bcc066f34f06e111c34baee21a97c2ede2d90d188d7a05f407631acfd74037
+EBUILD emacs-ipython-notebook-0.17.0_p20220419.ebuild 1743 BLAKE2B cc317a1b3916e0021b51ee4f3dc53e510059a84f7932c2dec00109daa1b8aa40b28aea55af88a9ac0da681d6700239f84de59c8d27f129269ce7aa8f3eee0279 SHA512 83f7a187430311e79a4a84ca85318b50945d6e28a35d13514f8cce47aec3aa9a22b9f72090a3bc99c46c5f0c9f039b771d5f3b610597617e7c18be468a3930a2
+MISC metadata.xml 451 BLAKE2B 22c22fc375f454f2d73aa08aa90ba3ffe5317badf5e9c24a9d3c890ea3fd983861ab85b8c21946801720ba750651d86e5f8d0374e1e72d2d2d0cc0782c8ab558 SHA512 4aad325d63fa41071054835afe506c67e02c720dce4519d9b7a5307c68aae1fbe9fce08f469925137de5c133d6a40c1839de1c837159507882d48198ff82f48a
diff --git a/app-emacs/emacs-ipython-notebook/emacs-ipython-notebook-0.17.0_p20220419.ebuild b/app-emacs/emacs-ipython-notebook/emacs-ipython-notebook-0.17.0_p20220419.ebuild
new file mode 100644
index 000000000000..c920c630fbc1
--- /dev/null
+++ b/app-emacs/emacs-ipython-notebook/emacs-ipython-notebook-0.17.0_p20220419.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NOTICE: Check package version in "lisp/ein-pkg.el".
+# NOTICE: File "lisp/ein-pkg.el" is needed by the "ein:dev-sys-info" function.
+
+EAPI=8
+
+H=388c8f753cfb99b4f82acbdff26bbe27189d2299
+NEED_EMACS=25
+
+inherit elisp readme.gentoo-r1
+
+DESCRIPTION="Jupyter notebook client in Emacs"
+HOMEPAGE="https://github.com/millejoh/emacs-ipython-notebook/"
+SRC_URI="https://github.com/millejoh/${PN}/archive/${H}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${H}
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-emacs/anaphora
+ app-emacs/dash
+ app-emacs/deferred
+ app-emacs/polymode
+ app-emacs/request
+ app-emacs/websocket
+ app-emacs/with-editor
+ dev-python/ipython
+ dev-python/notebook
+ www-servers/tornado
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ app-emacs/ert-runner
+ app-emacs/mocker
+ )
+"
+
+DOCS=( README.rst thumbnail.png )
+DOC_CONTENTS="There may be problems with connecting to Jupyter Notebooks
+ because of the tokens, in that case you can try running \"jupyter
+ notebook\" with --NotebookApp.token=\"\" (and --NotebookApp.ip=127.0.0.1 to
+ limit connections only to local machine), but be warned that this can
+ compromise your system if used without caution! For reference check out
+ https://github.com/millejoh/emacs-ipython-notebook/issues/838"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ BYTECOMPFLAGS="-L lisp" elisp-compile lisp/*.el
+}
+
+src_test() {
+ ert-runner -L lisp -L test -l test/testein.el \
+ --reporter ert+duration test/test-ein*.el || die
+}
+
+src_install() {
+ elisp-install ${PN} lisp/*.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ readme.gentoo_create_doc
+}
diff --git a/app-emacs/emacs-ipython-notebook/files/50emacs-ipython-notebook-gentoo.el b/app-emacs/emacs-ipython-notebook/files/50emacs-ipython-notebook-gentoo.el
new file mode 100644
index 000000000000..97bab14bcf69
--- /dev/null
+++ b/app-emacs/emacs-ipython-notebook/files/50emacs-ipython-notebook-gentoo.el
@@ -0,0 +1,4 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'ein:ipynb-mode "ein-ipynb-mode"
+ "A simple mode for ipynb file." t)
+(add-to-list 'auto-mode-alist '("\\.ipynb\\'" . ein:ipynb-mode))
diff --git a/app-emacs/emacs-ipython-notebook/metadata.xml b/app-emacs/emacs-ipython-notebook/metadata.xml
new file mode 100644
index 000000000000..d0e5ba20a2d5
--- /dev/null
+++ b/app-emacs/emacs-ipython-notebook/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/millejoh/emacs-ipython-notebook/issues/</bugs-to>
+ <remote-id type="github">millejoh/emacs-ipython-notebook</remote-id>
+ </upstream>
+</pkgmetadata>