summaryrefslogtreecommitdiff
path: root/app-emacs/emacs-ipython-notebook
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-13 01:09:33 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-13 01:09:33 +0000
commit58523314abd7b5740c06e3bbcd41ada404e7c612 (patch)
tree2ec4372c4b63bd8679af9b4c591c2743e421b1b9 /app-emacs/emacs-ipython-notebook
parent4fc30e4e13ecfbe29fbef3b5caf96218eab30b68 (diff)
gentoo auto-resync : 13:01:2024 - 01:09:33
Diffstat (limited to 'app-emacs/emacs-ipython-notebook')
-rw-r--r--app-emacs/emacs-ipython-notebook/Manifest2
-rw-r--r--app-emacs/emacs-ipython-notebook/emacs-ipython-notebook-0.17.1_pre20230826.ebuild81
2 files changed, 83 insertions, 0 deletions
diff --git a/app-emacs/emacs-ipython-notebook/Manifest b/app-emacs/emacs-ipython-notebook/Manifest
index 5810ac20e23c..810f1762979b 100644
--- a/app-emacs/emacs-ipython-notebook/Manifest
+++ b/app-emacs/emacs-ipython-notebook/Manifest
@@ -1,4 +1,6 @@
AUX 50emacs-ipython-notebook-gentoo.el 183 BLAKE2B 007608b7763cd9223bad524b5219503687c1e6665a2269a09621a9e381de9373ba299cc6b808c000d65b916f554f6ccef76b3f96fdd665b3ae4ec8443dc909a3 SHA512 be0e3a9e03a944947134a776164f8fdd206943609f7f84e7663363c3745c69d0a4d7fb8986b619e32e15ebe72c14ff1ec8cc9a47ab9b5c2ba16823b598adf648
DIST emacs-ipython-notebook-0.17.0_p20220419.tar.gz 313340 BLAKE2B 5ab9b82d8d17c3f64c375de7638aa4006e7dc47137260ab0a8222f7c507a54b32aa145d1630b3d0018c8303e0f116da81b61df27cd401875dfad5fd49ecdae13 SHA512 f6c2c293e7d2ddcba9dfac751523e0f8d55047ed01d4546ba1ece1f8833a1d54a1bcc066f34f06e111c34baee21a97c2ede2d90d188d7a05f407631acfd74037
+DIST emacs-ipython-notebook-0.17.1_pre20230826.tar.gz 312767 BLAKE2B 742df1a4fdf8409d711bd9903baa103cd28d110400f46c97e0fc0962e1ef3cf4f0fb696881bb54d83c7e1d342669dcd493e5e24067f6f439a8639dcef2140dae SHA512 1df8551c75fbd8e3c0543ec304cae9974024e36710fb6e7f418c4c8052bbfdefde357000e4df135ddbc58faf808d9bdf1ec731113e317500ad5fed48c1d1bd6f
EBUILD emacs-ipython-notebook-0.17.0_p20220419-r1.ebuild 1992 BLAKE2B cdeaf83dae039b5ee419efb85fbe5f52067f44cf5b7ae33605d0d2fc7f7d5385c2e7dfa0f1d1833b3aa2a77897bd73283819d6bc121bd8c6ab6d4db73e6a3ed7 SHA512 4abf2401b9f27e99f323b10eee1629c06232a0aa24b79aa27677ea2bbc117136e9570fdda4b85da2fcdfab3eaccf0012711e1a69c752b50ab72477d76df0356d
+EBUILD emacs-ipython-notebook-0.17.1_pre20230826.ebuild 2115 BLAKE2B 0596816cecc57217a0eaefc8177a94e8b0f8a6c93f21a5e676128c4924d70b1b4a4acb1276e1b5b86b68498a863d1e7230ea42e6b097a13100c176b0593635df SHA512 f458a99a64e5670d2f9c00c5e4a6baf2a0b84433846fadb7646f1ebbffd84c1c2aab78a3ef4b7627d49be8fffa5c4fb0ef4153be5f6d2faf2b57e14bec83aeaf
MISC metadata.xml 451 BLAKE2B 22c22fc375f454f2d73aa08aa90ba3ffe5317badf5e9c24a9d3c890ea3fd983861ab85b8c21946801720ba750651d86e5f8d0374e1e72d2d2d0cc0782c8ab558 SHA512 4aad325d63fa41071054835afe506c67e02c720dce4519d9b7a5307c68aae1fbe9fce08f469925137de5c133d6a40c1839de1c837159507882d48198ff82f48a
diff --git a/app-emacs/emacs-ipython-notebook/emacs-ipython-notebook-0.17.1_pre20230826.ebuild b/app-emacs/emacs-ipython-notebook/emacs-ipython-notebook-0.17.1_pre20230826.ebuild
new file mode 100644
index 000000000000..83f23a778891
--- /dev/null
+++ b/app-emacs/emacs-ipython-notebook/emacs-ipython-notebook-0.17.1_pre20230826.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NOTICE: Check package version in "lisp/ein-pkg.el".
+# NOTICE: File "lisp/ein-pkg.el" is needed by the "ein:dev-sys-info" function.
+
+EAPI=8
+
+[[ "${PV}" == *20230826 ]] && COMMIT=998ba22660be2035cd23bed1555e47748c4da8a2
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit elisp readme.gentoo-r1 python-single-r1
+
+DESCRIPTION="Jupyter notebook client in Emacs"
+HOMEPAGE="https://github.com/millejoh/emacs-ipython-notebook/"
+SRC_URI="https://github.com/millejoh/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${COMMIT}
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ app-emacs/anaphora
+ app-emacs/dash
+ app-emacs/deferred
+ app-emacs/polymode
+ app-emacs/request
+ app-emacs/websocket
+ app-emacs/with-editor
+ $(python_gen_cond_dep '
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/notebook[${PYTHON_USEDEP}]
+ dev-python/tornado[${PYTHON_USEDEP}]
+ ')
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ app-emacs/ert-runner
+ app-emacs/mocker
+ )
+"
+
+DOCS=( README.rst thumbnail.png )
+DOC_CONTENTS="There may be problems with connecting to Jupyter Notebooks
+ because of the tokens, in that case you can try running \"jupyter
+ notebook\" with --NotebookApp.token=\"\" (and --NotebookApp.ip=127.0.0.1 to
+ limit connections only to local machine), but be warned that this can
+ compromise your system if used without caution! For reference check out
+ https://github.com/millejoh/emacs-ipython-notebook/issues/838"
+
+SITEFILE="50${PN}-gentoo.el"
+
+pkg_setup() {
+ # * ACCESS DENIED: open_wr: ~/.config/python/jupyter/migrated
+ unset JUPYTER_CONFIG_DIR
+
+ elisp_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_compile() {
+ BYTECOMPFLAGS="-L lisp" elisp-compile lisp/*.el
+}
+
+src_test() {
+ ert-runner -L lisp -L test -l test/testein.el \
+ --reporter ert+duration test/test-ein*.el || die
+}
+
+src_install() {
+ elisp-install ${PN} lisp/*.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ readme.gentoo_create_doc
+}