summaryrefslogtreecommitdiff
path: root/app-emacs/emacs-eix/emacs-eix-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /app-emacs/emacs-eix/emacs-eix-9999.ebuild
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'app-emacs/emacs-eix/emacs-eix-9999.ebuild')
-rw-r--r--app-emacs/emacs-eix/emacs-eix-9999.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-emacs/emacs-eix/emacs-eix-9999.ebuild b/app-emacs/emacs-eix/emacs-eix-9999.ebuild
new file mode 100644
index 000000000000..2821ddbc8bc4
--- /dev/null
+++ b/app-emacs/emacs-eix/emacs-eix-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24.3
+
+inherit elisp
+
+DESCRIPTION="Eix integration for GNU Emacs"
+HOMEPAGE="https://gitweb.gentoo.org/proj/emacs-eix.git"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitweb.gentoo.org/proj/${PN}.git"
+else
+ SRC_URI="https://gitweb.gentoo.org/proj/${PN}.git/snapshot/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}