summaryrefslogtreecommitdiff
path: root/app-emacs/emacs-eat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-01 03:50:42 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-01 03:50:42 +0000
commitd4ad8633bc8c3408481e882d717fce4985457d81 (patch)
tree678ca03ee89620ce3fca38fc9769d81ecf908613 /app-emacs/emacs-eat
parentb43ae231a57eccda208f33c4343d956e7f2590f5 (diff)
gentoo auto-resync : 01:11:2023 - 03:50:42
Diffstat (limited to 'app-emacs/emacs-eat')
-rw-r--r--app-emacs/emacs-eat/Manifest4
-rw-r--r--app-emacs/emacs-eat/emacs-eat-0.9.2.ebuild63
-rw-r--r--app-emacs/emacs-eat/files/50emacs-eat-gentoo.el4
-rw-r--r--app-emacs/emacs-eat/metadata.xml24
4 files changed, 95 insertions, 0 deletions
diff --git a/app-emacs/emacs-eat/Manifest b/app-emacs/emacs-eat/Manifest
new file mode 100644
index 000000000000..e427d9f3ed01
--- /dev/null
+++ b/app-emacs/emacs-eat/Manifest
@@ -0,0 +1,4 @@
+AUX 50emacs-eat-gentoo.el 197 BLAKE2B b76e24e1551b948c7cf9dbb2b3d872fc481eda0f7499f9ae321b6d28e686311cfc2ac8b3897abe002d92f72412f797cff153efaf9a9d4da09964b76dc6ff6e54 SHA512 33be3eee0ddfab2ae273bdd5528b3d5cb57c30e2e7c0279f16ce83c59382306ebd26d8a29933fe5cf53fd51f8e95c1c06500c00741dfaea2639252dc2c0c6cc3
+DIST emacs-eat-0.9.2.tar.gz 274950 BLAKE2B 2b0378a20d1fec511c7b24e4e5cc1937bb8b01f4a0a76f794d847d77de54fb87bc0806082a2ceeb3793eb034d2e0b1aa916441b5b931e00e935d9399b1c84e14 SHA512 69db9aef6ba4037561bb2a344878ece7912140ff42a4c285b355ef2ef2351282d048af78949fe52959c6e5543f8a9a63bd07fc931b802abaa981effbb65e9c20
+EBUILD emacs-eat-0.9.2.ebuild 1092 BLAKE2B 816d29bd78bfa8ba83cbd629e9bc1c7065ea98f3406d7da50e0ab893d8e0cbd21e2521a7b7bae18dca31f17dbb8d0fa3e947f0a11231b2b65ad96e5f2c9ac74c SHA512 28e2d169bb837d077f4b359030308ba1568951bff0e7c56725ba3aefcad68534ccff5398bcbf412aad4f23d083d84686de3cbe0684c2caab083ec11230abddf5
+MISC metadata.xml 1139 BLAKE2B 6f8299dda59e00898cb2a7b5bfc0575aa4ad72fb384906b1db932b7f78bb9bc48b63f907086e9be78a4668ed07b1964137520cba6f0f99a5b573567df05b38bd SHA512 79f503e3ffda91adb654343e714de00365daf2b528cdbb897b5fef347069961db0437faca4d380aec7c3c26d84236739834791fe21f576dc0ca225e4f6103f0c
diff --git a/app-emacs/emacs-eat/emacs-eat-0.9.2.ebuild b/app-emacs/emacs-eat/emacs-eat-0.9.2.ebuild
new file mode 100644
index 000000000000..4f2a6cced758
--- /dev/null
+++ b/app-emacs/emacs-eat/emacs-eat-0.9.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Emulate A Terminal, in a region, in a buffer and in Eshell"
+HOMEPAGE="https://codeberg.org/akib/emacs-eat/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://codeberg.org/akib/${PN}.git"
+else
+ SRC_URI="https://codeberg.org/akib/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( ChangeLog NEWS README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND="
+ >=app-emacs/compat-29.1.4.2
+"
+BDEPEND="
+ ${RDEPEND}
+ sys-apps/texinfo
+"
+
+elisp-enable-tests ert . -l eat-tests.el
+
+src_compile() {
+ rm -r terminfo || die
+ emake EMACS="${EMACS}" EMACSFLAGS="${EMACSFLAGS}"
+
+ elisp-compile term/eat.el
+
+ elisp-make-autoload-file
+}
+
+src_install() {
+ rm eat-tests.el || die
+ elisp_src_install
+
+ insinto "${SITELISP}/${PN}"
+ doins -r term
+
+ insinto "${SITEETC}/${PN}"
+ doins -r integration
+ doins -r terminfo
+
+ insinto /usr/share
+ doins -r terminfo
+
+ doinfo eat.info
+}
diff --git a/app-emacs/emacs-eat/files/50emacs-eat-gentoo.el b/app-emacs/emacs-eat/files/50emacs-eat-gentoo.el
new file mode 100644
index 000000000000..ba961a5100d4
--- /dev/null
+++ b/app-emacs/emacs-eat/files/50emacs-eat-gentoo.el
@@ -0,0 +1,4 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "emacs-eat-autoloads" nil t)
+(setq eat-term-shell-integration-directory "@SITEETC@/integration")
+(setq eat-term-terminfo-directory "@SITEETC@/terminfo")
diff --git a/app-emacs/emacs-eat/metadata.xml b/app-emacs/emacs-eat/metadata.xml
new file mode 100644
index 000000000000..01dd6db7d03a
--- /dev/null
+++ b/app-emacs/emacs-eat/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ Eat's name self-explanatory, it stands for "Emulate A Terminal". Eat is a
+ terminal emulator. It can run most (if not all) full-screen terminal
+ programs, including Emacs. It is pretty fast, more than three times faster
+ than Term, despite being implemented entirely in Emacs Lisp. So fast that
+ you can comfortably run Emacs inside Eat, or even use your Emacs as a
+ terminal multiplexer. It has many features that other Emacs terminal
+ emulator still don't have, for example Sixel support, complete mouse
+ support, shell integration, etc. It flickers less than other Emacs terminal
+ emulator, so you get more performance and a smoother experience.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://codeberg.org/akib/emacs-eat/issues/</bugs-to>
+ <remote-id type="codeberg">akib/emacs-eat</remote-id>
+ </upstream>
+</pkgmetadata>