summaryrefslogtreecommitdiff
path: root/app-emacs/emacs-daemon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-emacs/emacs-daemon
reinit the tree, so we can have metadata
Diffstat (limited to 'app-emacs/emacs-daemon')
-rw-r--r--app-emacs/emacs-daemon/Manifest5
-rw-r--r--app-emacs/emacs-daemon/emacs-daemon-0.22.ebuild53
-rw-r--r--app-emacs/emacs-daemon/metadata.xml8
3 files changed, 66 insertions, 0 deletions
diff --git a/app-emacs/emacs-daemon/Manifest b/app-emacs/emacs-daemon/Manifest
new file mode 100644
index 000000000000..13f6e46dad37
--- /dev/null
+++ b/app-emacs/emacs-daemon/Manifest
@@ -0,0 +1,5 @@
+DIST emacs-daemon-0.22.tar.xz 5276 SHA256 62743bc32f48bd5406dedb1d5356e7959c413dbc295977de0315a6ea8c1c6272 SHA512 f013cd00d3a24ca348bf718dd20dec7bea89107c0a27c921d6b58595b611991830604fc658d57681708218fbee1dae6dd0b277a2a9da67639e3553e0fd133094 WHIRLPOOL ccc9a7bc1d378b4b64873f9458284bef9008b1380a58700d5210404a216a62fe98d0b4547e28a2f52d0b3e958b45c84e8654eddb4fab48854629cb513462b948
+EBUILD emacs-daemon-0.22.ebuild 1674 SHA256 a7281831e8fd2ff249a49300f1e0ade53a8c6537cd915754806590df511121f2 SHA512 e7044d8206d47abf8abc2aa8c934b0739ca51250c00d46a3311ec6eb1f05321b5d02e4957d4adcc5f70035f706345529b1ba41ba0d6b177bee5156a5d771fa75 WHIRLPOOL 4b8b294d0e4af07cff9bd79139b6049b445e59c5dbad8a2888d1ddb57b54394d4a86adc9c1bc4ec8e78e10116e92d24d2f406b650a21fb8d65a74b30a244fdb4
+MISC ChangeLog 3636 SHA256 30714f0a9c14c0e0a1a50a1dcb50a02f0989ca959cb7c8d6ddc0a140437ada06 SHA512 93323237a4fabc35547947d0f6591b23e1bdf4e97c2cb33a8e8d72bff5c270b53288108ebb5d37d1a806ea6ab2831d24eb2747b1000883dca20e00ba58b0f758 WHIRLPOOL 2187d8523abd0c90dbe42036ec99f6b226676370772e19a08d7dc1153544bc0583375efca83bd28ec5403940fad334c4ab717afba75d44763be489f04142975d
+MISC ChangeLog-2015 8939 SHA256 6bb03dc29a7d7ab32d70e227a07a05165adc23e485eace781dfd2bb122df3c27 SHA512 ee81d7b950d9c20eed14a265677266b5b25ded7067842ebd23d1b93caf25dd2fd026f8ea3568c15e7526153d432dbc5f2013b3fe20974afc6cc13bae7eb924a7 WHIRLPOOL 985efdef9cfc31c5fc3c2516dd136d705979f8a55d3797f4084e1a62e1ea88b6562a49f7e8e2957c8a440a871fff09ce8af533db151e597dcd851303d4df85af
+MISC metadata.xml 259 SHA256 4d59c14917cb31648858cb06bc3c7f224cf1c3906dc3166f8f0d8b8e02970928 SHA512 9a5c456aae7919a4cdbb10b67a27c232daf2ec6db4202e04ba6d5873242fc982a659410443dd6fb4498d42af00b495acc51a6a2cbe12aeab91b585dfac7233a3 WHIRLPOOL 08c68f505a8cc685c52f3a54a07582b64ff7c0b4682c8f9333286fbb5caf4a8d406933c7937fe8c9611f456b5a549ee100657a1c9dc766c8965772f277bf31fb
diff --git a/app-emacs/emacs-daemon/emacs-daemon-0.22.ebuild b/app-emacs/emacs-daemon/emacs-daemon-0.22.ebuild
new file mode 100644
index 000000000000..e219a750ce93
--- /dev/null
+++ b/app-emacs/emacs-daemon/emacs-daemon-0.22.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit elisp
+
+DESCRIPTION="Gentoo support for Emacs running as a server in the background"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Emacs"
+SRC_URI="https://dev.gentoo.org/~ulm/emacs/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd"
+
+DEPEND=">=virtual/emacs-23"
+RDEPEND="${DEPEND}"
+
+SITEFILE="10${PN}-gentoo.el"
+
+pkg_setup() {
+ local has_daemon has_gtk line
+ has_daemon=$(${EMACS} ${EMACSFLAGS} --eval "(princ (fboundp 'daemonp))")
+ has_gtk=$(${EMACS} ${EMACSFLAGS} --eval "(princ (featurep 'gtk))")
+
+ if [[ ${has_daemon} != t ]]; then
+ while read line; do ewarn "${line}"; done <<-EOF
+ Your current Emacs version does not support running as a daemon which
+ is required for ${CATEGORY}/${PN}.
+ Use "eselect emacs" to select an Emacs version >= 23.
+ EOF
+ elif [[ ${has_gtk} == t ]]; then
+ while read line; do ewarn "${line}"; done <<-EOF
+ Your current Emacs is compiled with GTK+. There is a long-standing bug
+ in GTK+ that prevents Emacs from recovering from X disconnects:
+ <https://bugzilla.gnome.org/show_bug.cgi?id=85715>
+ If you run Emacs as a daemon, then it is strongly recommended that you
+ compile it with the Lucid or the Motif toolkit instead, i.e. with
+ USE="athena Xaw3d -gtk -motif" or USE="motif -gtk -athena -Xaw3d".
+ EOF
+ fi
+}
+
+src_compile() { :; }
+
+src_install() {
+ newinitd emacs.rc emacs
+ newconfd emacs.conf emacs
+ exeinto /usr/libexec/emacs
+ doexe emacs-wrapper.sh emacs-stop.sh
+ elisp-site-file-install "${SITEFILE}"
+ dodoc README ChangeLog
+}
diff --git a/app-emacs/emacs-daemon/metadata.xml b/app-emacs/emacs-daemon/metadata.xml
new file mode 100644
index 000000000000..c438baf3b326
--- /dev/null
+++ b/app-emacs/emacs-daemon/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+</pkgmetadata>