summaryrefslogtreecommitdiff
path: root/app-emacs/eldev/eldev-1.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-21 19:55:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-21 19:55:00 +0000
commit427ba64bd6bcdd59a1ae9bc7c5cec0299d135413 (patch)
tree2455e3903e1b27c27a2132c1d12c86d57011d7f8 /app-emacs/eldev/eldev-1.3.1.ebuild
parent454de691f3543d47dc89cd0b137eaa9ea4640cd3 (diff)
gentoo auto-resync : 21:12:2022 - 19:55:00
Diffstat (limited to 'app-emacs/eldev/eldev-1.3.1.ebuild')
-rw-r--r--app-emacs/eldev/eldev-1.3.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-emacs/eldev/eldev-1.3.1.ebuild b/app-emacs/eldev/eldev-1.3.1.ebuild
new file mode 100644
index 000000000000..3f35959f7270
--- /dev/null
+++ b/app-emacs/eldev/eldev-1.3.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24.4
+
+inherit elisp
+
+DESCRIPTION="Emacs Lisp Development Tool"
+HOMEPAGE="https://github.com/doublep/eldev/"
+SRC_URI="https://github.com/doublep/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+DOCS=( README.adoc )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ELDEV_LOCAL="${S}" ./bin/${PN} test
+}
+
+src_install() {
+ elisp_src_install
+ dobin bin/${PN}
+
+ # NOTICE: If ELDEV_LOCAL is defined Eldev will use it
+ # to load up it's components,
+ # if it is not it will bootstrap itself from network
+ # always check if it uses installed Emacs Lisp files.
+ # Also, do not forget to run `env-update` & reopen your shell.
+ # https://github.com/doublep/eldev#influential-environment-variables
+ echo "ELDEV_LOCAL=${SITELISP}/${PN}" >> "${T}"/99${PN} || die
+ doenvd "${T}"/99${PN}
+}
+
+pkg_postinst() {
+ elisp_pkg_postinst
+
+ ewarn "Remember to run \`env-update && source /etc/profile\` if you plan"
+ ewarn "to use Eldev in a shell before logging out (or restarting"
+ ewarn "your login manager)."
+}