summaryrefslogtreecommitdiff
path: root/app-emacs/ef-themes
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-10 22:36:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-10 22:36:46 +0100
commit783da4542a9c3e0e1ec703644212707cde610679 (patch)
tree3e0cf56ac37ddf9d5fdc6ff0ced9135b1c7fc5e0 /app-emacs/ef-themes
parentd0041c590ed45bbfeae458ea926e36bc64e41dd7 (diff)
gentoo auto-resync : 10:09:2023 - 22:36:45
Diffstat (limited to 'app-emacs/ef-themes')
-rw-r--r--app-emacs/ef-themes/Manifest5
-rw-r--r--app-emacs/ef-themes/ef-themes-1.3.0.ebuild32
-rw-r--r--app-emacs/ef-themes/ef-themes-9999.ebuild32
-rw-r--r--app-emacs/ef-themes/files/50ef-themes-gentoo.el2
-rw-r--r--app-emacs/ef-themes/metadata.xml18
5 files changed, 89 insertions, 0 deletions
diff --git a/app-emacs/ef-themes/Manifest b/app-emacs/ef-themes/Manifest
new file mode 100644
index 000000000000..44faab882124
--- /dev/null
+++ b/app-emacs/ef-themes/Manifest
@@ -0,0 +1,5 @@
+AUX 50ef-themes-gentoo.el 73 BLAKE2B f9e2fbda6f0d9f8f1976231c64176fed8c0094b305739f4313b0299407dbd5a4f392ce99a49064cc6124fcca3b8828066be22b81115a3ce07ebe98a4a1a8c0fa SHA512 662243157b92cf614e5ca03d0252c832a7610f91902f70f9c4cd20e2ec0b902fbd233668c222761c1d7b12c5a990d334e300db5a3a7af8dd8142610d9bc6fc59
+DIST ef-themes-1.3.0.tar.gz 159848 BLAKE2B 141b5d1c809ef285f8bbfa6b91c60a9e6c03d5677baccf451091b9d2141a5d49f3c4a7e3f69ffdb8ebe99253ebd8cf1756f15723dae07c4a7db2b165bc38012a SHA512 85a7310f710a4e91c72d9c47fb596eeca181bf282e4cfb3d16c9e714bace4f87cb5d7d8c76d06e36cde170956d2f3dc0bfe0cde5b5332656292cc511f05e9583
+EBUILD ef-themes-1.3.0.ebuild 716 BLAKE2B 759207b8b74e069cdfd6d7a8ca742d149ce4c10c294e2d4254137b7ff3cbc07b320d2121e2d48f3e1458f19c0d6fed78fd6f95acf11f1dd231066b8f62299c52 SHA512 00d6618529925d93dcacd61bc7d3ff11ad54e73a9dc3459482b9cb256e97afeff441dbd0726af8f6b7eb8eaa8015ec53319d1607579196d90b22cb6ebb09e979
+EBUILD ef-themes-9999.ebuild 716 BLAKE2B 759207b8b74e069cdfd6d7a8ca742d149ce4c10c294e2d4254137b7ff3cbc07b320d2121e2d48f3e1458f19c0d6fed78fd6f95acf11f1dd231066b8f62299c52 SHA512 00d6618529925d93dcacd61bc7d3ff11ad54e73a9dc3459482b9cb256e97afeff441dbd0726af8f6b7eb8eaa8015ec53319d1607579196d90b22cb6ebb09e979
+MISC metadata.xml 681 BLAKE2B 0e249f93af691f703909461b09dadf4cc8d1b6f0f81053135e967358a9c7a39a4f559faf822ca752d31ca07519c0ab36dc31654dd2d994f6e0601fbad9efb8da SHA512 44762463f42adbd843de2b1ade4d6bda5deb4c1ae40bfe91f3f22fd6a14592e01554c9a640f84e01e48900161aa9a4bb26a2f844eb8f364988cd3adbed161e3e
diff --git a/app-emacs/ef-themes/ef-themes-1.3.0.ebuild b/app-emacs/ef-themes/ef-themes-1.3.0.ebuild
new file mode 100644
index 000000000000..e12280ff911b
--- /dev/null
+++ b/app-emacs/ef-themes/ef-themes-1.3.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Colourful and legible themes for GNU Emacs"
+HOMEPAGE="https://github.com/protesilaos/ef-themes/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/protesilaos/${PN}.git"
+else
+ SRC_URI="https://github.com/protesilaos/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( CHANGELOG.org README.md README.org contrast-ratios.org )
+ELISP_TEXINFO="${PN}.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-org-export-to texinfo README.org
+
+ elisp_src_compile
+ elisp-make-autoload-file
+}
diff --git a/app-emacs/ef-themes/ef-themes-9999.ebuild b/app-emacs/ef-themes/ef-themes-9999.ebuild
new file mode 100644
index 000000000000..e12280ff911b
--- /dev/null
+++ b/app-emacs/ef-themes/ef-themes-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Colourful and legible themes for GNU Emacs"
+HOMEPAGE="https://github.com/protesilaos/ef-themes/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/protesilaos/${PN}.git"
+else
+ SRC_URI="https://github.com/protesilaos/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( CHANGELOG.org README.md README.org contrast-ratios.org )
+ELISP_TEXINFO="${PN}.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-org-export-to texinfo README.org
+
+ elisp_src_compile
+ elisp-make-autoload-file
+}
diff --git a/app-emacs/ef-themes/files/50ef-themes-gentoo.el b/app-emacs/ef-themes/files/50ef-themes-gentoo.el
new file mode 100644
index 000000000000..58df6c8ef84e
--- /dev/null
+++ b/app-emacs/ef-themes/files/50ef-themes-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "ef-themes-autoloads" nil t)
diff --git a/app-emacs/ef-themes/metadata.xml b/app-emacs/ef-themes/metadata.xml
new file mode 100644
index 000000000000..26eebbc46b9e
--- /dev/null
+++ b/app-emacs/ef-themes/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ The ef-themes are a collection of light and dark themes for GNU Emacs whose
+ goal is to provide colorfulyet legible options for users who want something
+ with a bit more flair than the modus-themes.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/protesilaos/ef-themes/issues/</bugs-to>
+ <remote-id type="github">protesilaos/ef-themes</remote-id>
+ </upstream>
+</pkgmetadata>